cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6985
Views
40
Helpful
16
Replies
crench92
Beginner

ISR 4221 Guestshell Network Access

So I read that as of IOS XE 16.8.1, you can enable the guestshell with only 4G of RAM which is what our ISR 4221s have.  How do we configure this? I get the following when trying:

 

Test_host#guestshell enable
Interface will be selected if configured in app-hosting
Please wait for completion
% Error: No interface configuration for guestshell

 

The goal is to get iperf on the guestshell and talking to another iperf server.  Is this possible using Gi0/0/0 on the router with some kind of NAT?

16 REPLIES 16
gnijs
Enthusiast

Got the same error Cat9300 16.8.1a when doing "guestshell enable"

% Error: No interface configuration for guestshell

ok, so i found this (might help)

 

you need to add the following:

 

app-hosting appid guestshell
 vnic management guest-interface 0
end

 

i found this on a C9500. It seems to be automatically added on this platfrom.

But on a C9300, after an upgrade to 16.8.1a, it might be missing and hence guestshell won't start.

After adding the above, it worked.

 

So I've managed to get past this by switching around the order in Cisco's documentation and added this before enabling:

app-hosting appid guestshell

app-vnic gateway0 virtualportgroup 0 guest-interface 0

  guest-ipaddress 192.168.35.2 netmask 255.255.255.0

app-default-gateway 192.168.35.1 guest-interface 1

app-resource profile custom

  cpu 800

  memory 256

 

But now i get the following:

HUWANOR1TLHS0164NR01#guestshell enable

Interface will be selected if configured in app-hosting

Please wait for completion

% Error: Application ext2 disk is missing! : /bootflash/iox/repo/guestshell/extract_archive/guestshell.ext2

There any update on trying to find out why this error is happening?

Is there any external media installed such as a USB disk? I found it was creating some directories on the usbflash0: by default and seemed to have a problem finding them later. I removed the USB stick, destroyed the guestshell and disabled iox, re-enabled iox and then was able to get guestshell to enable properly.

I wanted to post this for anyone with 9300 switches for Guest shell to work:

this worked for me.

 

Enable Right-to-use license for app-hosting (this is required) and reboot switch

 

  • Switch(config)#license right-to-use activate addon dna-advantage subscription acceptEULA
  • Switch# ReloadAdd smart License for App-Hosting.

Add smart License for App-Hosting.

 

  • Switch(config)#license boot level network-advantage addon dna-advantage

Configure a management Interface for "guestshell enable" mode:

 

  • Switch(config-app-hosting)#vnic management guest-interface 0 guest-ipaddress <IPAddress> netmask <subnetmaskIP> gateway <IPAddress> name <nameserverIPaddress>

Enable Guest shell:

  • switch#guestshell enable

Interface will be selected if configured in app-hosting

Please wait for completion

guestshell activated successfully

Current state is: ACTIVATED

guestshell started successfully

Current state is: RUNNING

Guestshell enabled successfully

 

Verify guestshell is in running state.

Switchk#show app-hosting list

App id                           State

------------------------------------------------------

guestshell                       RUNNING

 

Now go try guestshell command:

Switch#guestshell
[guestshell@guestshell ~]$

 

I hope this helps anyone....

This means your install is incomplete or corrupted..., need to redo

vstepanov
Beginner

the same problem on catalyst 9300 IOS-XE 16.9.2. At the same time it works on catalyst 9300 IOS-XE 16.6.1

Richard Principe
Beginner

UBU-01#guestshell enable
Interface will be selected if configured in app-hosting
Please wait for completion
% Error: Error while creating container XML error: Domain interface: Missing required gateway attribute in route definition

 

Hi Richard,

I will be happy to help you. Have you resolved this problem? in case you don't, please share with me your current configuration.

Thank you.
Eduardo

Hi,

 

I have same problem -

 

% Error: Error while creating domain XML error: Domain interface: Missing required gateway attribute inroute definition.

 

 

C4331-1#sh app-hosting list
App id State
------------------------------------------------------
guestshell DEPLOYED

 

Did you find any workaround for the same.

 

Thanks,

Amit

configure gateway attribute on
conf ter


vnic gateway1 virtualportgroup 0 guest-interface 0 ---> blah blah blah

csr1000v#guestshell enable
Interface will be selected if configured in app-hosting
Please wait for completion
% Error: Error while creating container XML error: Domain interface: Missing required gateway attribute in route definition

I have the same problem,how to solve?
csr1000v#guestshell enable
Interface will be selected if configured in app-hosting
Please wait for completion
% Error: Error while creating container XML error: Domain interface: Missing required gateway attribute in route definition