cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
502
Views
0
Helpful
12
Replies
Beginner

ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Hi, i am using ISR4321/K9 router with 2 WAN and 1 LAN cards. Two ISPs are connected to WAN and the LAN side is connected to Firewall. ISP 1 is 50Mbps and ISP 2 is 80Mbps. after running Platform hardware throughput level to change to 100Mbps, i lost internet connectivity from ISP 1. but ISP2 is working find and i get full bandwidth.

please help.

router#sh int gi0/0/0
GigabitEthernet0/0/0 is up, line protocol is up
Hardware is ISR4321-2x1GE, address is xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Description: *****CONNECTEED-TO-ISP1*****
Internet address is x.x.x.x/30
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full Duplex, 100Mbps, link type is force-up, media type is RJ45
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:25:27, output 00:00:21, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 1000 bits/sec, 1 packets/sec
71941 packets input, 37749964 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
65138 packets output, 23549675 bytes, 0 underruns
0 output errors, 0 collisions, 9 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
7 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

router#sh int gi0/0/1
GigabitEthernet0/0/1 is up, line protocol is up
Hardware is ISR4321-2x1GE, address is xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Description: *****CONNECTEED-TO-ISP2*****
Internet address is x.x.x.x/30
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full Duplex, 1000Mbps, link type is auto, media type is RJ45
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:07:35, output 00:00:15, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 6564
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 4542000 bits/sec, 943 packets/sec
5 minute output rate 2079000 bits/sec, 782 packets/sec
12628686 packets input, 13247011094 bytes, 0 no buffer
Received 4 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
7333413 packets output, 2044815394 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

Everyone's tags (1)
12 REPLIES 12
VIP Advisor

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Can you post full configuration and routing information ?

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

ISP1 and ISP2 are connected to Router and LAN side is connected to firewall.

ISP1 = 50 Mb

ISP2 = 80 Mb

now i get only 50 Mb on both ports. after running the throughput level command to change the level to 100 Mbps, i am not getting internet from ISP1 port.

let me know if you need more information. 

 

router#sh run
Building configuration...


Current configuration : 6911 bytes
!
! Last configuration change at 00:56:39 IST Thu Nov 1 2018 by 
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
platform hardware throughput level 100000
!
hostname router
!
boot-start-marker
boot system bootflash:isr4300-universalk9.03.16.02.S.155-3.S2-ext.SPA.bin
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
no logging console
enable password 7 
!
no aaa new-model
clock timezone IST 5 30
!
!
!
!
!
!
!
!
!
!
!

 

no ip domain lookup
ip domain name 
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
license udi pid ISR4321/K9 sn FDO204715WD
!
spanning-tree extend system-id
!
username privilege 15 password 7 
!
redundancy
mode none
!
!
!
!
!
vlan internal allocation policy ascending
!
track 10 ip sla 1 reachability
delay down 1 up 2
!
track 20 ip sla 2 reachability
delay down 2 up 1
!
track 30 ip sla 3 reachability
!
track 40 ip sla 4 reachability
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
description *****CONNECTEED-TO-ISP1*****
bandwidth 1000000
ip address 115.110.123.206 255.255.255.252
ip nat outside
media-type rj45
speed 100
no negotiation auto
!
interface GigabitEthernet0/0/1
description *****CONNECTEED-TO-ISP2*****
ip address 182.75.191.226 255.255.255.252
ip nat outside
negotiation auto
!
interface GigabitEthernet0/1/0
description ****CoNNECTED to LAN***
ip address 182.72.178.227 255.255.255.240
ip nat inside
ip policy route-map PBR
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source route-map ASA-NAT interface GigabitEthernet0/0/0 overload
ip nat inside source route-map ISP1 interface GigabitEthernet0/0/0 overload
ip nat inside source route-map ISP2 interface GigabitEthernet0/0/1 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 115.110.123.205 track 10
ip route 0.0.0.0 0.0.0.0 182.75.191.225 track 20
ip route 8.8.8.8 255.255.255.255 115.110.123.205 track 30
ip route 8.8.8.8 255.255.255.255 182.75.191.225 track 40
ip route 10.10.11.0 255.255.255.0 182.72.178.226
ip route 10.10.12.0 255.255.255.0 182.72.178.226
ip route 10.10.13.0 255.255.255.0 182.72.178.226
ip route 10.10.14.0 255.255.255.0 182.72.178.226
ip route 10.10.15.0 255.255.255.0 182.72.178.226
ip route 10.10.16.0 255.255.255.0 182.72.178.226
ip route 10.10.17.0 255.255.255.0 182.72.178.226
ip route 10.10.18.0 255.255.255.0 182.72.178.226
ip route 10.10.19.0 255.255.255.0 182.72.178.226
ip route 10.10.20.0 255.255.255.0 182.72.178.226
ip route 10.10.21.0 255.255.255.0 182.72.178.226
ip route 10.10.22.0 255.255.255.0 182.72.178.226
ip route 10.20.10.0 255.255.255.0 182.72.178.226
ip route 10.20.11.0 255.255.255.0 182.72.178.226
ip route 10.20.12.0 255.255.255.0 182.72.178.226
ip route 10.30.10.0 255.255.255.0 182.72.178.226
ip route 192.168.1.0 255.255.255.0 182.72.178.226
ip route 192.168.2.0 255.255.255.0 182.72.178.226
ip route 192.208.240.34 255.255.255.255 115.110.123.205
ip ssh version 2
!
!
ip access-list extended ISP-NAT
deny ip 10.10.0.0 0.0.255.255 192.168.0.0 0.0.255.255
deny ip 10.20.0.0 0.0.255.255 192.168.0.0 0.0.255.255
deny ip 192.168.168.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip 10.10.11.0 0.0.0.255 any
permit ip 10.10.12.0 0.0.0.255 any
permit ip 10.10.13.0 0.0.0.255 any
permit ip 10.10.14.0 0.0.0.255 any
permit ip 10.10.15.0 0.0.0.255 any
permit ip 10.10.16.0 0.0.0.255 any
permit ip 10.20.10.0 0.0.0.255 any
permit ip 10.20.11.0 0.0.0.255 any
permit ip 10.20.12.0 0.0.0.255 any
permit ip 10.20.13.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
deny ip 10.30.0.0 0.0.255.255 192.168.0.0 0.0.255.255
permit ip 10.10.17.0 0.0.0.255 any
permit ip 10.10.18.0 0.0.0.255 any
permit ip 10.10.19.0 0.0.0.255 any
permit ip 10.10.20.0 0.0.0.255 any
permit ip 10.30.10.0 0.0.0.255 any
permit ip 10.10.21.0 0.0.0.255 any
permit ip 10.10.22.0 0.0.0.255 any
deny ip 10.10.0.0 0.0.255.255 10.122.0.0 0.0.255.255
deny ip 10.10.0.0 0.0.255.255 10.45.0.0 0.0.255.255
ip access-list extended asa-nat
permit ip host 182.72.178.226 host 192.208.240.34
!
ip sla 1
icmp-echo 8.8.8.8 source-ip 115.110.123.206
threshold 500
timeout 500
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 8.8.8.8 source-ip 182.75.191.226
threshold 500
timeout 500
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-echo 115.110.123.205 source-ip 115.110.123.206
threshold 500
timeout 500
ip sla schedule 3 life forever start-time now
ip sla 4
icmp-echo 182.75.191.225 source-ip 182.75.191.226
threshold 500
timeout 500
ip sla schedule 4 life forever start-time now
access-list 101 permit ip 10.20.11.0 0.0.0.255 any
access-list 101 permit ip 10.10.13.0 0.0.0.255 any
access-list 101 permit ip 10.10.12.0 0.0.0.255 any
access-list 101 permit ip 10.10.17.0 0.0.0.255 any
access-list 101 permit ip 10.10.18.0 0.0.0.255 any
access-list 102 permit ip 10.20.10.0 0.0.0.255 any
access-list 102 permit ip 10.20.12.0 0.0.0.255 any
access-list 102 permit ip 10.10.11.0 0.0.0.255 any
access-list 102 permit ip 10.10.14.0 0.0.0.255 any
access-list 102 permit ip 10.10.15.0 0.0.0.255 any
access-list 102 permit ip 10.10.16.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 10.10.19.0 0.0.0.255 any
access-list 102 permit ip 10.10.20.0 0.0.0.255 any
access-list 102 permit ip 10.30.10.0 0.0.0.255 any
access-list 102 permit ip 10.10.21.0 0.0.0.255 any
access-list 102 permit ip 10.10.22.0 0.0.0.255 any
access-list 120 permit ip 10.10.17.0 0.0.0.255 192.168.20.0 0.0.1.255
!
route-map ASA-NAT permit 10
match ip address asa-nat
match interface GigabitEthernet0/0/0
!
route-map PBR permit 10
match ip address 101
match interface GigabitEthernet0/0/0
set ip next-hop verify-availability 115.110.123.205 1 track 10
!
route-map PBR permit 20
match ip address 102
match interface GigabitEthernet0/0/1
set ip next-hop verify-availability 182.75.191.225 1 track 20
!
route-map ISP2 permit 10
match ip address ISP-NAT
match interface GigabitEthernet0/0/1
!
route-map ISP1 permit 10
match ip address ISP-NAT
match interface GigabitEthernet0/0/0
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 
login local
transport input ssh
transport output ssh
line vty 5 15
password 7 
login local
transport input ssh
transport output ssh
!
ntp server pool.ntp.org
!
end

router#

Participant

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Please remove your "line vty" and "enable password" sections or hashes if sensitive.  You are using old type 7 password security, which means we can easily decrypt your passwords in seconds.  There are a lot of things in that config that can be greatly improved, but just to start, let's look at licensing.  To enable 100Mbps on a 4321, you must own the "throughput" license or be on the eval period (with time remaining).  Try this command:    sh license all | b throughput     then send us the output.  

Beginner

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

i have not copied the right hash. i made changes which are vulnerable before pasting. thanks for letting me know.

please find the details for sh license command below:

Router#sh license all | b throughput
StoreIndex: 2 Feature: throughput Version: 1.0
License Type: Permanent
License State: Active, Not in Use
License Count: Non-Counted
License Priority: Medium
License Store: Built-In License Storage
StoreIndex: 0 Feature: appxk9 Version: 1.0
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: Non-Counted
License Priority: None
StoreIndex: 1 Feature: uck9 Version: 1.0
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: Non-Counted
License Priority: None
StoreIndex: 2 Feature: securityk9 Version: 1.0
License Type: EvalRightToUse
License State: Inactive
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: Non-Counted
License Priority: None
StoreIndex: 3 Feature: FoundationSuiteK9 Version: 1.0
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: Non-Counted
License Priority: None
StoreIndex: 4 Feature: AdvUCSuiteK9 Version: 1.0
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: Non-Counted
License Priority: None
StoreIndex: 5 Feature: cme-srst Version: 1.0
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: 0/0 (In-use/Violation)
License Priority: None
StoreIndex: 6 Feature: throughput Version: 1.0
License Type: EvalRightToUse
License State: Inactive
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
Period used: 0 minute 0 second
License Count: Non-Counted
License Priority: None

Participant

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Interesting that we see:

 

Router#sh license all | b throughput
StoreIndex: 2 Feature: throughput Version: 1.0
License Type: Permanent
License State: Active, Not in Use   <--

 

Did you reboot after applying the throughput command, as required?

 

Beginner

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

i had to remove the command as ISP1 port is not working after reboot.

 

Q1: Throughput command - is it an aggregate speed for all ports in the router or for each port i get 100 Mbps?

Q2: if i remove the commands suggested by another techy, what will happen to my policy routing?

Q3: Does the actual issues gets solved?

VIP Mentor

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Hello,

 

with your current configuration, only one ISP connection is active at the same time. If you want both to be active at the same time, you need to remove the 'track' keywords from the static routes...

 

So it's either (important parts marked in bold):

 

Current configuration : 6911 bytes
!
! Last configuration change at 00:56:39 IST Thu Nov 1 2018 by itadmin
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
platform hardware throughput level 100000
!
hostname router
!
boot-start-marker
boot system bootflash:isr4300-universalk9.03.16.02.S.155-3.S2-ext.SPA.bin
boot-end-marker
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
no logging console
enable password 7 00211F4714080225521D18
!
no aaa new-model
clock timezone IST 5 30
!
no ip domain lookup
ip domain name ispace.local
!
subscriber templating
!
multilink bundle-name authenticated
!
license udi pid ISR4321/K9 sn FDO204715WD
!
spanning-tree extend system-id
!
username itadmin privilege 15 password 7 02231A1B5506021C0D584F
!
redundancy
mode none
!
vlan internal allocation policy ascending
!
track 10 ip sla 1 reachability
delay down 1 up 2
!
track 20 ip sla 2 reachability
delay down 2 up 1
!
interface GigabitEthernet0/0/0
description *****CONNECTEED-TO-ISP1*****
bandwidth 1000000
ip address 115.110.123.206 255.255.255.252
ip nat outside
media-type rj45
speed 100
no negotiation auto
!
interface GigabitEthernet0/0/1
description *****CONNECTEED-TO-ISP2*****
ip address 182.75.191.226 255.255.255.252
ip nat outside
negotiation auto
!
interface GigabitEthernet0/1/0
description ****CoNNECTED to LAN***
ip address 182.72.178.227 255.255.255.240
ip nat inside
ip policy route-map PBR
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
--> no ip nat inside source route-map ASA-NAT interface GigabitEthernet0/0/0 overload
ip nat inside source route-map ISP1 interface GigabitEthernet0/0/0 overload
ip nat inside source route-map ISP2 interface GigabitEthernet0/0/1 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 115.110.123.205 track 10
ip route 0.0.0.0 0.0.0.0 182.75.191.225 10
ip route 8.8.8.8 255.255.255.255 115.110.123.205 track 30
ip route 8.8.8.8 255.255.255.255 182.75.191.225 track 40
ip route 10.10.11.0 255.255.255.0 182.72.178.226
ip route 10.10.12.0 255.255.255.0 182.72.178.226
ip route 10.10.13.0 255.255.255.0 182.72.178.226
ip route 10.10.14.0 255.255.255.0 182.72.178.226
ip route 10.10.15.0 255.255.255.0 182.72.178.226
ip route 10.10.16.0 255.255.255.0 182.72.178.226
ip route 10.10.17.0 255.255.255.0 182.72.178.226
ip route 10.10.18.0 255.255.255.0 182.72.178.226
ip route 10.10.19.0 255.255.255.0 182.72.178.226
ip route 10.10.20.0 255.255.255.0 182.72.178.226
ip route 10.10.21.0 255.255.255.0 182.72.178.226
ip route 10.10.22.0 255.255.255.0 182.72.178.226
ip route 10.20.10.0 255.255.255.0 182.72.178.226
ip route 10.20.11.0 255.255.255.0 182.72.178.226
ip route 10.20.12.0 255.255.255.0 182.72.178.226
ip route 10.30.10.0 255.255.255.0 182.72.178.226
ip route 192.168.1.0 255.255.255.0 182.72.178.226
ip route 192.168.2.0 255.255.255.0 182.72.178.226
ip route 192.208.240.34 255.255.255.255 115.110.123.205
ip ssh version 2
!
ip access-list extended ISP-NAT
deny ip 10.10.0.0 0.0.255.255 192.168.0.0 0.0.255.255
deny ip 10.20.0.0 0.0.255.255 192.168.0.0 0.0.255.255
deny ip 192.168.168.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip 10.10.11.0 0.0.0.255 any
permit ip 10.10.12.0 0.0.0.255 any
permit ip 10.10.13.0 0.0.0.255 any
permit ip 10.10.14.0 0.0.0.255 any
permit ip 10.10.15.0 0.0.0.255 any
permit ip 10.10.16.0 0.0.0.255 any
permit ip 10.20.10.0 0.0.0.255 any
permit ip 10.20.11.0 0.0.0.255 any
permit ip 10.20.12.0 0.0.0.255 any
permit ip 10.20.13.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
deny ip 10.30.0.0 0.0.255.255 192.168.0.0 0.0.255.255
permit ip 10.10.17.0 0.0.0.255 any
permit ip 10.10.18.0 0.0.0.255 any
permit ip 10.10.19.0 0.0.0.255 any
permit ip 10.10.20.0 0.0.0.255 any
permit ip 10.30.10.0 0.0.0.255 any
permit ip 10.10.21.0 0.0.0.255 any
permit ip 10.10.22.0 0.0.0.255 any
deny ip 10.10.0.0 0.0.255.255 10.122.0.0 0.0.255.255
deny ip 10.10.0.0 0.0.255.255 10.45.0.0 0.0.255.255
ip access-list extended asa-nat
permit ip host 182.72.178.226 host 192.208.240.34
!
ip sla 1
icmp-echo 8.8.8.8 source-ip 115.110.123.206
threshold 500
timeout 500
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 8.8.8.8 source-ip 182.75.191.226
threshold 500
timeout 500
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-echo 115.110.123.205 source-ip 115.110.123.206
threshold 500
timeout 500
ip sla schedule 3 life forever start-time now
ip sla 4
icmp-echo 182.75.191.225 source-ip 182.75.191.226
threshold 500
timeout 500
ip sla schedule 4 life forever start-time now
access-list 101 permit ip 10.20.11.0 0.0.0.255 any
access-list 101 permit ip 10.10.13.0 0.0.0.255 any
access-list 101 permit ip 10.10.12.0 0.0.0.255 any
access-list 101 permit ip 10.10.17.0 0.0.0.255 any
access-list 101 permit ip 10.10.18.0 0.0.0.255 any
access-list 102 permit ip 10.20.10.0 0.0.0.255 any
access-list 102 permit ip 10.20.12.0 0.0.0.255 any
access-list 102 permit ip 10.10.11.0 0.0.0.255 any
access-list 102 permit ip 10.10.14.0 0.0.0.255 any
access-list 102 permit ip 10.10.15.0 0.0.0.255 any
access-list 102 permit ip 10.10.16.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 10.10.19.0 0.0.0.255 any
access-list 102 permit ip 10.10.20.0 0.0.0.255 any
access-list 102 permit ip 10.30.10.0 0.0.0.255 any
access-list 102 permit ip 10.10.21.0 0.0.0.255 any
access-list 102 permit ip 10.10.22.0 0.0.0.255 any
access-list 120 permit ip 10.10.17.0 0.0.0.255 192.168.20.0 0.0.1.255
!
route-map ASA-NAT permit 10
match ip address asa-nat
match interface GigabitEthernet0/0/0
!
route-map PBR permit 10
match ip address 101
match interface GigabitEthernet0/0/0
set ip next-hop verify-availability 115.110.123.205 1 track 10
!
route-map PBR permit 20
match ip address 102
match interface GigabitEthernet0/0/1
set ip next-hop verify-availability 182.75.191.225 1 track 20
!
route-map ISP2 permit 10
match ip address ISP-NAT
match interface GigabitEthernet0/0/1
!
route-map ISP1 permit 10
match ip address ISP-NAT
match interface GigabitEthernet0/0/0
!
control-plane
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 052E0A4E31472A49464644
login local
transport input ssh
transport output ssh
line vty 5 15
password 7 0804400F19A0C3442485D52
login local
transport input ssh
transport output ssh
!
ntp server pool.ntp.org
!
end

 

---------------------

 

or

 

---------------------

 

Current configuration : 6911 bytes
!
! Last configuration change at 00:56:39 IST Thu Nov 1 2018 by itadmin
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
platform hardware throughput level 100000
!
hostname router
!
boot-start-marker
boot system bootflash:isr4300-universalk9.03.16.02.S.155-3.S2-ext.SPA.bin
boot-end-marker
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
no logging console
enable password 7 00211F4714080225521D18
!
no aaa new-model
clock timezone IST 5 30
!
no ip domain lookup
ip domain name ispace.local
!
subscriber templating
!
multilink bundle-name authenticated
!
license udi pid ISR4321/K9 sn FDO204715WD
!
spanning-tree extend system-id
!
username itadmin privilege 15 password 7 02231A1B5506021C0D584F
!
redundancy
mode none
!
vlan internal allocation policy ascending
!
track 10 ip sla 1 reachability
delay down 1 up 2
!
track 20 ip sla 2 reachability
delay down 2 up 1
!
interface GigabitEthernet0/0/0
description *****CONNECTEED-TO-ISP1*****
bandwidth 1000000
ip address 115.110.123.206 255.255.255.252
ip nat outside
media-type rj45
speed 100
no negotiation auto
!
interface GigabitEthernet0/0/1
description *****CONNECTEED-TO-ISP2*****
ip address 182.75.191.226 255.255.255.252
ip nat outside
negotiation auto
!
interface GigabitEthernet0/1/0
description ****CoNNECTED to LAN***
ip address 182.72.178.227 255.255.255.240
ip nat inside
ip policy route-map PBR
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
--> no ip nat inside source route-map ASA-NAT interface GigabitEthernet0/0/0 overload
ip nat inside source route-map ISP1 interface GigabitEthernet0/0/0 overload
ip nat inside source route-map ISP2 interface GigabitEthernet0/0/1 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 115.110.123.205 
ip route 0.0.0.0 0.0.0.0 182.75.191.225
ip route 8.8.8.8 255.255.255.255 115.110.123.205 track 30
ip route 8.8.8.8 255.255.255.255 182.75.191.225 track 40
ip route 10.10.11.0 255.255.255.0 182.72.178.226
ip route 10.10.12.0 255.255.255.0 182.72.178.226
ip route 10.10.13.0 255.255.255.0 182.72.178.226
ip route 10.10.14.0 255.255.255.0 182.72.178.226
ip route 10.10.15.0 255.255.255.0 182.72.178.226
ip route 10.10.16.0 255.255.255.0 182.72.178.226
ip route 10.10.17.0 255.255.255.0 182.72.178.226
ip route 10.10.18.0 255.255.255.0 182.72.178.226
ip route 10.10.19.0 255.255.255.0 182.72.178.226
ip route 10.10.20.0 255.255.255.0 182.72.178.226
ip route 10.10.21.0 255.255.255.0 182.72.178.226
ip route 10.10.22.0 255.255.255.0 182.72.178.226
ip route 10.20.10.0 255.255.255.0 182.72.178.226
ip route 10.20.11.0 255.255.255.0 182.72.178.226
ip route 10.20.12.0 255.255.255.0 182.72.178.226
ip route 10.30.10.0 255.255.255.0 182.72.178.226
ip route 192.168.1.0 255.255.255.0 182.72.178.226
ip route 192.168.2.0 255.255.255.0 182.72.178.226
ip route 192.208.240.34 255.255.255.255 115.110.123.205
ip ssh version 2
!
ip access-list extended ISP-NAT
deny ip 10.10.0.0 0.0.255.255 192.168.0.0 0.0.255.255
deny ip 10.20.0.0 0.0.255.255 192.168.0.0 0.0.255.255
deny ip 192.168.168.0 0.0.0.255 192.168.0.0 0.0.255.255
permit ip 10.10.11.0 0.0.0.255 any
permit ip 10.10.12.0 0.0.0.255 any
permit ip 10.10.13.0 0.0.0.255 any
permit ip 10.10.14.0 0.0.0.255 any
permit ip 10.10.15.0 0.0.0.255 any
permit ip 10.10.16.0 0.0.0.255 any
permit ip 10.20.10.0 0.0.0.255 any
permit ip 10.20.11.0 0.0.0.255 any
permit ip 10.20.12.0 0.0.0.255 any
permit ip 10.20.13.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
deny ip 10.30.0.0 0.0.255.255 192.168.0.0 0.0.255.255
permit ip 10.10.17.0 0.0.0.255 any
permit ip 10.10.18.0 0.0.0.255 any
permit ip 10.10.19.0 0.0.0.255 any
permit ip 10.10.20.0 0.0.0.255 any
permit ip 10.30.10.0 0.0.0.255 any
permit ip 10.10.21.0 0.0.0.255 any
permit ip 10.10.22.0 0.0.0.255 any
deny ip 10.10.0.0 0.0.255.255 10.122.0.0 0.0.255.255
deny ip 10.10.0.0 0.0.255.255 10.45.0.0 0.0.255.255
ip access-list extended asa-nat
permit ip host 182.72.178.226 host 192.208.240.34
!
ip sla 1
icmp-echo 8.8.8.8 source-ip 115.110.123.206
threshold 500
timeout 500
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 8.8.8.8 source-ip 182.75.191.226
threshold 500
timeout 500
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-echo 115.110.123.205 source-ip 115.110.123.206
threshold 500
timeout 500
ip sla schedule 3 life forever start-time now
ip sla 4
icmp-echo 182.75.191.225 source-ip 182.75.191.226
threshold 500
timeout 500
ip sla schedule 4 life forever start-time now
access-list 101 permit ip 10.20.11.0 0.0.0.255 any
access-list 101 permit ip 10.10.13.0 0.0.0.255 any
access-list 101 permit ip 10.10.12.0 0.0.0.255 any
access-list 101 permit ip 10.10.17.0 0.0.0.255 any
access-list 101 permit ip 10.10.18.0 0.0.0.255 any
access-list 102 permit ip 10.20.10.0 0.0.0.255 any
access-list 102 permit ip 10.20.12.0 0.0.0.255 any
access-list 102 permit ip 10.10.11.0 0.0.0.255 any
access-list 102 permit ip 10.10.14.0 0.0.0.255 any
access-list 102 permit ip 10.10.15.0 0.0.0.255 any
access-list 102 permit ip 10.10.16.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 10.10.19.0 0.0.0.255 any
access-list 102 permit ip 10.10.20.0 0.0.0.255 any
access-list 102 permit ip 10.30.10.0 0.0.0.255 any
access-list 102 permit ip 10.10.21.0 0.0.0.255 any
access-list 102 permit ip 10.10.22.0 0.0.0.255 any
access-list 120 permit ip 10.10.17.0 0.0.0.255 192.168.20.0 0.0.1.255
!
route-map ASA-NAT permit 10
match ip address asa-nat
match interface GigabitEthernet0/0/0
!
route-map PBR permit 10
match ip address 101
match interface GigabitEthernet0/0/0
set ip next-hop verify-availability 115.110.123.205 1 track 10
!
route-map PBR permit 20
match ip address 102
match interface GigabitEthernet0/0/1
set ip next-hop verify-availability 182.75.191.225 1 track 20
!
route-map ISP2 permit 10
match ip address ISP-NAT
match interface GigabitEthernet0/0/1
!
route-map ISP1 permit 10
match ip address ISP-NAT
match interface GigabitEthernet0/0/0
!
control-plane
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
password 7 052E0A4E31472A49464644
login local
transport input ssh
transport output ssh
line vty 5 15
password 7 0804400F19A0C3442485D52
login local
transport input ssh
transport output ssh
!
ntp server pool.ntp.org
!
end

Beginner

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

we have configured policy based routing. hence both the ISPs are active.

Fwe IP subnets get internet from ISP1 and few from ISP2. it is working. 

Rising star

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

!
route-map PBR permit 10
match ip address 101
no match interface GigabitEthernet0/0/0
set ip next-hop verify-availability 115.110.123.205 1 track 10
!
route-map PBR permit 20
match ip address 102
no match interface GigabitEthernet0/0/1
set ip next-hop verify-availability 182.75.191.225 1 track 20
!
!
route-map ISP2 permit 10
no match ip address ISP-NAT
match ip address 102

match interface GigabitEthernet0/0/1
!
route-map ISP1 permit 10
no match ip address ISP-NAT
match ip address 101

match interface GigabitEthernet0/0/0
!

 

Beginner

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Request you to please elaborate what am i supposed to do. i am not an expert, seeking help.

Do i need to remove those commands which are written in bold?

Rising star

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

you can just copy&paste

Highlighted
Participant

Re: ISR4321 No internet on Gi0/0/0 after running Platform hardware throughput level to 100Mbps

Have you remedied the active, not in use license issue:

 

Router#sh license all | b throughput
StoreIndex: 2 Feature: throughput Version: 1.0
License Type: Permanent
License State: Active, Not in Use   <--

 

Did you reboot after applying the throughput command, as required?

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards