cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

154
Views
0
Helpful
0
Replies
Highlighted
Beginner

ISR4331 VPLS WITH QINQ PROBLEM

Hi,

 

I have problems with a vpls configuration. As you can see from the attached diagram, I  need to stack some vlan in a s-vlan, and receive the same vlas at the other end of the link, however, I can' reach the other end via ping,

The xconnect is up and everything looks okay but no data transfer is possible (when i configure a single vlan i can reach the other end)

I am showing the summarised and importa configuration also the version of ios i am using

 

===============================

SW-1 CONFIGURATION

!
interface Vlan100
ip address 192.168.1.2 255.255.255.0
.
.
.
!
interface Vlan600
ip address 192.168.6.2 255.255.255.0
!

!

interface GigabitEthernet0/24
description TO-ISR4000
switchport trunk allowed vlan 100,200,300,400,500,600
switchport mode trunk

 

=======

ISR4331 CONFIGURATION

!
interface pseudowire1000
encapsulation mpls
neighbor 10.206.2.252 1000
!
!
interface GigabitEthernet0/0/1
description TO-SW3600
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1.200
encapsulation dot1Q 200 second-dot1q any
!

l2vpn xconnect context PRUEBA
member pseudowire1000
member GigabitEthernet0/0/1.200
!

========================================================================

SW-2 CONFIGURATION

!
interface Vlan100
ip address 192.168.1.1 255.255.255.0
.
.
.
!
interface Vlan600
ip address 192.168.6.1 255.255.255.0
!

!

interface GigabitEthernet0/24
description TO-ISR4000
switchport trunk allowed vlan 100,200,300,400,500,600
switchport mode trunk

 

=======

ISR4331 CONFIGURATION

!
interface pseudowire1000
encapsulation mpls
neighbor 10.206.2.251 1000
!
!
interface GigabitEthernet0/0/1
description TO-SW3600
no ip address
negotiation auto
!
interface GigabitEthernet0/0/1.200
encapsulation dot1Q 200 second-dot1q any
!

l2vpn xconnect context PRUEBA
member pseudowire1000
member GigabitEthernet0/0/1.200
!

=============================================================================================

 

ISR4000-2# sh xcon all
Legend: XC ST=Xconnect State S1=Segment1 State S2=Segment2 State
UP=Up DN=Down AD=Admin Down IA=Inactive
SB=Standby HS=Hot Standby RV=Recovering NH=No Hardware

XC ST Segment 1 S1 Segment 2 S2
------+---------------------------------+--+---------------------------------+--
UP pri mpls 10.206.2.254:1000 UP ac Gi0/0/1.200:268435656(Eth V UP
ISR4000-2#

 

====================================

 

ISR4000-2#sh ver
Cisco IOS XE Software, Version 16.09.04
Cisco IOS Software [Fuji], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.9.4, RELEASE SOFTWARE (fc2)

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here