cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
254
Views
0
Helpful
2
Replies
Highlighted
Enthusiast

L2TPv3 on dot1q subinterface with different vlan numbers

I am testing a setup that I have an L2TPv3 tunnel between two routers and the pseudowires are configured on the dot1q sub-interfaces. 

1. It is working with both ends use the same VLAN number (which is 2 in my virl lab)

2. It is working with both ends using the different VLAN number (2 on the left side and 22 on the right side). The switch would complain about the inconsistent VLAN in the STP errors, but with bpdufilter enabled, the ping will work.

3. It is not working with the different VLAN numbers and both VLAN numbers are configured as the "Native VLAN" on each side.

 

My topology is like

sw1 Gi0/1 ---(trunk)--- Gi0/3 rt1 --- rt3 Gi0/3 ---(trunk)--- sw2 Gi0/1

 

Here is my config

sw1:

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
!
interface Vlan2
 ip address 2.2.2.1 255.255.255.0
!

rt1:

pseudowire-class psw
 encapsulation l2tpv3
 ip local interface Loopback0
!
interface GigabitEthernet0/3.2
 encapsulation dot1Q 2 native
 no cdp enable
 xconnect 192.168.0.3 2 encapsulation l2tpv3 pw-class psw
end
! 192.168.0.3 is rt3's loopback IP

rt3:

pseudowire-class psw
 encapsulation l2tpv3
 ip local interface Loopback0
!
interface GigabitEthernet0/3.22
 encapsulation dot1Q 22 native
 no cdp enable
 xconnect 192.168.0.1 2 encapsulation l2tpv3 pw-class psw
! 192.168.0.1 is the rt1's loopback

sw2: 

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 22
 switchport mode trunk
!
interface Vlan22
 ip address 2.2.2.2 255.255.255.0

The pseudowire is up on both ends

rt1:

iosv-1#sh xconnect interface g0/3.2 detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi0/3.2:2(Eth VLAN)          UP l2tp 192.168.0.3:2                UP
            Interworking: vlan                   Session ID: 3656408470
                                                 Tunnel ID: 3142981728
                                                 Protocol State: UP
                                                 Remote Circuit State: UP
                                                 pw-class: psw

rt2:

iosv-3#sh xconnect interface g0/3.22 detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi0/3.22:22(Eth VLAN)        UP l2tp 192.168.0.1:2                UP
            Interworking: vlan                   Session ID: 687488009
                                                 Tunnel ID: 1088534909
                                                 Protocol State: UP
                                                 Remote Circuit State: UP
                                                 pw-class: psw

However, the ping between switch 1 and 2 between their vlan IPs are not working. The STP packets are not received on either end too... Is there a limitation with this setup? Thanks

 

 

Everyone's tags (2)
2 REPLIES 2
Highlighted
Enthusiast

Re: L2TPv3 on dot1q subinterface with different vlan numbers

I changed the vlan numbers to be the same on both ends but kept them both being the "native" vlan and the connection is still broken... Is L2TPv3 just don't like a connection with the vlan tag?

Highlighted
Enthusiast

Re: L2TPv3 on dot1q subinterface with different vlan numbers

Got confirmation from the Cisco TAC engineer

 

  • Untagged packets (native VLAN) forwarding for xconnect that is configured on the dot1q subinterface is not supported

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/wan_lserv/configuration/xe-16/wan-lserv-xe-16-book/wan-l2-tun-pro-v3-xe.html#GUID-023CAAE3-1F8D-41FE-91F1-8CEF0F6023A6

 

Kind of sad and wondering why... Now I have to think about how to do different VLANs without breaking STP...