cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1505
Views
15
Helpful
5
Replies

Loopback not pinging

himanshudwivedi
Level 1
Level 1

BGP ISSUE.PNG

 

 

Please check the network diagram. I have configured BGP on all the routers are R1 and R3 & R3 and R4 are the neighbor of each other.

Configured Loopback in all the routers and advertise in BGP. When I am executing command sh ip bgp , getting Routes to R1 loopback, but I am unable to ping the loopback ip. Please help me.

 

Below is the output

 

Capture.PNG

2 Accepted Solutions

Accepted Solutions

Hello,

 

post the full running configs of all three routers. Are you peering with the loopbacks or with the physical interface addresses ?

 

The below configs would be an option to have full reachability:

 

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description Link to R3
ip address 20.0.0.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 1
bgp router-id 1.1.1.1
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 20.0.0.0 mask 255.255.255.252
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 20.0.0.2

 

R3


interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
description Link to R1
ip address 20.0.0.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
description Link to R4
ip address 30.0.0.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 2
bgp router-id 2.2.2.2
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 20.0.0.0 mask 255.255.255.252
network 30.0.0.0 mask 255.255.255.252
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 20.0.0.1
ip route 3.3.3.3 255.255.255.255 30.0.0.1

 

R4


interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
description Link to R3
ip address 30.0.0.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 3
bgp router-id 3.3.3.3
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 30.0.0.0 mask 255.255.255.252
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 30.0.0.2

View solution in original post

Hello

Apply the following and test again.

R1
router bgp 1
no network 1.1.1.1

R3

router bgp 2
network 20.0.0.0 mask 255.255.255.252
network 30.0.0.0 mask 255.255.255.252


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

5 Replies 5

Hello,

 

post the full running configs of all three routers. Are you peering with the loopbacks or with the physical interface addresses ?

 

The below configs would be an option to have full reachability:

 

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description Link to R3
ip address 20.0.0.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 1
bgp router-id 1.1.1.1
bgp log-neighbor-changes
network 1.1.1.1 mask 255.255.255.255
network 20.0.0.0 mask 255.255.255.252
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 20.0.0.2

 

R3


interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
description Link to R1
ip address 20.0.0.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
description Link to R4
ip address 30.0.0.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 2
bgp router-id 2.2.2.2
bgp log-neighbor-changes
network 2.2.2.2 mask 255.255.255.255
network 20.0.0.0 mask 255.255.255.252
network 30.0.0.0 mask 255.255.255.252
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 20.0.0.1
ip route 3.3.3.3 255.255.255.255 30.0.0.1

 

R4


interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
description Link to R3
ip address 30.0.0.1 255.255.255.252
duplex auto
speed auto
media-type rj45
!
router bgp 3
bgp router-id 3.3.3.3
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
network 30.0.0.0 mask 255.255.255.252
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 30.0.0.2

All the configuration are attached... I am peering with Serial Interfaces...

It worked , I thank you for your support

Hello

Apply the following and test again.

R1
router bgp 1
no network 1.1.1.1

R3

router bgp 2
network 20.0.0.0 mask 255.255.255.252
network 30.0.0.0 mask 255.255.255.252


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Yes, it worked for me.. Thank You sir for your support..

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card