05-31-2023 07:23 AM
I am configuring MVPN on EVE-NG on 4 routers in full mesh topology. All the configs are done but it seems that tunnel0 interface is down and I cannot go further! MPLS is working just fine. Here are the R2 configs:
R2 and R4 are PEs. R4 config is similar to R2 with changes in IP addressing. I don't know if this is a bug in the software or a fault in my configuration.
R2:
hostname R2
!
boot-start-marker
boot-end-marker
!
!
vrf definition ALEX
rd 1:1
route-target export 1:1
route-target import 1:1
!
address-family ipv4
mdt default 239.1.1.1
mdt data 239.1.2.0 0.0.0.255
exit-address-family
!
!
no aaa new-model
!
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain lookup
ip multicast-routing
ip multicast-routing vrf ALEX
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
redundancy
!
no cdp log mismatch duplex
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 10.10.12.2 255.255.255.0
ip pim sparse-mode
!
interface Ethernet0/1
vrf forwarding ALEX
ip address 100.0.1.2 255.255.255.0
ip pim sparse-mode
!
interface Ethernet0/2
ip address 10.10.23.2 255.255.255.0
ip pim sparse-mode
!
interface Ethernet0/3
ip address 10.10.24.2 255.255.255.0
ip pim sparse-mode
!
router ospf 100 vrf ALEX
router-id 100.100.100.100
redistribute bgp 24 subnets
network 100.0.1.2 0.0.0.0 area 0
!
router ospf 1
mpls ldp autoconfig
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 10.10.12.2 0.0.0.0 area 0
network 10.10.23.2 0.0.0.0 area 0
network 10.10.24.2 0.0.0.0 area 0
!
router bgp 24
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 24
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!
address-family ipv4 vrf ALEX
redistribute ospf 100
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip pim bidir-enable
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
ipv6 ioam timestamp
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
transport input none
!
!
end
05-31-2023 08:43 AM
Hi @TheAnalyst ,
1. You need to configure "ip pim sparse-mode" on the loopback interface.
2. You need to configure a multicast RP for the global context.
3. You need to configure a multicast RP for the vrf ALEX context.
Regards,
06-01-2023 12:37 AM
I checked and I had forgotten to add pim sparse-mode to loopback interfaces (source and destination of the tunnel).
Now the problem is, the ping goes from one side to another but not from another to this one, Although I have enabled bidir!
Also at times the ping doesn't go through at all! Why? I don't know! Is this a bug or a misconfig?
06-01-2023 04:02 AM - edited 06-01-2023 04:02 AM
Hi @TheAnalyst ,
The only pim bidir configuration I saw in what you have provided so far is the "ip pim bidir-enable". You still need to configure either static RP, auto RP or BSR. For a lab test I generally use static RP on all devices, as it only requires one command on each router and is easier to troubleshoot in a small network.
ip pim rp-address <rp address>
For more information on how to configure the RP, please refer to the following documentation:
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide