cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
370
Views
0
Helpful
8
Replies
Beginner

Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

I have C1112-8PLTEEA router connected to an ADSL line, but it does not work. The ADSL line is ok, VPI/VCI settings are also ok, the whole configuration was tested successfully with different model (C876). I would like to know if someone has the same bad experience. I have used IOS versions 16.8.2 and 16.9.1 for testing purposes.

 

Layer 1 on C1112 is up
!
C1112#show controllers vdsl 0/3/0
...

Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.992.5 (ADSL2+) Annex J

...

Modem FW Version: 4.16L.05
Modem PHY Version: B2pvfbH043j.d26r
!

Layer 2 is up
!
interface ATM0/3/0
no ip address
no atm ilmi-keepalive
no atm enable-ilmi-trap
pvc 1/32
pppoe-client dial-pool-number 1
!
!
C1112#sh int atm0/3/0
ATM0/3/0 is up, line protocol is up
Hardware is C1112-GFAST-BJ, address is 780c.f0c0.1018 (bia 780c.f0c0.1018)
MTU 1800 bytes, sub MTU 1800, BW 572 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Keepalive not supported
Encapsulation(s): AAL5
8 maximum active VCs, 0 current VCCs
ATM Dynamic Bandwidth Enabled.
VC Auto Creation Disabled.
VC idle disconnect time: 300 seconds
2 carrier transitions
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
!
!

but the input/output packet counters do not increment. VPI/VCI settings are correct.

 

Debug of pppoe events provides following output

C1112#debug pppoe events
PPPoE protocol events debugging is on
C1112#
*Feb 11 08:30:45.600: PPPoE:ATM0/3/0 1/32, Got ATM VC Event[4]
*Feb 11 08:30:45.600: PPPoE:ATM0/3/0 1/32, Got ATM VC Event[4]
*Feb 11 08:30:46.599: PPPoE:ATM0/3/0 1/32, Got ATM VC Event[4]
*Feb 11 08:30:46.599: PPPoE:ATM0/3/0 1/32, Got ATM VC Event[4]
*Feb 11 08:30:46.657: padi timer expired

 

Best Regards,

 

Peter

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

I have solved this problem with a small configuration change.

Instead of ATM physical interface configuration, I have created an ATM subinterface and specified VPI/VCI and PPPoE client configuration under this subinterface.

 

Non-working configuration

!

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

no atm enable-ilmi-trap

pvc 1/32

  pppoe-client dial-pool-number 1

!

 

Working configuration

!

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

no atm enable-ilmi-trap

!

interface ATM0/3/0.10 point-to-point

no atm enable-ilmi-trap

pvc 1/32

  pppoe-client dial-pool-number 1

!

!

 

This new configuration brought up the Virtual-Access interface bound to Dialer interface.

 

*Feb 12 15:21:36.829: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

*Feb 12 15:21:36.833: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Feb 12 15:21:37.108: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

 

The “show interface atm” command output now shows 1 active VCC, before it was 0.

 

C1112#sh int atm0/3/0

ATM0/3/0 is up, line protocol is up

  Hardware is C1112-GFAST-BJ, address is 780c.f0c0.1018 (bia 780c.f0c0.1018)

  MTU 1800 bytes, sub MTU 1800, BW 572 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ATM, loopback not set

  Keepalive not supported

  Encapsulation(s): AAL5

  8 maximum active VCs, 1 current VCCs

 

Best Regards,

 

Peter

8 REPLIES 8
Highlighted
VIP Mentor

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

post the full configuration of the router (show run)...

VIP Mentor

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Also, who is your ISP ?

Beginner

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Please find attached following output

 

show running-config

show version

show controllers vdsl 0/3/0

show interface atm0/3/0

show dialer 1

show atm pvc 1/32

VIP Mentor

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

what are your controller options ?

 

C112(config-controller)# operating mode ?

 

And who is your ISP ?

Beginner

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Here are the options:

C1112(config-controller)#operating mode ?
adsl1 ITU G.992.1
adsl2 ITU G.992.3
adsl2+ ITU G.992.5
auto auto detect mode
etsi ETSI TS 101 388 V1.3.1 Annex C
vdsl2 ITU G.993.2

My ISP is Slovak Telekom, member of DT group - https://www.telekom.sk/about/
VIP Mentor

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

try to set the operating mode manually (try adsl2, adsl2+, and vdsl2). Also, complete the configuration (see below, additions marked in bold).

 

I have looked at the Slovak Telekom site, and the Cisco is not specifically listed as a supported device. That might not mean much but there is always a chance that their DSLAM is not compatible with the chipset in your router. Check with them to be sure...

 

https://www.telekom.sk/wiki/zariadenia/modemy-a-routre

 

Current configuration : 4222 bytes
!
! Last configuration change at 09:46:00 UTC Mon Feb 11 2019
!
version 16.8
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname C1112
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
subscriber templating
!
multilink bundle-name authenticated
!
license udi pid C1112-8PLTEEA sn FGL223695QA
no license smart enable
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
redundancy
mode none
!
controller Cellular 0/2/0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
controller VDSL 0/3/0
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/0/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface Cellular0/2/0
ip address negotiated
ipv6 enable
!
interface Cellular0/2/1
no ip address
shutdown
!
interface ATM0/3/0
no ip address
no atm ilmi-keepalive
no atm enable-ilmi-trap
pvc 1/32
pppoe-client dial-pool-number 1
!
interface Ethernet0/3/0
no ip address
no negotiation auto
!
interface Vlan1

ip nat inside
ip address x.x.x.x y.y.y.y
!
interface Dialer1
ip address negotiated

ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username ... password ...
ppp ipcp dns request accept
ppp ipcp route default
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 permit any
!
control-plane
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
wsma agent exec
!
wsma agent config
!
wsma agent filesys
!
wsma agent notify
!
end

 

VIP Mentor

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

one more thing, are you sure that Telekom uses PAP ? Just to be sure they don't use CHAP, try the config below (changes marked in bold):

 

Current configuration : 4222 bytes
!
! Last configuration change at 09:46:00 UTC Mon Feb 11 2019
!
version 16.8
service timestamps debug datetime msec
service timestamps log datetime msec
platform qfp utilization monitor load 80
no platform punt-keepalive disable-kernel-core
!
hostname C1112
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
subscriber templating
!
multilink bundle-name authenticated
!
license udi pid C1112-8PLTEEA sn FGL223695QA
no license smart enable
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
redundancy
mode none
!
controller Cellular 0/2/0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
controller VDSL 0/3/0
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/0/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface Cellular0/2/0
ip address negotiated
ipv6 enable
!
interface Cellular0/2/1
no ip address
shutdown
!
interface ATM0/3/0
no ip address
no atm ilmi-keepalive
no atm enable-ilmi-trap
pvc 1/32
pppoe-client dial-pool-number 1
!
interface Ethernet0/3/0
no ip address
no negotiation auto
!
interface Vlan1

ip nat inside
ip address x.x.x.x y.y.y.y
!
interface Dialer1
ip address negotiated
ip nat outside
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer idle-timeout 600
dialer-group 1
no keepalive
ppp authentication chap callin
ppp chap hostname xxxxxxxxxx@xxxxxx
ppp chap password 7 xxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp mask request
ppp ipcp route default
no cdp enable
no cdp enable
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
!
--> no ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 permit any
!
control-plane
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
wsma agent exec
!
wsma agent config
!
wsma agent filesys
!
wsma agent notify
!
end

Beginner

Re: Missing ADSL (Annex B) support on ISR1100 (GFAST model)

Hello,

 

I have solved this problem with a small configuration change.

Instead of ATM physical interface configuration, I have created an ATM subinterface and specified VPI/VCI and PPPoE client configuration under this subinterface.

 

Non-working configuration

!

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

no atm enable-ilmi-trap

pvc 1/32

  pppoe-client dial-pool-number 1

!

 

Working configuration

!

interface ATM0/3/0

no ip address

no atm ilmi-keepalive

no atm enable-ilmi-trap

!

interface ATM0/3/0.10 point-to-point

no atm enable-ilmi-trap

pvc 1/32

  pppoe-client dial-pool-number 1

!

!

 

This new configuration brought up the Virtual-Access interface bound to Dialer interface.

 

*Feb 12 15:21:36.829: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

*Feb 12 15:21:36.833: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Feb 12 15:21:37.108: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

 

The “show interface atm” command output now shows 1 active VCC, before it was 0.

 

C1112#sh int atm0/3/0

ATM0/3/0 is up, line protocol is up

  Hardware is C1112-GFAST-BJ, address is 780c.f0c0.1018 (bia 780c.f0c0.1018)

  MTU 1800 bytes, sub MTU 1800, BW 572 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ATM, loopback not set

  Keepalive not supported

  Encapsulation(s): AAL5

  8 maximum active VCs, 1 current VCCs

 

Best Regards,

 

Peter

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards