cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
431
Views
0
Helpful
25
Replies
Highlighted
Beginner

Multi Homed BGP - how to influence outbound path per ip

I have two providers and in which all my incoming traffic is somewhat balanced using route maps, currently all outgoing traffic just goes to one provider and if that provider goes down then it rolls to the other. Is there a way I can force an individual IP address or range to go out my other provider while both are active?

Everyone's tags (4)
25 REPLIES 25
VIP Mentor

Re: Multi Homed BGP - how to influence outbound path per ip

Hello,

 

without knowing your exact topology, the easiest way to accomplish this is probably policy routing. You match an IP address, or a range, and then set the next hop or the outgoing interface that matches your respective ISP link..

Beginner

Re: Multi Homed BGP - how to influence outbound path per ip

I have tried

ip route X.X.X.X 255.255.255.255 Y.Y.Y.Y (isp B) but this kills the IP address all together.

 

The only thing I can come up with is setting up a route-map with a local preference that includes the ip address or range and set it to the neighbor ... I haven't tried this yet as I was hoping there is a simpler solution.

VIP Mentor

Re: Multi Homed BGP - how to influence outbound path per ip

Hello,

 

what does your topology look like ? Since you are using local preference I assume you have at least two routers ?

Beginner

Re: Multi Homed BGP - how to influence outbound path per ip

Single ASR Router - Multi homed with ISP A and ISP B

Beginner

Re: Multi Homed BGP - how to influence outbound path per ip

I am not using any local preferences yet, I was thinking that could be a solution. Currently I am receiving a Full route table from ISP A and only the default route from ISP B (which is why all current outbound connections are going out ISP A)
VIP Expert

Re: Multi Homed BGP - how to influence outbound path per ip

Yes, there are different ways to accomplish that, PBR has been mentioned, but unless you're really want to policy route (which can be a pain, especially dealing with fail over), have you consider either accepting routes from both providers or using just a default to both? (BTW, on the same router, you'll need to use a hidden command if you want to use ECMP.)

Another option, would be to consider using PfR (may require a feature upgrade/license). It should be able to dynamically load balance even with BGP from one provider and default to the other.
Beginner

Re: Multi Homed BGP - how to influence outbound path per ip

If I accept full routes or only a default route from each provider will I be able to use local pref in a route map for different subnets?

VIP Mentor

Re: Multi Homed BGP - how to influence outbound path per ip

Hello,

 

policy routing is definitely an option then. Can you post the config of your ASR ?

Beginner

Re: Multi Homed BGP - how to influence outbound path per ip

Its a pretty large config I would rather not post the entire thing on here, is there something specific you would like to see from it?

VIP Mentor

Re: Multi Homed BGP - how to influence outbound path per ip

Hello,

 

for the policy routing I basically only need to see the LAN as well as both ISP facing interfaces...

Beginner

Re: Multi Homed BGP - how to influence outbound path per ip

interface TenGigabitEthernet0/3/0
description ISP B 10GB
ip address Y.Y.Y.50 255.255.255.252
no ip redirects
no ip proxy-arp
ip nat outside
ip flow monitor ddosB input
ip access-group 136 in
ip access-group 128 out
ipv6 address YYYY
ipv6 enable
ipv6 traffic-filter all_network in
ipv6 traffic-filter all_network out
nat64 enable

interface TenGigabitEthernet1/3/0
description Connected to ISP A 10GB
ip address X.X.X.190 255.255.255.252
no ip redirects
no ip proxy-arp
ip nat outside
ip flow monitor ddos input
ip access-group 136 in
ip access-group 128 out
ipv6 address XXXX
ipv6 enable
nat64 enable

neighbor X.X.X.189 route-map ISPA out
neighbor X.X.X.189 filter-list 3 out

neighbor Y.Y.Y.49 send-community
neighbor Y.Y.Y.49 route-map ISPB out
neighbor Y.Y.Y.49 filter-list 3 out

 

 

 

Does this have what you are looking for?

Cisco Employee

Re: Multi Homed BGP - how to influence outbound path per ip

As suggested by Georg, a PBR would be the easiest way to do it :
https://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/10116-36.html

As you are using multi homed providers, you might also be interested on the verify-availability feature for PBR for fallback next hops.

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_pi/command/iri-cr-book/iri-cr-s1.html#wp8093935770

Hall of Fame Master

Re: Multi Homed BGP - how to influence outbound path per ip

If you are receiving full routes from one ISP and only a default route from the other ISP then neither local preference nor weight will be effective. Either you need to have multiple routes from both ISP or you need PBR.

 

HTH

 

Rick

VIP Advisor

Re: Multi Homed BGP - how to influence outbound path per ip

Hello


@Brandon Baker wrote:

I have two providers and in which all my incoming traffic is somewhat balanced using route maps, currently all outgoing traffic just goes to one provider and if that provider goes down then it rolls to the other. Is there a way I can force an individual IP address or range to go out my other provider while both are active?

 

Single ASR Router - Multi homed with ISP A and ISP B


You can LB on received routes using BGP Weight PA which isn't as specific as PBR but very useful.

Example:

access-list 10 permit 123.123.123.0 0.0.0.255
route-map ISP1-Weight permit 10
set weight 30000

route-map ISP2-Weight permit 10
match ip address 10
set weight 40000

route-map ISP2-Weight permit 99
set weight 20000

router bgp x
neighbor x.x.x route-map ISP1-Weight in

neighbor x.x.x route-map ISP2-Weight in



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards