cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
628
Views
0
Helpful
1
Replies

Multiple locations with same LAN subnet?

tylerlucas
Level 1
Level 1

We are adding a new remote office to our MPLS cloud.  Their LAN subnet happens to have the same IP scheme as one of our other offices.  Changing the IP scheme is not an option.

Is it possible to do outbound (from remote office to headend), and translate to an IP not local to the remote router? Essentially NAT to a random IP? From our head end, we would need to connect to a couple devices, so we would like to do static NAT from out to in (not in config below).

Would the following config work?

int fa0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside

int s0/0 (head-end facing interface)
ip address X.X.X.X 255.255.255.252
ip nat outside
no shut

ip route 0.0.0.0 0.0.0.0 X.X.X.Y (all non-local traffic goes to head-end)

ip nat inside source list NAT_OUT pool NAT_OUT_POOL overload

ip access-list extended NAT_OUT
permit ip 192.168.10.0 0.0.0.255 any

ip nat pool NAT_OUT_POOL 172.16.99.99 172.16.99.99 netmask 255.255.255.255

1 Accepted Solution

Accepted Solutions

andrew.prince
Level 10
Level 10

To be able to connect back to devices the easiest way is to perform network nat.

So you have a remote site with 192.168.10.0/24 and you are already using that, then choose a subnet that is free.  And you want 172.16.99.0/24

int fa 0/0

ip nat inside

!

int s0/0

ip nat outside

!

ip nat inside source static network 192.168.10.0 172.16.99.0 /24

This way you know that any static IP address machines will match = 192.168.10.23 <> 172.16.99.23 etc.

HTH>

View solution in original post

1 Reply 1

andrew.prince
Level 10
Level 10

To be able to connect back to devices the easiest way is to perform network nat.

So you have a remote site with 192.168.10.0/24 and you are already using that, then choose a subnet that is free.  And you want 172.16.99.0/24

int fa 0/0

ip nat inside

!

int s0/0

ip nat outside

!

ip nat inside source static network 192.168.10.0 172.16.99.0 /24

This way you know that any static IP address machines will match = 192.168.10.23 <> 172.16.99.23 etc.

HTH>

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card