cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1598
Views
0
Helpful
3
Replies

MWR2941 CEM QoS

Jon Berres
Level 4
Level 4

I have a question regarding enforcing a QoS on Pseudowire packets coming from a T1/CEM interface on an MWR2941. I have the TDM pseudowire working great testing in a lab with two T1 testsets. The problem is prioritizing the T1 traffic so that on small WAN connections the T1 traffic is not dropped because of other low priority IP traffic. Currently I have tried applying policy maps to both the input CEM and output gig ethernet interfaces. However, I am having trouble matching anything on the CEM input. I don't know if it is even possible to match packets on a CEM interface but that is the only point I can think of to put those packets in a qos-group.

Attached is an example of the config. Any suggestions would be appreciated.

!

class-map match-any cemTraffic
match mpls experimental topmost 3
match any

!

policy-map INPUT-POLICY
class cemTraffic
  set qos-group 5
  set dscp ef
!

!
interface CEM0/1
no ip address
cem 0
  xconnect 10.10.10.1 301 pw-class MPLS_EXP3
!
service-policy input INPUT-POLICY
!

MWR_2#sh policy-map INterface cem 0/1
CEM0/1

  Service-policy input: INPUT-POLICY

    Class-map: cemTraffic (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: mpls experimental topmost 3
        0 packets, 0 bytes
        5 minute rate 0 bps
      Match: any
      QoS Set
        qos-group 5
          Packets marked 0
        dscp ef
          Packets marked 0

    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any

3 Replies 3

siddiqirf
Level 1
Level 1

Hi Jon

Did you manage to solve this problem? I am having the exact same difficulty of getting QOS to run on the MWR for marking inbound of E1 traffic and outbound towards the WAN Ethernet link..

Did you manage to come up with any solution for this ?

Yes I did finally get a QoS solution for T1 CEM traffic. The major set back I had ended up being the non-support of QoS statistics on the MWR2941's. Because of this any "sh policy-map" print will not show your packets being matched/queued.

There is a built in match which will set the internal qos-group based on the MPLS exp bit. So based on this you just need to set the MPLS Exp bit on CEM circuits and then create the policy-map from that. Below is an example (I am also shaping in this example).

!

interface CEM0/1

no ip address

cem 0

  xconnect 10.10.10.2 301 pw-class pwe_cem_exp5

!

pseudowire-class pwe_cem_exp5

encapsulation mpls

mpls experimental 5

!

!

class-map match-any cem-cos-5

match qos-group 5

!

policy-map cem_egress_child

class cem-cos-5

    priority percent 90

!

policy-map cem_egress_parent

class class-default

    shape average 2500000

  service-policy cem_egress_child

Let me know how it works for you.

Hi Jon

Im still struggling to get a working QoS solution. Would really appreciate if you can help me.

Firstly I dont understand how, your MPLS EXP 5 gets mapped to qos-group 5, as you havent set it anywhere in your configuration. You mention its done automaticallly, but Cisco documentation doesnt mention this anywhere?

Also how did you queue your ptp traffic. I want to mark, classify and give that a bandwidth reservation as well on egress.

I also will have a layer 2 switch connect to G0/2 of MWR and have too user vlans traverse over it, for which I also need bandwidth reservation.

I notice that you have put your ptp configuration on the same vlan as E1-Data, does this matter?

I have attached my configuration below, please can you have a look and assist me as I am struggling. If you provide me with your email (my email is irfansid747@hotmail.com, I can send you a diagram, which shows the setup. In fact I posted it on another thread:

https://supportforums.cisco.com/thread/2094621

My output service -policy parent failed to apply on the WAN link G0/2, and I kept getting errors.

Also if it is possible to send your complete working configuration which will immensily help.

Building configuration...

Current configuration : 3869 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XCA-CED-1a
!
boot-start-marker
boot system flash mwr2941-ipran-mz.124-20.MR2.bin
boot-end-marker
!
card type e1 0 0
logging message-counter syslog
enable password cisco
!
no aaa new-model
ip source-route
!
!
ip cef
no ip domain lookup
ptp mode ordinary
ptp priority1 128
ptp priority2 128
ptp domain 1
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username cisco password 0 cisco
archive
log config
  hidekeys
!
!
controller E1 0/0
framing NO-CRC4
clock source line
cem-group 0 timeslots 1-17
!
controller E1 0/1
clock source internal
!
controller E1 0/2
clock source internal
!
controller E1 0/3
clock source internal
!
controller E1 0/4
clock source internal
!
controller E1 0/5
clock source internal
!
controller E1 0/6
clock source internal
!
controller E1 0/7
clock source internal
!
controller E1 0/8
clock source internal
!
controller E1 0/9
clock source internal
!
controller E1 0/10
clock source internal
!
controller E1 0/11
clock source internal
!
controller E1 0/12
clock source internal
!
controller E1 0/13
clock source internal
!
controller E1 0/14
clock source internal
!
controller E1 0/15
clock source internal
!
controller BITS
  applique E1
!
ip tftp source-interface Loopback0
!
class-map match-all E1-DATA-out
match qos-group 5
class-map match-any cemTraffic-in
match any
class-map match-all USERGROUPA-in
match any
class-map match-all USERGROUPB-in
match any
class-map match-any E1-CLOCK-in
match vlan  902
class-map match-all USERGROUPA-out
match qos-group 3
class-map match-all USERGROUPB-out
match qos-group 2
class-map match-all E1-CLOCK-out
match qos-group 4
!
!
policy-map out-child
class E1-DATA-out
    priority percent 40
class USERGROUPA-out
    bandwidth percent 20
class USERGROUPB-out
    bandwidth percent 20
class E1-CLOCK-in
    bandwidth percent 10
policy-map out-parent
class class-default
    shape average 10000000
  service-policy out-child
policy-map INPUT-USERGROUPS
class USERGROUPA-in
  set qos-group 3
  set dscp af31
class USERGROUPB-in
  set qos-group 2
  set dscp af21
policy-map INPUT-POLICY
class cemTraffic-in
  set qos-group 5
  set dscp ef
!
!
!
!
!
interface Loopback0
description MANAGEMENT LOOPBACK
ip address 10.240.4.1 255.255.255.255
!
interface GigabitEthernet0/0
description Link to QSM-CED-1a
switchport trunk allowed vlan 1,100,900,902,1002-1005
switchport mode trunk
bandwidth 10000
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
switchport access vlan 800
!
interface GigabitEthernet0/4
description #NOT-IN-USE
shutdown
!
interface GigabitEthernet0/5
description #NOT-IN-USE
shutdown
!
interface CEM0/0
bandwidth 102400
no ip address
cem 0
  xconnect 10.240.13.1 300 encapsulation mpls
!
service-policy input INPUT-POLICY
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface Vlan1
description #NOT-IN-USE
no ip address
ip mtu 1500
shutdown
no ptp enable
!
interface Vlan800
ip address 10.1.1.1 255.255.255.0
no ptp enable
!
interface Vlan900
ip address 10.193.3.2 255.255.255.248
no ptp enable
mpls ip
!
interface Vlan902
ip address 10.193.3.17 255.255.255.248
ptp announce interval 0
ptp sync interval -6
ptp delay-req interval -4
ptp master unicast
ptp clock-destination 10.193.3.18
ptp enable
!
ip forward-protocol nd
ip route 10.240.13.1 255.255.255.255 10.193.3.1
!
!
no ip http server
!
!
!
!
tftp-server flash:mwr2941-iprank9-mz.124-19.MR2.bin
!
control-plane
!
!
!
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login local
!
exception crashinfo buffersize 128
network-clock-select hold-timeout 30
network-clock-select mode nonrevert
network-clock-select 1 E1 0/0
end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: