cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2886
Views
5
Helpful
2
Replies

Named EIGRP redistribution with different VRF

I'm using Named EIGRP and i need to redistribute from an AS to another but I´m not getting the redistribution done!. For this example I have the network 10.10.6.0 on AS 1 VRF GRE and need the route to be redistributed to AS 110 VRF MPLS.

 

What i'm missing??

 

here is my configuration.

 

router eigrp MPLS
!
address-family ipv4 unicast vrf MPLS autonomous-system 110
!
af-interface GigabitEthernet2
summary-address 10.10.0.0 255.255.0.0
exit-af-interface
!
topology base
redistribute connected
redistribute static
redistribute eigrp 1
exit-af-topology
network 10.8.3.0 0.0.0.7
exit-address-family
!
address-family ipv4 unicast vrf GRE autonomous-system 1
!
topology base
redistribute eigrp 110
exit-af-topology
network 192.168.189.0
network 192.168.190.0
exit-address-family

 

 

MPLS_1#show ip route vrf GRE 10.10.6.1

Routing Table: GRE
Routing entry for 10.10.6.0/24
Known via "eigrp 1", distance 90, metric 38160000, type internal
Redistributing via eigrp 1
Last update from 192.168.189.14 on Tunnel23, 00:14:09 ago
Routing Descriptor Blocks:
* 192.168.189.14, from 192.168.189.14, 00:14:09 ago, via Tunnel23
Route metric is 38160000, traffic share count is 1
Total delay is 55000 microseconds, minimum bandwidth is 512 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
MPLS_1#
MPLS_1#
MPLS_1#show ip route vrf MPLS 10.10.6.1

Routing Table: MPLS
% Subnet not in table
MPLS_1#

MPLS_1#show ip route vrf MPLS 10.10.0.0

Routing Table: MPLS
% Subnet not in table
MPLS_1#

1 Accepted Solution

Accepted Solutions

Hi

The redistribution between the EIGRPs. will not work because they are in differents VRFs so you need to advertise the routes into the VRF, it can be done importing the route-targets, for example:

 

ip vrf MPLS

rd 1:1

route-target export 1:1

route-target import1:1

 

ip vrf GRE

rd 2:2

route-target export 2:2

router-target import 2:2

 

So the solution can be:

 

ip vrf MPLS

rd 1:1

route-target export 1:1

route-target import1:1

route-target import 2:2

 

ip vrf GRE

rd 2:2

route-target export 2:2

route-target import 2:2

route-target import 1:1

 

Now you can specify the networks to import using maps. 

Example: http://packetlife.net/blog/2013/sep/26/vrf-export-maps/

 

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

View solution in original post

2 Replies 2

Hi

The redistribution between the EIGRPs. will not work because they are in differents VRFs so you need to advertise the routes into the VRF, it can be done importing the route-targets, for example:

 

ip vrf MPLS

rd 1:1

route-target export 1:1

route-target import1:1

 

ip vrf GRE

rd 2:2

route-target export 2:2

router-target import 2:2

 

So the solution can be:

 

ip vrf MPLS

rd 1:1

route-target export 1:1

route-target import1:1

route-target import 2:2

 

ip vrf GRE

rd 2:2

route-target export 2:2

route-target import 2:2

route-target import 1:1

 

Now you can specify the networks to import using maps. 

Example: http://packetlife.net/blog/2013/sep/26/vrf-export-maps/

 

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

 

Thanks!,
    Great advice, I just added a BGP because the routes weren't redistributed directly from eigrp to eigrp.
Here is my final configuration just for the record. 

!
vrf definition EDGE
rd 10.7.0.4:1
route-target export 10.7.0.4:1
route-target import 10.7.0.4:1
route-target import 10.7.0.4:2
!
address-family ipv4
exit-address-family
!
vrf definition GRE
rd 10.7.0.4:2
route-target export 10.7.0.4:2
route-target import 10.7.0.4:2
route-target import 10.7.0.4:1
!
address-family ipv4
exit-address-family
!
router eigrp EDGE
!
address-family ipv4 unicast vrf EDGE autonomous-system 110
!
af-interface GigabitEthernet2
summary-address 10.10.0.0 255.255.0.0
exit-af-interface
!
topology base
default-metric 1000 100 250 100 1500
redistribute connected
redistribute static
redistribute bgp 6500
exit-af-topology
network 10.8.3.0 0.0.0.7
exit-address-family
!
address-family ipv4 unicast vrf GRE autonomous-system 1
!
topology base
default-metric 1000 100 250 100 1500
redistribute bgp 6500
exit-af-topology
network 192.168.189.0
network 192.168.190.0
exit-address-family
!
router bgp 6500
bgp log-neighbor-changes
!
address-family ipv4 vrf EDGE
redistribute connected
redistribute eigrp 110
exit-address-family
!
address-family ipv4 vrf GRE
redistribute connected
redistribute eigrp 1
exit-address-family
!

 

************

ASR_EDGE1#show ip route vrf EDGE 10.10.6.0

Routing Table: EDGE
Routing entry for 10.10.6.0/24
Known via "bgp 6500", distance 20, metric 38160000, type external
Redistributing via eigrp 110
Advertised by eigrp 110
Last update from 192.168.189.14 on Tunnel23, 00:23:58 ago
Routing Descriptor Blocks:
* 192.168.189.14 (GRE), from 0.0.0.0, 00:23:58 ago, via Tunnel23
Route metric is 38160000, traffic share count is 1
AS Hops 0
MPLS label: none
ASR_EDGE1#show ip route vrf GRE 10.10.6.0

Routing Table: GRE
Routing entry for 10.10.6.0/24
Known via "eigrp 1", distance 90, metric 38160000, type internal
Redistributing via eigrp 1, bgp 6500
Advertised by bgp 6500
Last update from 192.168.189.14 on Tunnel23, 00:43:27 ago
Routing Descriptor Blocks:
* 192.168.189.14, from 192.168.189.14, 00:43:27 ago, via Tunnel23
Route metric is 38160000, traffic share count is 1
Total delay is 55000 microseconds, minimum bandwidth is 512 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
ASR_EDGE1#

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card