cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

148
Views
0
Helpful
0
Replies
Highlighted
Beginner

Nat Load balancing PBR Problem

Hi All,

I have done the below configuration for NAT Load balancing for our network.

Hardware Used:Cisco 1841 Router with HWIC-4ESW Card

Fa0/0-ISP1

Fa0/1-ISP2

Hwic card- local lan.

 

RTR#sh running-config
Building configuration...

Current configuration : 3889 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RTR
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.20
!
ip dhcp pool LAN
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 192.168.2.12 8.8.8.8
   lease 14
!
!
ip cef
ip name-server 192.168.2.12
ip name-server 8.8.8.8
!
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-1268235365
!
!
username RTR privilege 15 secret 5 $TLldVSKKePUy.98ys/
archive
 log config
  hidekeys
!
!
!
!
!
track timer interface 5
!
track 123 interface FastEthernet0/0 ip routing
 delay down 15 up 10
!
track 345 interface FastEthernet0/1 ip routing
 delay down 15 up 10
!
!
!
interface FastEthernet0/0
 description ISP1
 ip address 10.5.24.3 255.255.255.252
 ip nat outside
 ip nat enable
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description ISP2
 ip address 20.8.1.13 255.255.252.0
 ip nat outside
 ip nat enable
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
 description CONNECTION TO LAN
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip nat enable
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.5.24.4 track 123
ip route 0.0.0.0 0.0.0.0 20.8.1.1 track 345
ip http server
ip http secure-server
!
!
ip dns server
ip nat inside source route-map fixed-nat1 interface FastEthernet0/0 overload
ip nat inside source route-map fixed-nat2 interface FastEthernet0/1 overload
!
access-list 110 permit ip 192.168.2.0 0.0.0.255 any
!
!
!
route-map fixed-nat1 permit 10
 match ip address 110
 match interface FastEthernet0/0
!
route-map fixed-nat2 permit 10
 match ip address 110
 match interface FastEthernet0/1
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
 transport input all
 transport output all
!
scheduler allocate 20000 1000
end

 

Now I need to do these changes as per the below requirements.

1.All the traffic with a port number(ex:2622) should go through ISP1.

2.Route particular local ip's to isp1

3.All other traffic should go through both isp1 and isp2.

Please suggest me some configuration changes .

another problem is 

ISP1 has given a pool of 5 ip's for us.

is there any configuration change that can be done so that i can assign public ip address directly to the internal system without using additional devices.

Please help me to solve this issue.