cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2121
Views
0
Helpful
6
Replies

NAT many-to-one

alberto-pesce
Level 1
Level 1

Hi all,

 I would like implement a configuration based on (Cisco 2800, ios 12.4(13r)T) in order to have clients inside that connect a server outside using a single outside IP address.

Best Regards

6 Replies 6

Richard Burts
Hall of Fame
Hall of Fame

What you describe is an almost classic depiction of Port Address Translation which is the type of Network Address Translation that translates multiple inside addresses to a single outside address, typically using the outside interface address with overload.

HTH

Rick

HTH

Rick

Hi,

 do you think that I have to implement also some access-list? My scope it is to forge client's request to the server as a Unique IP address (due to the restriction on server 172.16.0.250)

Best Regards

interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1
ip address 172.16.0.254 255.255.255.0
ip nat outside
!
!
!
ip nat inside source static 192.168.0.1 172.16.0.8
ip nat outside source static 172.16.0.250 192.168.0.8
!

I am a bit puzzled by your response. In your original post you were quite clear that you need translation for many to one. But in your response you are showing examples of static one to one translation.

If you are going to do Port Address Translation then it is likely that you would need an access list to identify the traffic that is to be translated.

HTH

Rick

HTH

Rick

Sorry for the puzzle.

My intent it is to find a workaround for Server that accept only one client connection per each. I'm trying to forge multiple request as coming form single IP address, as reported in the scenario attached on my first post.

It is now more clear? Could you suggest something?

Thank in advance

Best Regards

If you want requests coming from multiple sources to look like a single source then you need your translation to be dynamic and not static.

HTH

Rick

HTH

Rick

Ok, with the configuration below it is working :-)

how can I create a pool with single IP address instead of 4?


interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1
ip address 172.16.0.254 255.255.255.0
ip nat outside
!
!
!
ip nat pool NAT-pool 172.16.0.2 172.16.0.5 prefix-length 29
ip nat inside source list 100 pool NAT-pool
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card