cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
142
Views
10
Helpful
5
Replies
Highlighted

NAT outside to multI Pool

Hello 

i have two subnet public ip's 
first : 91.x.x.x/25

second : 185.x.x.x/24

 

i have now create  

 

ip nat pool FirstPool x.x.x.131 x.x.x.x.250 prefix-length 25
ip nat inside source list 1 pool FirstPool overload

access-list 1 permit 172.0.0.0 0.255.255.255
access-list 1 permit 10.0.0.0 0.255.255.255

 

 

my first-pool is full 

how to use second pool in same nat 

Everyone's tags (1)
5 REPLIES 5
Highlighted
Rising star
Rising star

Re: NAT outside to multI Pool

Hi

you could do something like this ...

 

ip nat pool FirstPool x.x.x.131 x.x.x.x.250 prefix-length 25
ip nat inside source list 1 pool FirstPool overload

access-list 1 permit 172.0.0.0 0.255.255.255

ip nat pool SecondPool 185.x.x.1 185.x.x.x.254 prefix-length 24
ip nat inside source list 2 pool SecondPool overload

access-list 2 permit 10.0.0.0 0.255.255.255

https://www.cisco.com/c/en/us/support/docs/ip/network-address-translation-nat/13739-nat-routemap.html#approach

 

Highlighted
Rising star
Rising star

Re: NAT outside to multI Pool

Highlighted

Re: NAT outside to multI Pool

now , i have one isp , give me two ip address
94.x.x.0/25
185.x.x.0/24
in same interface


interface Port-channel1.9
description BAND-IN
encapsulation dot1Q 9
ip address 185.89.98.2 255.255.255.0 secondary
ip address 94.231.199.130 255.255.255.128
ip nat outside

Highlighted
Rising star
Rising star

Re: NAT outside to multI Pool

proposed solution should work then ..

Highlighted
Collaborator

Re: NAT outside to multI Pool

Hi,

 

    There are not too many options on IOS/IOS-XE. You could split the traffic to be NAT'ed between the pools:

 

access-list 1 permit 10.0.0.0 0.255.255.255

ip nat pool FIRST

ip nat inside source list 1 pool FIRST overload

!
access-list 2 permit 172.0.0.0 0.255.255.255

ip nat pool SECOND

ip nat inside source list 2 pool SECOND overload

 

Regards,

Cristian Matei.