cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

249
Views
0
Helpful
5
Replies
Highlighted
Beginner

NAT problem ISR4431, connect to internet but very slow

Hello. I have problems with ISR4431 with I have configured as internet edge, but it seem like NAT works but the speed is very slow. When I use the public IP without NAT it connect to internet very fast but when I use NAT and configured in my PC connected to ISR4431 with a privet IP then the internet turn slower. Also the speedtest doesn't work, it shows latency failure.

Somebody help me !!!

5 REPLIES 5
Highlighted
Beginner

Re: NAT problem ISR4431, connect to internet but very slow

I'd say the first thing you need to do is paste a show run so ppl can see what and how your configured.

Highlighted
VIP Mentor

Re: NAT problem ISR4431, connect to internet but very slow

Hello,

 

make sure your basic configuration looks similar to the one below (important parts marked in bold, IP addressing is arbitrary):

 

service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname ISR4331
!
boot-start-marker
boot-end-marker
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
no aaa new-model
!
ipv6 multicast rpf use-bgp
!
multilink bundle-name authenticated
!
redundancy
mode none
!
interface GigabitEthernet0/0/0
description Link to ISP
ip address 79.77.67.65 255.255.255.252
ip nat outside
negotiation auto
!
interface GigabitEthernet0/0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
negotiation auto
!
interface GigabitEthernet0/0/3
no ip address
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
!

ip route 0.0.0.0 0.0.0.0 79.77.67.66

!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
line con 0
stopbits 1
line vty 0 4
login
!
end

Highlighted
Beginner

Re: NAT problem ISR4431, connect to internet but very slow

Hello. Thank you for your answer. The configuration in ISR4431 is the same as you showed.

Highlighted
Beginner

Re: NAT problem ISR4431, connect to internet but very slow

Hello,

Please give us the results of the following commands:

show process cpu sorted

show process memory sorted

show logs -> it will be important during the day when you have problems

show int wan_int_id | i err

show int wan_int_id | i duplex

 

Thank you

 

Highlighted
VIP Mentor

Re: NAT problem ISR4431, connect to internet but very slow

Hello


@egomezb wrote:

 When I use the public IP without NAT it connect to internet very fast but when I use NAT and configured in my PC connected to ISR4431 with a privet IP then the internet turn slower. Also the speedtest doesn't work, it shows latency failure.


Can you confirm what dns servers the clients are pointing too?
Have you tried using a ip address instead of a dns FQDN just to to see if the response is any better?
what software version is running on the rtr please?

What speedtest are you using?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future