03-06-2017 11:43 PM - edited 03-05-2019 08:08 AM
Hello Everyone,
I have to do a work Packet Tracer, it is about two buildings, A and B, Building A have 20 floors, each floor has 1 switch and 3 computers, and their networks or subnet are different. The building B have 5 Floors, same as A, it has 1 switch and 3 computers for each floor.
What i need to do, is to connect with Copper Cross Over cable the switches, after i do that on the two buildings, i have to connect those to 1 router and send packets from building to building.
What i don't know, is how to send packets between different networks, i mean, for example send a message from floor 1 to floor 2 in the same building, never worked with two switches connected together.
There is an image to make you understand better.
The Left one, is the building A, the Right one, is the Buidling B. I need that, it can send packets between floors and buildings...
I would really appreciate who could help me in this, i would be really grateful...
I am sorry for my English.
Hope you have a Good Night.
03-07-2017 03:41 AM
Hi Ram,
I suggest you to go with intervlan routing concept for establishing this connectivity.
Example:
ON router
int fa0/0
no ip add
no shut
int fa0/0.10
ip add 10.1.1.1 255.255.255.0
encapsulation dot1q 10
int fa0/0.20
ip add 20.1.1.1 255.255.255.0
encapsulation dot1q 20
int fa0/0.30
ip add 30.1.1.1 255.255.255.0
encapsulation dot1q30
int fa0/1
no ip add
no shut
int fa0/1.40
ip add 40.1.1.1 255.255.255.0
encapsulation dot1q40
int fa0/1.50
ip add 50.1.1.1 255.255.255.0
encapsulation dot1q50
int fa0/1.60
ip add 60.1.1.1 255.255.255.0
encapsulation dot1q60
on switch end..
Make the uplink ports that are connecting to the router as trunk port on both sides of switch
on switch
int fa0/0
switchport mode trunk
The router should now have the complete routing table entries for all the different network subnets. Configure the ip's on the PC's and verify the end to end ping response between different subnets which the router should enable the routing between different subnets.
03-07-2017 08:16 AM
I recommend you to first configure encapsulation dot1q on the sub-interfaces and then configure the ip address in the next line because configuring ip first on the sub-interfaces and then the ip address would not be recognized which would end up with some information as given below.
Configuring IP routing on a LAN subinterface is only allowed if that subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q, or ISL vLAN.
Additionally you need to ensure that the vlan's you create on the switches have the access ports mapped correctly to the respective vlan's properly and the PC's are configured with ip's and default gateways properly.
These default gateway's that you set on the PC's are the ip addresses that you set for trunking encapsulation on the respective sub-interfaces.
example:
on switch
int vlan10
int fa1/1
switchport mode access
switchport access vlan 10
03-07-2017 05:28 AM
You don't go into details as to whether you have different networks within each building. James' suggestion may be a little more that you are looking for but it would accomplish what you are looking for.
The simple answer for you is that you just need to trunk the connections between the switches. Here is a configuration guide for interVLAN routing, not that you need to segment your network but it is a good illustration for trunking between multiple switches:
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-3750-series-switches/45002-intervlan3750-45002.html
Regards,
Sam
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide