cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1463
Views
0
Helpful
9
Replies

NHRP issue

RenXiangYou94375
Beginner
Beginner

Hi all,

I have problem when I doing DMVPN lab.

I configure the hub and spoke router.

The spoke router is working. Use "sh dmvpn" can see output and can send NHRP Registration request to hub router.

But "sh dmvpn" and "sh ip nhrp" show nothing on the hub router.

 

the hub router config is:

 

interface Tunnel0
 ip address 172.16.123.3 255.255.255.0
 no ip redirects
 ip nhrp map multicast dynamic
 ip nhrp network-id 10
 tunnel source GigabitEthernet0/1
 tunnel mode gre multipoint

 

 

the spoke router config is:

interface Tunnel0
ip address 172.16.123.1 255.255.255.0
ip nhrp map 172.16.123.3 10.100.100.2
ip nhrp map multicast 10.100.100.2
ip nhrp network-id 10
ip nhrp nhs 172.16.123.3
tunnel source GigabitEthernet0/2
tunnel destination 10.100.100.2

the hub router show:

Hub#show dmvpn                 
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
T1 - Route Installed, T2 - Nexthop-override
C - CTS Capable
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================

 

 

I check the connectivity between spoke and hub is work.

How can I solve it?  Thank you.

1 Accepted Solution

Accepted Solutions

RenXiangYou94375
Beginner
Beginner

Hi all,

Finally, I find that I misconfigure the "tunnel source" ,make NHRP not working.

It's completed. thank you.

View solution in original post

9 Replies 9

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

hard to tell what you are missing. Are these the full tunnel configs ? On the hub tunnel, try and configure:

 

ip nhrp redirect

 

Also, post the output of:

 

show ip nhrp nhs detail

 

from the hub and spoke routers...

Hi,

 

the spoke router use "show ip nhrp nhs detail":

Spoke#show ip nhrp nhs detail 
Legend:E=Expecting replies, R=Responding, W=Waiting
Tunnel0:
172.16.123.3   E priority = 0 cluster = 0  req-sent 809  req-failed 0  repl-recv 0 


Pending Registration Requests:
Registration Request: Reqid 17, Ret 64  NHS 172.16.123.3 expired (Tu0) 

The Hub router shows:

Hub#show ip nhrp nhs detail
Hub#

 

 

MHM Cisco World
VIP Mentor VIP Mentor
VIP Mentor

tunnel destination in spoke must replace with tunnel mode gre multipoint.  

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

on the spoke  add and test

 

ip nhrp map multicast dynamic
tunnel mode gre multipoint

  

here is some reference :

 

https://www.cisco.com/c/en/us/support/docs/security-vpn/ipsec-negotiation-ike-protocols/29240-dcmvpn.html

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

Looks like your using DMVPN phase 2, Do you have an IGP running as well (rip,ospf,eigrp) if so
try the following:

NHS (Hub router)
interface Tunnel0
no tunnel source GigabitEthernet0/1

 

NHC (the spoke router)

interface Tunnel0
no tunnel destination 10.100.100.2
tunnel mode gre multipoint

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi,

 

I try these command and it still not working.

I make sure the hub router can receive the NHRP registration packet from the spoke router

Hello

Would you be able to post configs for both the NHS (hub) and NHC (spoke) please?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Post updated config to look.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

RenXiangYou94375
Beginner
Beginner

Hi all,

Finally, I find that I misconfigure the "tunnel source" ,make NHRP not working.

It's completed. thank you.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers