cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
805
Views
5
Helpful
7
Replies

No fast- or CEF switching occurring

mflocco
Beginner
Beginner

I have a 3560 switch which has CEF enabled on all routed interfaces. Output from show ip interfaces shows the following:

IP fast switching is enabled

IP CEF switching is enabled

IP CEF switching turbo vector

IP multicast fast switching is enabled

IP multicast distributed fast switching is enabled

IP route-cache flags are Fast, CEF

for Vlan3, Fa0/11, Fa0/24.

However, a show interface stats shows all packets being switched by the processor, zero by the Route cache. My understanding is that CEF and fast-switched packets should show up here. I also see a relatively high utilization on CPU on the IP input process. For example, I see this:

Vlan3

Switch path Pkts In Chars In Pkts Out Chars Out

Processor 8032 544231 5958 777174

Route cache 0 0 0 0

Total 8032 544231 5958 777174

Applicable portions of my current config:

!

version 12.2

no service pad

!

no aaa new-model

ip subnet-zero

ip routing

no ip domain-lookup

!

ip multicast-routing distributed

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/2

switchport access vlan 3

!

interface FastEthernet0/4

switchport access vlan 3

duplex full

!

interface FastEthernet0/5

switchport access vlan 3

!

interface FastEthernet0/6

switchport access vlan 3

speed 100

no cdp enable

!

interface FastEthernet0/7

switchport access vlan 3

duplex full

!

interface FastEthernet0/11

no switchport

ip address 1.2.3.4 255.255.255.0

!

interface FastEthernet0/24

no switchport

ip address 5.6.7.8 255.255.255.0

ip pim sparse-mode

duplex full

speed 100

!

interface Vlan3

description Order Subnet and Unicast

ip address 9.10.11.12 255.255.255.0 secondary

ip address 13.14.15.16 255.255.255.0

ip pim sparse-mode

!

!

end

I initially concentrated on the multicast portion, since that's the majority of my data, but realized that no packets, not even TCP, were being fast- or CEF switched. Any suggestions would be appreciated.

7 Replies 7

s.arunkumar
Participant
Participant

Hi

Just remembering read somewhere that "locally originated traffics are processes switched"..

but ur case u are mentioning that packets are getting traverse across the switch..???

lets see what experts says..

arun

Mohamed Sobair
Rising star
Rising star

Hi,

Fast Switching is a feature that rely on (Route-Cache). On routers when you enable (Ip route-cache) per interface , its just stores the recent routes used by the router for fast Switching process.

In a Multicast environment, it has the same logic, If you want to enable it, you should configure (IP mroute-cahe) for any pim interface enabled.

verify: (sh ip mroute-cache) after configuring it.

HTH

Mohamed

pciaccio
Enthusiast
Enthusiast

Try enabling Route-Cache on each interface that you are running (ip route-cache). This will start the cache switching on the interfaces...