cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
442
Views
5
Helpful
6
Replies

OSPF neighbor 9500 to c3560X

bruce.thornton
Beginner
Beginner

Need help.

This should be fairly simply.....however. I have a C9500-16X that has routing enabled(couple of ports routed working with neighbors)that I'm trying to establish a neighbor relation with an old C3560X(:c3560e-universalk9-mz.152-4.E10.bin) enabled. The links are up, I can ping each side of the link, however no neighbor can be establish.

See below

9500 config:

interface TenGigabitEthernet1/0/16
description Link<>VG0202 Gateway
no switchport
ip address 10.13.255.13 255.255.255.252

############################

router ospf 100
router-id 10.13.255.100
passive-interface default
no passive-interface TenGigabitEthernet1/0/1
network 10.13.187.16 0.0.0.7 area 0.0.0.0
network 10.13.255.12 0.0.0.3 area 0.0.0.0
network 10.13.0.0 0.0.255.255 area 0.0.0.0

######################################

BTRBRGBBCFH9500_1#sho cdp nei te1/0/16 de
-------------------------
Device ID: CFHSurgVG_Sw1.ghsbtr.net
Entry address(es):
IP address: 10.13.255.14
Platform: cisco WS-C3560X-24P, Capabilities: Router Switch IGMP
Interface: TenGigabitEthernet1/0/16, Port ID (outgoing port): GigabitEthernet1/ 1
Holdtime : 143 sec

Version :
Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 15.2(4)E10, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2020 by Cisco Systems, Inc.
Compiled Tue 31-Mar-20 21:44 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: full
Management address(es):
IP address: 10.13.255.14

 

Cisco 3560X config:

interface GigabitEthernet1/1
description Link<>9400-port 16
no switchport
ip address 10.13.255.14 255.255.255.252
end

####################################

CFHSurgVG_Sw1#sho run | b router ospf 100
router ospf 100
router-id 10.13.255.101
network 10.13.187.16 0.0.0.7 area 0.0.0.0
network 10.13.255.12 0.0.0.3 area 0.0.0.0

#######################################

CFHSurgVG_Sw1#sho cdp nei gi1/1 de
-------------------------
Device ID: BTRBRGBBCFH9500_1.ghsbtr.net
Entry address(es):
IP address: 10.13.255.13
Platform: cisco C9500-16X, Capabilities: Router Switch IGMP
Interface: GigabitEthernet1/1, Port ID (outgoing port): TenGigabitEthernet1/0/16
Holdtime : 135 sec

Version :
Cisco IOS Software [Fuji], Catalyst L3 Switch Software (CAT9K_IOSXE), Version 16.9.3, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2019 by Cisco Systems, Inc.
Compiled Wed 20-Mar-19 08:02 by mcpre

advertisement version: 2
VTP Management Domain: 'GHSDOMAIN_MT3'
Duplex: full
Management address(es):
IP address: 10.13.255.13

 

Any ideas!!!!!!!!!!!!!!!!!!

 

 

6 Replies 6

Tyson Joachims
Rising star
Rising star

On the 9500, you have passive interface default enabled. You will have to issue the following command to allow OSPF adjacencies to form on the port:

no passive-interface TenGigabitEthernet1/0/16

 

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

Do the same config on Cisco 3560X  (Some IOS by default passive-interface) - test and advise.


router ospf 100

no passive-interface GigabitEthernet1/1

 

Cat 9500

 

router ospf 100
no passive-interface TenGigabitEthernet1/0/16

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

@balaji.bandi 

 

Out of curiosity, which IOS versions have OSPF set to passive-interface default, by default ?

 @Georg Pauwen  apologies may be mixed up auto-summary  vs passive interface. (Some IOS by default passive-interface)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

paul driver
VIP Expert VIP Expert
VIP Expert

Hello

Assuming it just a paste typo and you have indeed allowed that interface to be non passive as suggested by @Tyson Joachims 

what sdm template is being used?

can you post  output of:

debug up ospf adj


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Assuming that the original post was accurate then passive interface was an issue. I would like to hear from the original poster about whether the passive interface has been corrected and whether there are any remaining issues. 

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers