cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
476
Views
0
Helpful
3
Replies
Farhan64
Beginner

OSPF NOT ABLE TO COMMUNICATE BETWEEN TWO AREA

I HAVE ATTACHED THE FILE

 

ROUTER 1 IS NOT SHOWING ROUTE OF AREA 76  (i.e ROUTE 89, ROUTE 109, ROUTE 119)

 

Router1#sh ip route ospf

O IA 192.168.24.0 [110/129] via 192.168.13.2, 01:49:24, GigabitEthernet0/1

O IA 192.168.34.0 [110/65] via 192.168.13.2, 01:49:24, GigabitEthernet0/1

O IA 192.168.45.0 [110/66] via 192.168.13.2, 01:49:24, GigabitEthernet0/1

O IA 192.168.56.0 [110/130] via 192.168.13.2, 00:16:02, GigabitEthernet0/1

O IA 192.168.57.0 [110/130] via 192.168.13.2, 00:16:02, GigabitEthernet0/1

O IA 192.168.68.0 [110/194] via 192.168.13.2, 00:16:02, GigabitEthernet0/1

O IA 192.168.78.0 [110/194] via 192.168.13.2, 00:16:02, GigabitEthernet0/1

O IA 192.168.120.0 [110/198] via 192.168.13.2, 00:15:37, GigabitEthernet0/1

O IA 192.168.121.0 [110/197] via 192.168.13.2, 00:15:37, GigabitEthernet0/1

 

Router1#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 1.1.1.0/24 is directly connected, Loopback0

L 1.1.1.1/32 is directly connected, Loopback0

192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.12.0/24 is directly connected, GigabitEthernet0/0

L 192.168.12.1/32 is directly connected, GigabitEthernet0/0

192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.13.0/24 is directly connected, GigabitEthernet0/1

L 192.168.13.1/32 is directly connected, GigabitEthernet0/1

O IA 192.168.24.0/24 [110/129] via 192.168.13.2, 01:57:41, GigabitEthernet0/1

O IA 192.168.34.0/24 [110/65] via 192.168.13.2, 01:57:41, GigabitEthernet0/1

O IA 192.168.45.0/24 [110/66] via 192.168.13.2, 01:57:41, GigabitEthernet0/1

O IA 192.168.56.0/24 [110/130] via 192.168.13.2, 00:24:19, GigabitEthernet0/1

O IA 192.168.57.0/24 [110/130] via 192.168.13.2, 00:24:19, GigabitEthernet0/1

O IA 192.168.68.0/24 [110/194] via 192.168.13.2, 00:24:19, GigabitEthernet0/1

O IA 192.168.78.0/24 [110/194] via 192.168.13.2, 00:24:19, GigabitEthernet0/1

O IA 192.168.120.0/24 [110/198] via 192.168.13.2, 00:23:54, GigabitEthernet0/1

O IA 192.168.121.0/24 [110/197] via 192.168.13.2, 00:23:54, GigabitEthernet0/1

 

I have configured virtual link between Router 3 and Router 5 , and in between Router 8 and Router 11.

 

between Router 3 and Router 5

Router>sh ip ospf virtual-links

Virtual Link OSPF_VL3 to router 5.5.5.5 is up

Run as demand circuit

Transit area 66, via interface Serial0/1/1, Cost of using 65

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:06

Adjacency State FULL

Index 1/2, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

 

In between 8 and 11

 

Router>sh ip ospf virtual-links

Virtual Link OSPF_VL1 to router 11.11.11.11 is up

Run as demand circuit

Transit area 76, via interface GigabitEthernet0/0, Cost of using 2

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

Hello due in 00:00:09

Adjacency State FULL

Index 1/2, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

 

 

 

 

WHILE.......

 

ROUTER 10 HAS ROUTE OF ALL.

 

 

Router>sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C 10.10.10.0/24 is directly connected, Loopback0

L 10.10.10.10/32 is directly connected, Loopback0

O IA 192.168.12.0/24 [110/199] via 192.168.120.2, 00:29:10, GigabitEthernet0/1

O IA 192.168.13.0/24 [110/198] via 192.168.120.2, 00:29:10, GigabitEthernet0/1

O IA 192.168.24.0/24 [110/197] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O IA 192.168.34.0/24 [110/197] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O IA 192.168.45.0/24 [110/133] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O 192.168.56.0/24 [110/132] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O 192.168.57.0/24 [110/132] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O 192.168.68.0/24 [110/68] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O 192.168.78.0/24 [110/68] via 192.168.120.2, 01:04:32, GigabitEthernet0/1

O IA 192.168.89.0/24 [110/4] via 192.168.120.2, 03:33:55, GigabitEthernet0/1

192.168.109.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.109.0/24 is directly connected, Serial0/1/0

L 192.168.109.2/32 is directly connected, Serial0/1/0

O IA 192.168.119.0/24 [110/3] via 192.168.120.2, 03:33:55, GigabitEthernet0/1

192.168.120.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.120.0/24 is directly connected, GigabitEthernet0/1

L 192.168.120.1/32 is directly connected, GigabitEthernet0/1

O 192.168.121.0/24 [110/2] via 192.168.120.2, 03:34:05, GigabitEthernet0/1

 

 

 

WHEN I HAVE CONFIGURED VIRTUAL LINK BETWEEN ROUTER 3 AND ROUTER 5 AND IN BETWEEN ROUTER 8 AND 11, WHY ROUTER 1 HAS NOT GETTING ROUTE OF AREA 76,  WHEREAS I AM ABLE TO PING ROUTER 12

 

Router1#ping 192.168.120.1

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.120.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 10/16/27 ms

 

 

BUT NOT ABLE TO GET ROUTE OF AREA 76 IN MY ROUTER 1

 

3 REPLIES 3
paul driver
VIP Mentor

Hello

You have a dis-contiguous OSPF backbone hence you required additional VL's to allow correct propagation of the ospf LSA's
rtr 8 require an additional VL with rtr 10
rtr 5 require an addtion VL with rtr 2



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Georg Pauwen
VIP Expert

Hello,

 

you can also configure a tunnel with IP addresses belonging to area 0 between R3 and R5, and R8 and R11, respectively.

 

Router3

 

interface Tunnel0
ip address 10.10.10.5 255.255.255.252
mtu 1476
tunnel source Serial0/1/1
tunnel destination 192.168.57.1
!
router ospf 1
network 10.10.10.4 0.0.0.3 area 0

 

Router5

 

interface Tunnel0
ip address 10.10.10.6 255.255.255.252
mtu 1476
tunnel source Serial0/1/1
tunnel destination 192.168.34.1
!
router ospf 1
network 10.10.10.4 0.0.0.3 area 0

 

Router8

 

interface Tunnel0
ip address 10.10.10.1 255.255.255.252
mtu 1476
tunnel source GigabitEthernet0/0
tunnel destination 192.168.119.2
!
router ospf 1
network 10.10.10.0 0.0.0.3 area 0

 

Router11

 

interface Tunnel0
ip address 10.10.10.2 255.255.255.252
mtu 1476
tunnel source GigabitEthernet0/1
tunnel destination 192.168.89.1
!
router ospf 1
network 10.10.10.0 0.0.0.3 area 0

 

@Georg Pauwen @FYI the VL’s of the abr’s become assigned to area0 they need to be as they as then are able to provide the reachability for other non backbone areas they are connecting to.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future