cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
223
Views
10
Helpful
3
Replies
Beginner

OSPF not preferred over EIGRP external routes Problem

image.png

R1 Configuration:

R1#sh run | s r e
router eigrp 10
network 10.1.12.1 0.0.0.0
network 10.1.13.1 0.0.0.0
redistribute static metric 1500 0 255 1 1500


R1#sh run | s r o
router ospf 10
redistribute static subnets
network 10.1.12.1 0.0.0.0 area 0
network 10.1.13.1 0.0.0.0 area 0
R1#

ip route 2.2.2.2 255.255.255.255 10.1.12.2

 

 

R2 Configuration:

R2#sh run | s r o
router ospf 10
network 10.1.12.2 0.0.0.0 area 0
R2#
R2#sh run | s r e
router eigrp 10
network 10.1.12.2 0.0.0.0
R2#

 

R3 configuration:

R3#sh run | s r e
router eigrp 10
network 10.1.13.3 0.0.0.0
R3#
R3#sh run | s r o
router ospf 1
network 10.1.13.3 0.0.0.0 area 0
R3#

 

Output from R3:

R3#sh ip route | b Ga
Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets
D EX 2.2.2.2 [170/1732096] via 10.1.13.1, 00:04:09, Ethernet1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.1.12.0/24 [90/307200] via 10.1.13.1, 00:04:14, Ethernet1/0
C 10.1.13.0/24 is directly connected, Ethernet1/0
L 10.1.13.3/32 is directly connected, Ethernet1/0
R3#

 

R3#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.13.1 Et1/0 12 00:04:41 56 336 0 11
R3#sh ip os ne
R3#sh ip os neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.13.1 1 FULL/DR 00:00:35 10.1.13.1 Ethernet1/0
R3#

 

 

R3#sh ip os database

OSPF Router with ID (3.3.3.3) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
2.2.2.2 2.2.2.2 605 0x80000002 0x00EBFB 1
3.3.3.3 3.3.3.3 616 0x80000003 0x00C11A 1
10.1.13.1 10.1.13.1 652 0x80000006 0x004C29 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.1.12.1 10.1.13.1 652 0x80000002 0x00EEF7
10.1.13.1 10.1.13.1 652 0x80000002 0x0016CB

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
2.2.2.2 10.1.13.1 652 0x80000002 0x00F86C 0
R3#

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: OSPF not preferred over EIGRP external routes Problem

Hi @shehab320 

 

The OSPF external route will not be installed because of the following reason. If you look at the 'show ip ospf database external 2.2.2.2' on R3 you will see that the forwarding address is chosen as 10.1.12.2. 

 

R3 sees 10.1.12.0/24 is as an EIGRP internal route with AD90. OSPF external route requires that if the forwarding address on the type 5 LSA is non-zero then it should have a route to it learned via OSPF intra or inter area. You will argue that OSPF does have a route to it, but because EIGRP AD 90 is preferred over OSPF 110, OSPF route is not preferred for the forwarding address. So the parent type 5 route is not installed in the routing table. 

 

Please rate this post and mark as resolved if you find this helpful.

 

-

Sebastian

 

 

 

 

 

 

 

 

3 REPLIES 3
Highlighted

Re: OSPF not preferred over EIGRP external routes Problem

Hi,
Please run "clear ip eigrp 10 neig" and check again. If you still get the same result, please share the output of "show ip ospf database external".

HTH,
Meheretab

Re: OSPF not preferred over EIGRP external routes Problem

Hi @shehab320 

 

The OSPF external route will not be installed because of the following reason. If you look at the 'show ip ospf database external 2.2.2.2' on R3 you will see that the forwarding address is chosen as 10.1.12.2. 

 

R3 sees 10.1.12.0/24 is as an EIGRP internal route with AD90. OSPF external route requires that if the forwarding address on the type 5 LSA is non-zero then it should have a route to it learned via OSPF intra or inter area. You will argue that OSPF does have a route to it, but because EIGRP AD 90 is preferred over OSPF 110, OSPF route is not preferred for the forwarding address. So the parent type 5 route is not installed in the routing table. 

 

Please rate this post and mark as resolved if you find this helpful.

 

-

Sebastian

 

 

 

 

 

 

 

 

Beginner

Re: OSPF not preferred over EIGRP external routes Problem

Thanks Sebastian, got it

 

Shehab

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards