cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5428
Views
5
Helpful
6
Replies
Highlighted
Not applicable

OSPF problem with two ABR

Hi experts,

We have a problem with an OSPF setup on which we see two routers, Pavas and Atenas who are in area 0, and they are ABRs for a router PZ who is in another area 56. The problem we see is that the conection between Pavas and PZ is intended to be a backup, and the connection Atenas-PZ is intended to be the main one. We set up an OSPF cost of 1000 between Pavas and PZ, but still Pavas prefers to send traffic directly to PZ instead of using Atenas.

The problem we have is that PZ does use Atenas as its exit point so we are seeing an assymetric flow on which Pavas sends the traffic directly to PZ and PZ answers back through Atenas.

What we want is to have Pavas sending the traffic to PZ via Atenas.

Configuration:

PZ:

interface Loopback0

description ADMIN

ip address 10.192.9.193 255.255.255.255

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface GigabitEthernet0/0

description TO PAVAS

dampening 30 75 2000 240

bandwidth 300000

ip address 10.X.X.62 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf network point-to-point

ip ospf cost 1000

ip ospf mtu-ignore

load-interval 30

carrier-delay msec 0

delay 1000

duplex full

speed 1000

media-type gbic

negotiation auto

!

interface GigabitEthernet1/0

description To ATENAS

dampening 30 75 2000 240

ip address 10.X.X.2 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf network point-to-point

carrier-delay msec 0

negotiation auto

!

router ospf 1805

router-id 10.192.9.193

log-adjacency-changes

auto-cost reference-bandwidth 100000

timers throttle spf 50 50 5000

timers lsa arrival 15

timers pacing flood 15

redistribute connected subnets

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet1/0

network 10.X.X.2 0.0.0.0 area 56

network 10.X.X.62 0.0.0.0 area 56

network 10.192.9.193 0.0.0.0 area 56

PZ#sh ip route 10.192.0.236

Routing entry for 10.192.0.236/32

  Known via "ospf 1805", distance 110, metric 201, type inter area

  Last update from 10.X.X.1 on GigabitEthernet1/0, 00:55:28 ago

  Routing Descriptor Blocks:

  * 10.X.X.1, from 10.192.0.251, 00:55:28 ago, via GigabitEthernet1/0 // IP of Atenas

      Route metric is 201, traffic share count is 1

ATENAS:

interface Loopback0

description Gestion_Equipo

ip address 10.192.0.251 255.255.255.255

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface GigabitEthernet0/0

description PAVAS

dampening 30 75 2000 240

ip address 10.X.X.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf network point-to-point

carrier-delay msec 0

duplex full

speed 1000

media-type gbic

negotiation auto

!

interface GigabitEthernet1/0

description TO PZ

dampening 30 75 2000 240

ip address 10.X.X.1 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf network point-to-point

carrier-delay msec 0

negotiation auto

!

router ospf 1805

router-id 10.192.0.251

log-adjacency-changes

auto-cost reference-bandwidth 100000

timers throttle spf 50 50 5000

timers lsa arrival 15

timers pacing flood 15

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet1/0

network 10.X.X.1 0.0.0.0 area 0

network 10.X.X.1 0.0.0.0 area 56

network 10.192.0.251 0.0.0.0 area 0

Atenas#sh ip route 10.192.9.193

Routing entry for 10.192.9.193/32

  Known via "ospf 1805", distance 110, metric 101, type intra area

  Last update from 10.X.X.2 on GigabitEthernet1/0, 01:02:36 ago

  Routing Descriptor Blocks:

  * 10.X.X.2, from 10.192.9.193, 01:02:36 ago, via GigabitEthernet1/0 // IP of PZ

      Route metric is 101, traffic share count is 1

Atenas#sh ip route 10.192.0.236

Routing entry for 10.192.0.236/32

  Known via "ospf 1805", distance 110, metric 101, type intra area

  Last update from 10.X.X.2 on GigabitEthernet0/0, 01:02:47 ago

  Routing Descriptor Blocks:

  * 10.X.X.2, from 10.192.0.236, 01:02:47 ago, via GigabitEthernet0/0 // IP of Pavas

      Route metric is 101, traffic share count is 1

Pavas:

interface Loopback0

description ADMIN

ip address 10.192.0.236 255.255.255.255

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface GigabitEthernet0/0

description TO ATENAS

dampening 30 75 2000 240

ip address 10.X.X.2 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf network point-to-point

carrier-delay msec 0

duplex full

speed 1000

media-type gbic

negotiation auto

!

interface GigabitEthernet1/0

description TO PZ

dampening 30 75 2000 240

ip address 10.X.X.61 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf network point-to-point

ip ospf cost 1000

ip ospf mtu-ignore

carrier-delay msec 0

negotiation auto

!

router ospf 1805

router-id 10.192.0.236

ispf

log-adjacency-changes

auto-cost reference-bandwidth 100000

timers throttle spf 50 50 5000

timers lsa arrival 15

timers pacing flood 15

passive-interface default

no passive-interface GigabitEthernet0/0

no passive-interface GigabitEthernet1/0

network 10.x.x.2 0.0.0.0 area 0

network 10.x.x.61 0.0.0.0 area 56

network 10.192.0.236 0.0.0.0 area 0

Pavas#sh ip route 10.192.9.193

Routing entry for 10.192.9.193/32

  Known via "ospf 1805", distance 110, metric 1001, type intra area

  Last update from 10.x.x.62 on GigabitEthernet1/0, 00:01:03 ago

  Routing Descriptor Blocks:

  * 10.x.x.62, from 10.192.9.193, 00:01:03 ago, via GigabitEthernet1/0 // IP PZ

      Route metric is 1001, traffic share count is 1

Pavas#sh ip route 10.192.0.251

Routing entry for 10.192.0.251/32

  Known via "ospf 1805", distance 110, metric 101, type intra area

  Last update from 10.x.x.1 on GigabitEthernet0/0, 00:01:12 ago

  Routing Descriptor Blocks:

  * 10.x.x.1, from 10.192.0.251, 00:01:12 ago, via GigabitEthernet0/0 // IP Atenas

      Route metric is 101, traffic share count is 1

Any additional information, please request me.

Thanks for you help!

Kenneth Rodriguez

Costa Rica.

Everyone's tags (4)
6 REPLIES 6
Highlighted
Rising star

Re: OSPF problem with two ABR

If an ABR needs to send traffic to an attached area it will do so without sending traffic to the backbone interface. This traffic becomes intra-area traffic on Pavas and no backbone transit is necessary.

HTH.

Highlighted
Not applicable

OSPF problem with two ABR

I know that, but the connection Pavas-Pz via "Radios" have a bandwidth of 300mbps and via Atenas is of 1gbps, for that reason i want ospf to prefer it...

Thanks

Kenneth Rodriguez

Highlighted
Hall of Fame Guru

Re: OSPF problem with two ABR

The essence of the problem is that both ABR see each other only through area 0. To achieve your intention of having a backup path both ABR will need to see each other over a path that is in area 56. The easy way to do this would be to configure a tunnel between them and put the tunnel in area 56.

HTH

Rick

Sent from Cisco Technical Support iPhone App

HTH

Rick
Highlighted
VIP Expert

Re: OSPF problem with two ABR

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Both Rais and Rick have identified the problem, i.e. once traffic is on Pavas, traffic to Area 56 will flow out on the interface in that area in preference to even a lower cost Area 0 path.

Rick has also identified the typical solution, provide a better Area 56 "link" between Pavas and Atenas than between Pavas and PZ.

Besides Rick's suggestion of using a tunnel, another possible option might be trunking the Pavas and Atenas link so you can have both a logical Area 0 and Area 56 link across it.

Highlighted

OSPF problem with two ABR

joseph is right

Highlighted

Re: OSPF problem with two ABR

I have performed a small lab in packet tracer and observed below things :

 

In my topology its working as expected to reach 3.3.3.3 which is in R3 my R1 is taking via Area1 and R2 is taking via Area1. 

 

When i increase the cost of the interface on R2 connecting R3 to 100 the path changes via R1 for 3.3.3.3 in R2.

 

Below are the output. 

 

Normal working

-------------

R2 : 

 

Gateway of last resort is not set

3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 23.0.0.3, 00:00:14, FastEthernet0/1
C 12.0.0.0/8 is directly connected, FastEthernet0/0
O IA 13.0.0.0/8 [110/2] via 12.0.0.1, 00:19:11, FastEthernet0/0
[110/2] via 23.0.0.3, 00:00:14, FastEthernet0/1
C 23.0.0.0/8 is directly connected, FastEthernet0/1

 

Router(config)#interface fa0/1
Router(config-if)#ip ospf cost 100


without clearing the ospf process. 

3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 23.0.0.3, 00:01:19, FastEthernet0/1
C 12.0.0.0/8 is directly connected, FastEthernet0/0
O 13.0.0.0/8 [110/2] via 23.0.0.3, 00:01:19, FastEthernet0/1
C 23.0.0.0/8 is directly connected, FastEthernet0/1

 

after - clear the ospf process.


3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/3] via 12.0.0.1, 00:00:20, FastEthernet0/0
C 12.0.0.0/8 is directly connected, FastEthernet0/0
O IA 13.0.0.0/8 [110/2] via 12.0.0.1, 00:00:20, FastEthernet0/0
C 23.0.0.0/8 is directly connected, FastEthernet0/1
Router#

 

 

 

Please do not hesitate to click the STAR button if you are satisfied with my answer.