cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
300
Views
5
Helpful
6
Replies
Highlighted

OSPF route tag 10

Hi guys!

please do consider my topology: map-1.png

 

 

 

And my issue:

On Branch Router's i have output of command:

#sh ip route 0.0.0.0 
Routing entry for 0.0.0.0/0, supernet
  Known via "ospf 10", distance 110, metric 1, candidate default path
  Tag 10, type extern 2, forward metric 10
  Last update from 172.19.74.170 on GigabitEthernet0/0, 4w6d ago
  Routing Descriptor Blocks:
  * 172.19.74.170, from 172.19.74.245, 4w6d ago, via GigabitEthernet0/0
      Route metric is 1, traffic share count is 1
      Route tag 10

My interesting int line: Route tag 10

I didnt find any configurations about tag on Core Router:

router ospf 10
 router-id 172.19.74.245
 passive-interface default
 no passive-interface GigabitEthernet0/1.47
 no passive-interface GigabitEthernet0/1.75
 no passive-interface GigabitEthernet0/1.107
 no passive-interface GigabitEthernet0/1.177
 no passive-interface GigabitEthernet0/1.666
 no passive-interface GigabitEthernet0/1.667
 no passive-interface GigabitEthernet0/1.1412
 no passive-interface GigabitEthernet0/1.1413
 no passive-interface GigabitEthernet0/1.1414
 no passive-interface GigabitEthernet0/1.1415
 no passive-interface Tunnel0
 network 10.100.100.0 0.0.0.255 area 0
 network 10.100.101.0 0.0.0.1 area 0
 network 10.100.101.2 0.0.0.1 area 0
 network 172.16.68.168 0.0.0.7 area 0
 network 172.16.124.24 0.0.0.3 area 0
 network 172.19.74.168 0.0.0.1 area 0
 network 172.19.74.170 0.0.0.1 area 0
 network 172.19.74.184 0.0.0.1 area 0
 network 172.19.74.224 0.0.0.7 area 0
 network 172.19.74.245 0.0.0.0 area 0
 network 172.19.74.246 0.0.0.1 area 0
 network 172.19.74.248 0.0.0.1 area 0
 network 172.19.74.250 0.0.0.1 area 0
 network 172.19.74.252 0.0.0.1 area 0
 network 172.19.74.254 0.0.0.1 area 0
 network 172.19.75.16 0.0.0.1 area 0
 network 192.168.4.0 0.0.0.255 area 0
 network 192.168.111.0 0.0.0.255 area 0
 network 192.168.112.0 0.0.0.255 area 0
 default-information originate

But i have static default in direction to my ISP( peer  to peer link with him)

ip route 0.0.0.0 0.0.0.0 10.1.1.1



And my question:

Where from my Branch Router did the take in tag 10  on route to 0.0.0.0/0

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi Ivan,

 

 

tag   tag-value | (Optional) 32-bit dotted-decimal value attached to each external route. This is not used by the OSPF protocol itself. It may be used to communicate information between autonomous system boundary routers (ASBRs). If a tag is not specified, then the configured OSPF process number is used.

 

you can find above reference under IOS XR documentation, as tag option for IOS default-information originate command is parameter configurable within route-map construct, but concept should be the same.

 

 

 

Regards.

View solution in original post

6 REPLIES 6
Highlighted
Cisco Employee

Hi Ivan,

 

the route tag should correspond to the ospf PID of your routing domain, that's why you see external default tagged with 10.
Could you try to alter the process-id to confirm it is expected behavior ?

 

 

 

Regards

Highlighted

Hi pigallo,

 

thanks for you reply

 

unfortunately i cannot change OSPF pid because it is production environment.

Do you have any referring for approving ?

Highlighted

Hi Ivan,

 

 

tag   tag-value | (Optional) 32-bit dotted-decimal value attached to each external route. This is not used by the OSPF protocol itself. It may be used to communicate information between autonomous system boundary routers (ASBRs). If a tag is not specified, then the configured OSPF process number is used.

 

you can find above reference under IOS XR documentation, as tag option for IOS default-information originate command is parameter configurable within route-map construct, but concept should be the same.

 

 

 

Regards.

View solution in original post

Highlighted

Thank you so much, Pigallo!

It exactly that im searching.

But of course i forgot\lazy about RTFM)

Highlighted

privet, ivan

 

sorry, if this not really answering your question.. did you already check on that router with the following command

#show ip ospf interface brief

the second column 'PID' should list PID 10 that corresponds to tag 10?

 

Highlighted


@kstatinet wrote:

privet, ivan

 

sorry, if this not really answering your question.. did you already check on that router with the following command

#show ip ospf interface brief

the second column 'PID' should list PID 10 that corresponds to tag 10?

 


yes, it's true, but i didn't  know about

If a tag is not specified, then the configured OSPF process number is used.