cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
564
Views
10
Helpful
8
Replies

Particular application has to be given limited bandwidth by using QOS

Hi,

I want to limit the bandwidth one of the particular application in my router by using QOS and I have configured the QOS  but It is not working as I need.

 

Please find the below configuration and suggest.

1.SMTP sholud not take more than 20 k whereas as per below configuration,each conversation it takes below 20 k.

For example.

A. 2.2.2.2/24 to 4.4.4.4/24--------------19 k bandwidth

B.2.2.2.3/24 to 4.4.4.5/24----------------15 K bandwidth

 

 

Configuration

class-map match-all SMTP

match protocol smtp

Policy-map qostest

class SMTP

shape average 20000

int g0/0

service-policy output qostest

 

please check the above config and suggest that how to limit the bandwidth all the conversation should not exceed 20k

 

1 ACCEPTED SOLUTION

Accepted Solutions
paul driver
VIP Mentor

Hello

When your shaping your really shouldn't see much drops as shaping queues traffic so as not to drop it, so clear your interface counters just to make sure your not seeing historic rates.

Also having an load interval of 5 minutes wont really give you a good representation of the actual traffic rate, so suggest also to decrease this for testing purposes and review again

 

Saying that if you wish to allow only 19K to smtp try the below config.

access-list 100 permit tcp host 2.2.2.2 host 4.4.4.4 eq 25
access-list 101 permit tcp host 2.2.2.3 host 4.4.4.5 eq 25

Class-MAP 2-4
match access-group 100

Class-MAP 3-5
match access-group 101

policy-map qostest
class 2-4
Bandwidth 19
class 3-4
Bandwidth 19
class class-default
fair-queue

clear counter x/x
int x/x
load interval 30
service-policy output qostest


res
Paul

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

8 REPLIES 8
Julio E. Moisa
VIP Mentor

Hi,

What you see through: show policy-map interface g0/0




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

 

Hi,

Please find the my results.

I could see in my router,whatever bandwidth limited,whereas my whatsup gold is not showing properly.Instead it is showing each conversation 20k limitation.

 

Router#sh traffic-shape queue g0/0

Traffic queued in shaping queue on GigabitEthernet0/0

 Traffic shape class: SMTP

  Queueing strategy: weighted fair

  Queueing Stats: 2/1000/64/0 (size/max total/threshold/drops)

     Conversations  2/3/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 20 kilobits/sec

 

  (depth/weight/total drops/no-buffer drops/interleaves) 1/32384/0/0/0

  Conversation 1, linktype: ip, length: 74

  source: 17x.17.x.x, destination: 172.1x.x.x, id: 0x3101, ttl: 123, prot: 1

 

  (depth/weight/total drops/no-buffer drops/interleaves) 1/32384/0/0/0

  Conversation 15, linktype: ip, length: 1514

  source: 172.x.x.x, destination: x.x.x.x, id: 0x7F51, ttl: 255, prot: 1

---------------------------------------------------------------

Router#sh policy-map int g0/0
 
  Service-policy output: qostest

    Class-map: SMTP (match-all)
      34455 packets, 3670268 bytes
      5 minute offered rate 10000 bps, drop rate 1000 bps
      Match: protocol smtp
        34455 packets, 3670268 bytes
        5 minute rate 10000 bps
      Traffic Shaping
           Target/Average   Byte   Sustain   Excess    Interval  Increment
             Rate           Limit  bits/int  bits/int  (ms)      (bytes)  
             20000/20000      2000   8000      8000      1000      1000     

        Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
        Active Depth                         Delayed   Delayed   Active
        -      68        29516     3077210   28238     2942052   yes

    Class-map: class-default (match-all)
      79080 packets, 11898751 bytes
      5 minute offered rate 24000 bps, drop rate 0 bps
      Match: all

 

Actually I think your shaping is working:

 

Class-map: SMTP (match-all)
34455 packets, 3670268 bytes
5 minute offered rate 10000 bps, drop rate 1000 bps

 

Not sure why WhatsUp Gold is showing the per flow limitation...

Your stats indicate shaping is working. In fact, the posted stats show shaping active, 68 packets currently queued, and packets have been delayed.

I suspect your What's up Gold is "confused" by the QoS policy and is incorrectly showing the shaping per conservation.

paul driver
VIP Mentor

Hello

When your shaping your really shouldn't see much drops as shaping queues traffic so as not to drop it, so clear your interface counters just to make sure your not seeing historic rates.

Also having an load interval of 5 minutes wont really give you a good representation of the actual traffic rate, so suggest also to decrease this for testing purposes and review again

 

Saying that if you wish to allow only 19K to smtp try the below config.

access-list 100 permit tcp host 2.2.2.2 host 4.4.4.4 eq 25
access-list 101 permit tcp host 2.2.2.3 host 4.4.4.5 eq 25

Class-MAP 2-4
match access-group 100

Class-MAP 3-5
match access-group 101

policy-map qostest
class 2-4
Bandwidth 19
class 3-4
Bandwidth 19
class class-default
fair-queue

clear counter x/x
int x/x
load interval 30
service-policy output qostest


res
Paul

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Thank u Paul Driver for your reply.

 

I want to limit entire smtp should be limited 20k,whoever passing through this link.(router int g0/0)

 

Moreover, is it required these commands,please explain.

class class-default
fair-queue

 

hello

 


@Kolanjiyappan Kaliyamoorthy wrote:

Thank u Paul Driver for your reply.

 

I want to limit entire smtp should be limited 20k,whoever passing through this link.(router int g0/0)

Amend the acl to accommodate any traffic

ip accces-list extended 100
no 10
no 20
10 permit tcp any any eq 25

 

Moreover, is it required these commands,please explain.

class class-default
fair-queue

 

Fair queue (WFQ) is for your traffic which cannot or has not been characterize in any class map and is left to use the default queue ( class-default) where it can allocated some fairness of BW to the default traffic queue

 

res
Paul


 

 

 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Georg Pauwen
VIP Expert

I lost track of the entire thread, but your initial configuration is working. The problem seems to be the way WhatsUp Gold is reporting and displaying the flows. Can you maybe provide a screenshot of the relevant WhatsUp Gold information that is being collected ?