11-09-2022 05:27 PM - last edited on 11-10-2022 01:07 AM by Translator
If we have PBR command like below :
set ip next-hop verify-availability A.A.A.A 1 track 1
set ip next-hop verify-availability B.B.B.B 2 track 2
set ip next-hop verify-availability C.C.C.C 3 track 3
The traffic will be re-route to B.B.B.B if track 1 down, am i right?
If track 1 coming up, will the traffic re-route back to A.A.A.A or still use B.B.B.B?
Solved! Go to Solution.
11-09-2022 11:48 PM
as per your theory yes, it fails to B if A not reachable, Once A reachable it should fail back to A - subject to your configuration of IP sla and tracking.
post complete configuration
below example help you :
https://packetpushers.net/using-ip-sla-delay-feature-to-safely-monitor-lossy-links/
11-09-2022 11:48 PM
as per your theory yes, it fails to B if A not reachable, Once A reachable it should fail back to A - subject to your configuration of IP sla and tracking.
post complete configuration
below example help you :
https://packetpushers.net/using-ip-sla-delay-feature-to-safely-monitor-lossy-links/
11-10-2022 01:15 AM
Hello,
I just lab-tested your setup in GNS3, if your config looks like below (IP addressing is arbitrary, obviously), it should work as intended.
ip cef
!
track 1 ip sla 1 reachability
!
track 2 ip sla 2 reachability
!
track 3 ip sla 3 reachability
!
interface GigabitEthernet0/0
ip address 1.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
ip address 2.2.2.1 255.255.255.252
!
interface GigabitEthernet0/2
ip address 3.3.3.1 255.255.255.252
!
interface GigabitEthernet0/3
ip address 192.168.1.1 255.255.255.0
ip policy route-map PBR
!
ip sla 1
icmp-echo 1.1.1.2 source-interface GigabitEthernet0/0
threshold 300
timeout 500
frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo 2.2.2.2 source-interface GigabitEthernet0/1
threshold 300
timeout 500
frequency 5
ip sla schedule 2 life forever start-time now
ip sla 3
icmp-echo 3.3.3.2 source-interface GigabitEthernet0/2
threshold 300
timeout 500
frequency 5
ip sla schedule 3 life forever start-time now
!
route-map PBR permit 10
match ip address 101
set ip next-hop verify-availability 1.1.1.2 10 track 1
set ip next-hop verify-availability 2.2.2.2 20 track 2
set ip next-hop verify-availability 3.3.3.2 30 track 3
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 host 8.8.8.8
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide