cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
433
Views
0
Helpful
8
Replies
Highlighted
Beginner

Performing an IOS upgrade, but having trouble between laptop and router.

Hello everyone.

Im trying to upgrade an IOS and the Strangest thing is happening to me at home today. I CAN ping the router from my laptop, but
I can't ping the laptop from my router. I am directly connected to the router F0/0. I swapped cabling from xover to straight and still no ping.
I even tried adding default gateway, but nothing works. No firewall is enabled on my laptop. Am I missing something?


Home Network 192.168.1.0 /24

Router IP: 192.168.1.254

BB1_Termserver#

interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
speed 100
full-duplex

__________________________

C    192.168.1.0/24 is directly connected, FastEthernet0/0

BB1_Termserver#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Laptop IP: 192.168.1.2


C:\Documents and Settings\sancmar>route print

===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0      192.168.1.2     192.168.1.2       20
      192.168.1.2  255.255.255.255        127.0.0.1       127.0.0.1       20
    192.168.1.255  255.255.255.255      192.168.1.2     192.168.1.2       20
        224.0.0.0        240.0.0.0      192.168.1.2     192.168.1.2       20
  255.255.255.255  255.255.255.255      192.168.1.2     192.168.1.2       1
  255.255.255.255  255.255.255.255      192.168.1.2               2       1
===========================================================================
Persistent Routes:
  None

C:\Documents and Settings\sancmar>ping 192.168.1.254

Pinging 192.168.1.254 with 32 bytes of data:

Reply from 192.168.1.254: bytes=32 time=1ms TTL=255
Reply from 192.168.1.254: bytes=32 time=1ms TTL=255
Reply from 192.168.1.254: bytes=32 time=1ms TTL=255
Reply from 192.168.1.254: bytes=32 time=1ms TTL=255

Ping statistics for 192.168.1.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

+++++++++++++++++++++++++++++++++

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Intel(R) 82567LM Gigabit Network Con
nection
        Physical Address. . . . . . . . . : 00-24-7E-14-DE-EA

BB1_Termserver#sh ip arp f0/0
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.254           -   000d.bd1a.f4e0  ARPA   FastEthernet0/0
*************************************************************************************************

C:\Documents and Settings\sancmar>ping 192.168.1.254

Pinging 192.168.1.254 with 32 bytes of data:

Reply from 192.168.1.254: bytes=32 time=27ms TTL=64
Reply from 192.168.1.254: bytes=32 time=6ms TTL=64
Reply from 192.168.1.254: bytes=32 time=3ms TTL=64
Reply from 192.168.1.254: bytes=32 time=5ms TTL=64

Ping statistics for 192.168.1.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 3ms, Maximum = 27ms, Average = 10ms

C:\Documents and Settings\sancmar>arp -a

Interface: 192.168.1.4 --- 0x2
  Internet Address      Physical Address      Type
  192.168.1.254         00-25-9c-d9-a1-dc     dynamic

BB1_Termserver#sh int f0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 000d.bd1a.f4e0 (bia 000d.bd1a.f4e0)
  Internet address is 192.168.1.254/24


ANy ideas??

8 REPLIES 8
Highlighted
Hall of Fame Master

Re: Performing and IOS upgrade, but having trouble between lapto

This is a pretty wierd situation as described so far. I would suggest that you do the ping from the laptop again and follow it immediately by arp -a. This should have in the PC ARP table the MAC for who answered the ping. I would be curious to know if the MAC is the one found on the router f0/0.

HTH

Rick

HTH

Rick
Highlighted
Beginner

Re: Performing and IOS upgrade, but having trouble between lapto

Hi Richard -

I just checked arp -a.. and the MAC is not from the router interface. Strange!  192.168.1.4 is responding!

Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    192.168.1.254     192.168.1.4       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
      192.168.1.0    255.255.255.0      192.168.1.2     192.168.1.2       20
      192.168.1.0    255.255.255.0      192.168.1.4     192.168.1.4       20
      192.168.1.2  255.255.255.255        127.0.0.1       127.0.0.1       20
      192.168.1.4  255.255.255.255        127.0.0.1       127.0.0.1       20
    192.168.1.255  255.255.255.255      192.168.1.2     192.168.1.2       20
    192.168.1.255  255.255.255.255      192.168.1.4     192.168.1.4       20
        224.0.0.0        240.0.0.0      192.168.1.2     192.168.1.2       20
        224.0.0.0        240.0.0.0      192.168.1.4     192.168.1.4       20
  255.255.255.255  255.255.255.255      192.168.1.2     192.168.1.2       1
  255.255.255.255  255.255.255.255      192.168.1.4     192.168.1.4       1
Default Gateway:     192.168.1.254
===========================================================================
Persistent Routes:
  None

C:\Documents and Settings\sancmar>ping 192.168.1.254

Pinging 192.168.1.254 with 32 bytes of data:

Reply from 192.168.1.254: bytes=32 time=7ms TTL=64
Reply from 192.168.1.254: bytes=32 time=4ms TTL=64
Reply from 192.168.1.254: bytes=32 time=3ms TTL=64
Reply from 192.168.1.254: bytes=32 time=2ms TTL=64

Ping statistics for 192.168.1.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)
Approximate round trip times in milli-seconds:
    Minimum = 2ms, Maximum = 7ms, Average = 4ms

C:\Documents and Settings\sancmar>arp -a

Interface: 192.168.1.4 --- 0x2
  Internet Address      Physical Address      Type
  192.168.1.254         00-25-9c-d9-a1-dc     dynamic

Highlighted
Beginner

Re: Performing and IOS upgrade, but having trouble between lapto

Hi All -

Now my arp on laptop looks correct but I am still unable to ping :-(

Active Routes:
Network Destination        Netmask          Gateway      Interface  Metric
          0.0.0.0          0.0.0.0    192.168.1.254    192.168.1.2      20
        127.0.0.0        255.0.0.0        127.0.0.1      127.0.0.1      1
      192.168.1.0    255.255.255.0      192.168.1.2    192.168.1.2      20
      192.168.1.2  255.255.255.255        127.0.0.1      127.0.0.1      20
    192.168.1.255  255.255.255.255      192.168.1.2    192.168.1.2      20
        224.0.0.0        240.0.0.0      192.168.1.2    192.168.1.2      20
  255.255.255.255  255.255.255.255      192.168.1.2    192.168.1.2      1
  255.255.255.255  255.255.255.255      192.168.1.2              2      1
Default Gateway:    192.168.1.254
===========================================================================
Persistent Routes:
  None

LAPTOP

C:\Documents and Settings\sancmar>ping 192.168.1.254

Pinging 192.168.1.254 with 32 bytes of data:

Reply from 192.168.1.254: bytes=32 time=1ms TTL=255
Reply from 192.168.1.254: bytes=32 time=1ms TTL=255
Reply from 192.168.1.254: bytes=32 time=1ms TTL=255
Reply from 192.168.1.254: bytes=32 time=1ms TTL=255

Ping statistics for 192.168.1.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Documents and Settings\sancmar>arp -a

Interface: 192.168.1.2 --- 0x3
  Internet Address      Physical Address      Type
  192.168.1.254        00-0d-bd-1a-f4-e0    dynamic

ROUTER

BB1_Termserver>sh ip arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.2             7   0024.7e14.deea  ARPA   FastEthernet0/0
Internet  192.168.1.254           -   000d.bd1a.f4e0  ARPA   FastEthernet0/0

BB1_Termserver>sh int f0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 000d.bd1a.f4e0 (bia 000d.bd1a.f4e0)
  Internet address is 192.168.1.254/24

BB1_Termserver>ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

UNBELIEVABLE!!! Directly connected and nothing! Layer 2 looks good now, but Layer 3 is not working.

Here is my config on router..Really basic:

BB1_Termserver#sh run
Building configuration...

Current configuration : 545 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BB1_Termserver
!
!
ip subnet-zero
!!
interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
speed 100
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
ip classless
ip http server
ip pim bidir-enable
!
!
!
line con 0
line 33 64
line aux 0
line vty 0 4
login
!
!
end

BB1_Termserver#

BB1_Termserver#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, FastEthernet0/0
BB1_Termserver#

Highlighted
Beginner

Re: Performing and IOS upgrade, but having trouble between lapto

Try from another host on the network to ping your laptop, it's probably not responsive to ICMP for one reason or another.

Also, why do you really care whether ICMP is working? If you can get replies there is obviously 2 way connectivity and I'd be willing to bet even though you can't ping from the router to the laptop, you'd still be able to hit a TFTP service running on the laptop. This has sometimes been the case for me when emulating a router and using GNS3 and a loopback adapter bound to the network cloud.

Highlighted
Beginner

Re: Performing and IOS upgrade, but having trouble between lapto

Hi Josh -

Nope TFTP is not working. ICMP is not blocked...It is as basic as it gets. one laptop connected to one router directly connected. Ill try another Laptop.

Thanks for the info, but I already tried TFTP and it did not work ..really strange!

Thanks

Maria

Highlighted
Beginner

Re: Performing and IOS upgrade, but having trouble between lapto

Hey Maria.

Yeah, that is strange.

I wonder if it would be worthwhile running Wireshark in the background while running the pings/TFTP connection attempts? That way you can see if you're discarding packets for one reason or another or if something similarly suspect is happening.

Either way, let me know how you get on. Am eager to hear how you solved it and what the root cause was.

Cheers,

Josh.

Highlighted
Cisco Employee

Re: Performing and IOS upgrade, but having trouble between lapto

Hello,

I realize that currently you are using a straight-through cable to connect

these two devices. Have you tried TFTP when cross-over cable was connected?

To verify two-way connectivity, let us try the following:

On the Router, create a loopback interface and give it an IP (say

172.16.1.1/24)

On the PC, set the router as the default gateway

Now ping the 172.16.1.1 address. See if that ping is successful. If it is,

then let us move to the next step:

On the router, check the arp cache (show arp | include 192.168.1.2) and see

the MAC. Make sure that it is the MAC of the laptop. If there is no MAC,

please add a static entry (arp 192.168.1.2 arpa) and see if the

communication is going through.

Hope this helps.

Regards,

NT

Highlighted
Beginner

Re: Performing and IOS upgrade, but having trouble between lapto

Hello Najaraja -

I have a crossover connected...that was the very first thing I checked!!  I will place wireshark and see what is going on. On both my router and my laptop i see the MAC's. My configuration is very basic. Ill test this ptroblem with wireshark tomorrow.

Thanx

Maria Esturao