cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
344
Views
30
Helpful
19
Replies
Highlighted
Beginner

PIM Routing problem

Hi I have set up PIM sparse mode between some sites. Site 1,2,3 and 4. On site 1 I get the multicast service from provider, and have set up an RP. Site 2 is behind site 1, and site 3 and 4 is behind site 2. First I set up separate VLANs with linknets from each site to RP. This works, but multicast traffic is tripled between site 1 and 2 (takes to much bandwidth). About 400Mbps to site 2, 100Mbps to site 3 and 4, that gave 600Mbps between site 1 and 2. Then I though I would set up just one VLAN, and have each site be a member of this, and set site 2 as DR (highest priority). Now multicast traffic between 1 and 2 is ok, around 400Mbps, but traffic to the smaller sites 3 and 4 grew a lot. It is almost like traffic is flooded to these sites also, even though there are few users there. Before doing this (when using separate VLANs) I had about 100Mbps multicast to these sites (3 and 4), now it is around 400Mbps (pretty much same as site 2). Problem is that I have limited capacity between the sites, and want to make most use of it. Any ideas what I have done wrong here?
19 REPLIES 19
Highlighted
Hall of Fame Cisco Employee

Hi,The picture you have

Hi,

The picture you have posted looks like an ordinary connection of four routers where no multicast should become multiplied. However, in your description, you have mentioned that you have set up several VLANs (and then got back to just one). How do the VLANs apply to your topology? The picture does not suggest where the VLANs are and how they apply to your network. Can you please clarify this? Ideally, it would be helpful to see a picture of your physical topology (please be sure to use router icons only where true routers are used, and multilayer switch icons where L3 switches are used), and an accompanying picture of your logical topology that shows the individual VLANs as they span across your network, including the devices where the VLANs are terminated.

Best regards,
Peter

Highlighted
Beginner

Hi Peter.

Hi Peter. You are right, it was not a good description. These are L3 (3750) switches, the topology in the drawing is physical, and the VLAN spans all switches.
Highlighted
Hall of Fame Guru

Hope Peter doesn't mind me

Hope Peter doesn't mind me joining in, we don't get involved in many of the same threads these days :-)

Firstly before anything else it should be noted it is not the number of users at each site that affects how much traffic is sent it is the number of streams requested.

So by the sounds of your description when you had multiple vlans you had subinterfaces on the RP for these vlans ?

If that is the case that would explain the extra traffic on the link because each site could be requesting the same stream. What is interesting though is you say that sites 3 and 4 only actually received about 100Mbps.

What is confusing then (to me at least) is why when you had one vlan the traffic to sites 3 and 4 increased so much because IGMP snooping on the site 2 switch should know which streams are requested from sites 3 and 4 and so the bandwidth used should not have increased.

I'm assuming you didn't disable IGMP snooping which I can't see why you would and it is enabled by default as far as I know.

I suspect a solution may be to connect all switches together using L3 routed links, which would mean routing vlans locally on each switch, and then run PIM on all switches so the site 3 and 4 switches request the stream from the site 2 switch but I would like to understand why there was such an increase in bandwidth.

Note that the solution above may not solve the issue and it would involve adding routing etc. so it would be better if we could get to the bottom of why it behaves differently depending on the number of vlans used.

Peter, any ideas ?

Jon

Highlighted
Beginner

I have a linknet in the VLAN,

I have a linknet in the VLAN, and run PIM there. ip pim vrf IPTV rp-address 10.0.10.134 ip pim vrf IPTV autorp listener EDIT, sorry about formating in these posts, the are perfectly formated until I post them. interface Vlan1126 ip vrf forwarding IPTV ip address 10.20.0.4 255.255.255.240 ip pim dr-priority 11 ip pim sparse-mode
Highlighted
Hall of Fame Guru

Sorry but what is a "linknet"

Sorry but what is a linknet ?

Jon

Highlighted
Beginner

Just a small subnet I use for

Just a small subnet I use for static routes between the L3 switches, for the IPTV STBs...
Highlighted
Beginner

You are right. This is a

You are right. This is a small part of a rather complex network. But I thought we could keep it concentrated around the multicast part, in this case. I will post all configuration around this, and see if you can make anything of it. By the way thank you both for taking the time to look at it :)
Beginner

This is how multicast is

This is how multicast is configured now between the sites:

This is PIM config on RP (1).
Here interface gig3 is uplink for IPTV provider.
And on interface gig1 there is a trunk to DR (2), where among many others VLAN200 is transported.

ip vrf IPTV
 rd 1:2

ip multicast-routing vrf IPTV distributed

interface GigabitEthernet1/0/3
 description IPTV Prov
 no switchport
 ip vrf forwarding IPTV
 ip address 10.0.250.2 255.255.255.252
 ip pim sparse-mode
 ip multicast boundary IPTV_RP_ACL

interface Vlan200
 ip vrf forwarding IPTV
 ip address 10.20.0.1 255.255.255.240
 ip pim sparse-mode

ip pim vrf IPTV rp-address 10.0.10.134
ip msdp vrf IPTV peer 10.123.100.209 connect-source Loopback0
ip msdp vrf IPTV description 10.123.100.209 #IPTV RP#
ip msdp vrf IPTV cache-sa-state

ip access-list standard IPTV_RP_ACL
 deny   224.0.1.39
 deny   224.0.1.40
 permit any

 

This is PIM config on DR (2).
Here interface gig1 is a trunk to RP (1).
Interface gig2 is a trunk to Router (3), and interface gig3 is a trunk to Router (4).

ip vrf IPTV
 rd 1:2

ip multicast-routing vrf IPTV distributed

interface Vlan200
 ip vrf forwarding IPTV
 ip address 10.20.0.2 255.255.255.240
 ip pim dr-priority 11
 ip pim sparse-mode

ip pim vrf IPTV rp-address 10.0.10.134
ip pim vrf IPTV autorp listener

 

This is PIM config on Router (3).
Here interface gig1 is a trunk to DR (2).

ip vrf IPTV
 rd 1:2

ip multicast-routing vrf IPTV distributed

interface Vlan200
 ip vrf forwarding IPTV
 ip address 10.20.0.3 255.255.255.240
 ip pim dr-priority 1
 ip pim sparse-mode

ip pim vrf IPTV rp-address 10.0.10.134
ip pim vrf IPTV autorp listener

 

This is PIM config on Router (4).
Here interface gig1 is a trunk to DR (2).

ip vrf IPTV
 rd 1:2

ip multicast-routing vrf IPTV distributed

interface Vlan200
 ip vrf forwarding IPTV
 ip address 10.20.0.4 255.255.255.240
 ip pim dr-priority 1
 ip pim sparse-mode

ip pim vrf IPTV rp-address 10.0.10.134
ip pim vrf IPTV autorp listener

 

Before this setup I had a similar setup, but with one VLAN connecting each site to RP instead of only VLAN 200 as now. When using one VLAN for each site multicast traffic between 2 <-> 3 and 2 <-> 4 where low, but traffic between 1 <-> 2 where unnecessary high (as you point out, as streams had to be duplicated in each VLAN.

Using current setup multicast traffic between 1 <-> 2 is as it should be (no unnecessary duplicate streams), but between 2 <-> 3 and 2 <-> 4 multicast traffic is pretty much the same as between 1 <-> 2.

Highlighted
Hall of Fame Guru

Thanks for the details.Some

Thanks for the details.

Some follow up questions -

1) you say vlan 200 is among many vlans on the trunk. Do all the other vlans carry multicast traffic and are they all configured on each switch the same way ?

2) the vlan 200 setup. Is this just a transit vlan or are there clients in that vlan at each site.

If there are clients does each client point to the SVI IP for vlan 200 on their local switch ?

3) the amount of traffic sent is down to the number of groups requested.

Are you therefore saying that sites 3 and 4 request fewer groups ie. when you had multiple vlans there was less traffic to these sites.

Jon

Highlighted
Beginner

1) This VLAN is the only

1) This VLAN is the only multicast VLAN in the trunks.

2) It is just for transport, no clients in this VLAN. Clients connect to other VLANs on each site.

3) When using separate VLANs for multicast transport to each site, the multicast traffic to site 3 and 4 was a lot less. After the change to one VLAN I can see in graphs that the traffic to each site is pretty much the same (as in the same amount to each site, not individual and less to site 3 and 4 as before), this happened in an instance, so it`s not increased use of the multicast service by users. On the upside, the traffic between site 1 and 2 was a lot less.

I thought that with this setup only necessary groups would be sent to each router. But obviously this did not work.

Any idea on how to best configure this distribution?

Highlighted
Hall of Fame Guru

Sorry I should have asked

Sorry I should have asked this before.

Are the client vlans routed locally on each switch ?

I ask because your connections between switches are trunks which suggests multiple vlans between each switch.

If you do have multiple vlans shared between the sites and there are clients in those vlans do any of those clients request multicast streams ?

Jon

Highlighted
Beginner

The client VLANs only exist

The client VLANs only exist on switches locally. None are shared between the switches, or exist on the trunks between the sites.

Highlighted
Hall of Fame Guru

I think what is happening is

I think what is happening is that the site 2 switch is running IGMP snooping and knows that the ports connecting to sites 3 and 4 are mrouter ports ie. it has seen PIM messages on those ports.

So any multicast traffic received in vlan 200 by the site 2 switch is going to be sent across the trunk links to site 3 and site 4 even if there are no receivers requesting the stream.

That is my best guess at the moment.

If that is correct the solution is not to have a common vlan for transit between the sites.

How you do this depends on why they are trunks in the first place ie. if all the client vlans are routed locally at each site do they need to be trunks ?

If each site connected with a routed link then each switch would only request streams it had received IGMP requests for from clients.

Like I say that is a best guess at the moment.

Hopefully Peter will revisit the thread and add his thoughts because it may not be the answer and I wouldn't want you to have to reconfigure all the links only to find it did not solve the problem.

Jon

Highlighted
Beginner

The trunks carry many other

The trunks carry many other services need that are not involved with the multicast.
So I unfortunately need them.