cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
236
Views
10
Helpful
13
Replies
Highlighted
Beginner

Port Unreachable

Hello all you awesome people, I have 2 routers (1941)  and 3 switches (3560) for my lab. Literally it's fresh out of the box, and all I've really done was setup telnet, DHCP, and messed around with port channeling and STP. Nothing more than "just to see". I could ping and telnet to everything from my PC no problem at all. Then played some video games for a few hours, came back, and now I can't ping or telnet into anything outside of what I'm directly connected to. All my equipment can ping every interface, so it's not like routing is an issue. So I issues debug ip icmp and I get this message "dst (10.0.0.1) port unreachable sent to 10.0.0.2". What does this mean?

Please see attachment for diagram setup if that helps.

 

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Port Unreachable

So I did a tracert to 10.0.0.1 - no problem. Tracert to 10.0.0.17, and for some reason the PC tries resolving that through my home router (dual ether ports). So why all the sudden it want's to resolve it through the home router when it worked fine yesterday, I don't know.

So I went into the NIC config and the Primary DNS server was 10.0.0.1. So I added the secondary DNS of 10.0.0.17, and it works. I'm just mind blown that yesterday it worked, play a game for a few hours and it just decided to not work anymore because of that.

 

I appreciate everyones help!

13 REPLIES 13
VIP Mentor

Re: Port Unreachable

Hello,

 

looking at the attached picture, what IP address spaces are you using for the connection from your PC to R1, and for the connection between R1 and R2 ? Post the full configs of both routers...

Rising star

Re: Port Unreachable

Config on devices would be helpful. But have you saved the config after you did all the configuration? 

Hope it will help. Best regards, Abzal
VIP Advocate

Re: Port Unreachable

Hi,

I think it will better if you would share the running configuration of your router with some other output as:

show ip route

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Beginner

Re: Port Unreachable

A lot of replies already. You guys are awesome.

 

I shut down R2 because it wasn't doing anything but relaying packets. I'm posting the config and a picture of a more detailed setup. Everything is still able to ping and telnet within each other, but just not from my computer.

 

Show ip route-

C 10.0.0.0 is directly connected, FastEthernet0/1
C 10.0.0.16 is directly connected, FastEthernet0/0

VIP Advocate

Re: Port Unreachable

Hi,

There is something missing:

ip dhcp pool PC1
   network 10.0.0.0 255.255.255.240
   domain-name CCNP
   dns-server 10.0.0.1
default-router 10.0.0.1

As default-router (Default Gateway) is missing in the DHCP Pool. 

there is no route to the internet (default route) on the router so add new command as:

 

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Also, check routes on all the switches or another router in the path in your lab. 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Beginner

Re: Port Unreachable

Deepak, I entered the command you said and the results are the same.

All the switches have a default route to 10.0.0.1 which is the port my PC is hooked up to and it's able to ping it no problem.

VIP Advisor

Re: Port Unreachable

As per the Post, you have 2 segment network 1 is PC connected with 10.0.0.1 as Gateway and you confirmed it is working.

Rest is another segment going to R2 network, that segment need to have Gateway is 10.0.0.17 as per your configuration, you can not set gateway as 10.0.0.1 which is not reachable for your switches they are behind your R2 router?

 

R2 onside port configuration 10.0.0.18 gateway as 10.0.0.17 that should work for you.

we need to see your R2 other interface configuration ? can you post that configuration.

BB
*** Rate All Helpful Responses ***
Beginner

Re: Port Unreachable

I took R2 out of the picture since it was just relaying packets to R1. Please see attached picture on how the equipment is setup.

 

The 3 switches are connected to each other and S1 goes to R1. All switches have gateway of 10.0.0.17. (R1 fa 0/0) but can still get to fa0/1(pc) of 10.0.0.1.

 

(Also attaching switches config).

VIP Advisor

Re: Port Unreachable

In this case you have removed R2, now you looking to R1 config.

 

R1 interface configured for 10.0.0.17 - you need to enable ip routing here on R1 to route between subnet

 

ip routing global command.

 

Swtch 0 

the port connected to Router

 

configure as Trunk / Access port depends oin requirement.

 setup a vlan svi

 

interface vlan 10

ip address 10.0.0.18 255.255.255.240

no shutdown

 

Switch 1 to Switch 2 - configured as trunk

Switch 2

 

interface vlan 10

ip address 10.0.0.19 255.255.255.240

no shutdown

 

Switch 2 to Switch 3 - configured as trunk

Switch 3

 

interface vlan 10

ip address 10.0.0.20 255.255.255.240

no shutdown

 

You can point all gateway to 10.0.0.18 and you should be able to ping 10.0.0.2 (if PC do not have any FW enabled)

 

EDIT

 

somehow your configuration loaded after i posted, check from Router you able to ping switch IP address? and enable routing on Router

BB
*** Rate All Helpful Responses ***
Beginner

Re: Port Unreachable

I did the ip routing commando n the router like you said (but wouldn't that be on by default on a router?). The SVIs are setup on Vlan1. The other Vlans was just me playing with STP. They serve no purpose.

 

Why point everything to to Sw1 .18 instead of just the router .17? Since the switches can ping the router no problem.

No firewall enabled and nothing has changed. And from the router, I am able to ping and telnet to the other switches and vise versa.

VIP Advisor

Re: Port Unreachable

My typo there it should be a point to .17 only.

 

From the router you able to reach both the side, its required static route between segment, at this moment you do not have any routing place.

 

If you trace from PC to 10.0.0.1, that will dropped at Router, since Routing not available.

 

add respective static routing you will be good.

 

if you have still issue, post updated config 

 

along with traceroute from PC

show ip route from Router.

 

 

 

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Port Unreachable

So I did a tracert to 10.0.0.1 - no problem. Tracert to 10.0.0.17, and for some reason the PC tries resolving that through my home router (dual ether ports). So why all the sudden it want's to resolve it through the home router when it worked fine yesterday, I don't know.

So I went into the NIC config and the Primary DNS server was 10.0.0.1. So I added the secondary DNS of 10.0.0.17, and it works. I'm just mind blown that yesterday it worked, play a game for a few hours and it just decided to not work anymore because of that.

 

I appreciate everyones help!

VIP Advisor

Re: Port Unreachable

Glad all went well at the end, if this is resolved can we mark as resolved.

 

Sometimes there may be a some information not visible, so traceroute is the best command to find where it blocking or dropping.

 

BB
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards