cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
2702
Views
0
Helpful
19
Replies

PPPOE DSL Not connecting

whickwire
Level 1
Level 1

Hello,

 

I set up a small lab a few weeks ago and got a consumer dsl line. My hope was that I would be able to configure it with the help of all the resources on the web and I'm stuck. Below is the cfg sample of the respective interfaces I believe to be the problem. I can verify the modem is in bridge mode as well. Attached full config should it be needed.

 

More than likely this is may be something silly but would appreciate some input. Thanks!

 

interface Dialer1
mtu 1477
ip address negotiated
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ymca79Jame5
ppp chap password 0 ymca79Jame5
ppp pap sent-username ymca79james@teksavy.com password 0 ymca79Jame5
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept

 

interface FastEthernet0/0
description UPLINK TO TEKSAVY
no ip address
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable

19 Replies 19

Hello,

 

you are missing a few things (changes and additions marked in bold). Also, your interface FastEthernet0/1 has only two IP addresses, is that by design ?

 

interface FastEthernet0/1
ip address 10.79.0.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto

 

Current configuration : 1800 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CoreRouter
!
boot-start-marker
boot-end-marker
!
no aaa new-model
dot11 syslog
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
username admin privilege 15 secret 5 $1$M6fZ$TDpU3j4kbBqI9ZE1Nrv9e0
archive
log config
hidekeys
!
interface FastEthernet0/0
description UPLINK TO TEKSAVY
no ip address
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
ip address 10.79.0.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
interface Dialer1
mtu 1477
ip address negotiated
no ip proxy-arp
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ymca79Jame5
ppp chap password 0 ymca79Jame5
ppp pap sent-username ymca79james@teksavy.com password 0 ymca79Jame5
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
!
ip forward-protocol nd
!
ip nat inside source list 1 interface Dialer1 overload
!
ip route 10.77.0.0 255.255.0.0 Tunnel1 track 100
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.79.90.0 255.255.255.0 10.79.0.2
!
access-list 1 permit 10.79.0.0 0.0.0.255
!
no ip http server
no ip http secure-server
!
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Hello,

 

also, since you have 'ppp ipcp route default' configured on the dialer interface, you don't really need the static default route ('ip route 0.0.0.0 0.0.0.0 Dialer1').

 

So try and either remove the static default route, or take the 'ppp ipcp route default' line off the dialer interface...

Hello

 

Your hostname and sent username differ.
ppp chap hostname ymca79Jame5

ppp pap sent-username ymca79james@teksavy.com


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the communityā€™s global network.

Kind Regards
Paul

I shall check that in the morning and see if that does the trick. Something so silly possibly.
I did have another question regarding the placement of a 0 after the password field ie 
ppp chap password 0 ymca79Jame5

Is it trying to pass that in the authentication?

 

Helo


@whickwire wrote:
I shall check that in the morning and see if that does the trick. Something so silly possibly.
I did have another question regarding the placement of a 0 after the password field ie 
ppp chap password 0 ymca79Jame5

Is it trying to pass that in the authentication?

its states its a clear text authentication password

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the communityā€™s global network.

Kind Regards
Paul

Gotcha thanks!

So some logs based of that config:

*Nov 25 19:32:21.235: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Nov 25 19:32:21.235: Vi2 PPP: Using dialer call direction
*Nov 25 19:32:21.235: Vi2 PPP: Treating connection as a callout
*Nov 25 19:32:21.235: Vi2 PPP: Session handle[9D00004D] Session id[0]
*Nov 25 19:32:21.235: Vi2 PPP: Authorization required
*Nov 25 19:32:21.235: Vi2 PPP: No remote authentication for call-out
*Nov 25 19:32:21.239: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to u
*Nov 25 19:32:24.175: Vi2 PPP: No authorization without authentication
*Nov 25 19:32:24.179: Vi2 CHAP: I CHALLENGE id 1 len 49 from "HMTNON143HW"
*Nov 25 19:32:24.179: Vi2 CHAP: Using hostname from interface CHAP
*Nov 25 19:32:24.179: Vi2 CHAP: Using password from interface CHAP
*Nov 25 19:32:24.179: Vi2 CHAP: O RESPONSE id 1 len 44 from "ymca79james@teksavy.com"
*Nov 25 19:32:24.283: %DIALER-6-UNBIND: Interface Vi2 unbound
*Nov 25 19:32:24.283: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

 

Any ideas?

Hello,

 

typically, what you configure under ppp pap sent-username should match the chap hostname and password. So in your case it would be:

 

ppp chap hostname ymca79Jame5
ppp chap password 0 ymca79Jame5
ppp pap sent-username ymca79Jame5 password 0 ymca79Jame5

Sorry I should have mentioned I have changed.
ppp chap hostname ymca79james@teksavy.com
ppp chap password 0 ymca79Jame5
ppp pap sent-username ymca79james@teksavy.com password 0 ymca79Jame5

Also I'm curious, I have a static IP but my ISP said the subnet is pulled from the PPPOE session. Would that matter at all?

Hello,

 

what do you mean with static IP ? 

 

Post the current full config of your router...

The provider just said my IP was 209.*.*.* and that the subnet mask was pulled from the PPPOE session (I'm not sure if this is common but just what he said)

Building configuration...


Current configuration : 1713 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CoreRouter
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 secret 5 $1$M6fZ$TDpU3j4kbBqI9ZE1Nrv9e0
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description UPLINK to TEKSAVY
no ip address
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
ip address 10.79.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
interface Dialer1
ip address negotiated
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
delay 50000
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname ymca79james@teksavy.com
ppp chap password 0 ymca79Jame5
ppp ipcp dns request accept
ppp ipcp address accept
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.79.90.0 255.255.255.0 10.79.0.2
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 10.0.0.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Hello,

 

a few things are misconfigured. Make sure the lines marked in bold match:

 

Current configuration : 1713 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CoreRouter
!
boot-start-marker
boot-end-marker
!
no aaa new-model
dot11 syslog
!
ip cef
!
multilink bundle-name authenticated
!
voice-card 0
no dspfarm
!
username admin privilege 15 secret 5 $1$M6fZ$TDpU3j4kbBqI9ZE1Nrv9e0
archive
log config
hidekeys
!
interface FastEthernet0/0
description UPLINK to TEKSAVY
no ip address
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
ip address 10.79.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
interface Dialer1
ip address negotiated
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
delay 50000
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ymca79james@teksavy.com
ppp chap password 0 ymca79Jame5
ppp pap sent-username ymca79james@teksavy.com password 0 ymca79Jame5
ppp ipcp dns request accept
ppp ipcp address accept
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.79.90.0 255.255.255.0 10.79.0.2
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 10.79.0.0 0.0.0.255
!

dialer-list 1 protocol ip permit


control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Done. Debug after those commands.

*Nov 25 20:27:31.551: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Nov 25 20:27:31.551: Vi2 PPP: Using dialer call direction
*Nov 25 20:27:31.551: Vi2 PPP: Treating connection as a callout
*Nov 25 20:27:31.551: Vi2 PPP: Session handle[E900006B] Session id[0]
*Nov 25 20:27:31.551: Vi2 PPP: Authorization required
*Nov 25 20:27:31.551: Vi2 PPP: No remote authentication for call-out
*Nov 25 20:27:31.555: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Nov 25 20:27:34.819: Vi2 PPP: No authorization without authentication
*Nov 25 20:27:34.819: Vi2 PAP: Using hostname from interface PAP
*Nov 25 20:27:34.819: Vi2 PAP: Using password from interface PAP
*Nov 25 20:27:34.819: Vi2 PAP: O AUTH-REQ id 1 len 40 from "ymca79james@teksavy.com"
*Nov 25 20:27:34.899: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
*Nov 25 20:27:34.899: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

Hello,

 

post the running config again with the changes you just made...

Building configuration...


Current configuration : 1821 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CoreRouter
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 secret 5 $1$M6fZ$TDpU3j4kbBqI9ZE1Nrv9e0
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description UPLINK to TEKSAVY
no ip address
ip nat outside
no ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
ip address 10.79.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/2/1
no ip address
shutdown
clock rate 125000
!
interface Dialer1
ip address negotiated
no ip proxy-arp
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
delay 50000
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname ymca79james@teksavy.com
ppp chap password 0 ymca79Jame5
ppp pap sent-username ymca79james@teksavy.com password 0 ymca79Jame5
ppp ipcp dns request accept
ppp ipcp address accept
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 10.79.90.0 255.255.255.0 10.79.0.2
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 10.79.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: