cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1086
Views
15
Helpful
7
Replies

PPPoE enablement & config on ISR 4K - IOS XE for automatic DNS and routing from ISP

Liv_Liv
Level 1
Level 1

Hi,

Im setting an ISR4K (4331) with IOS XE Fuji for voice functionality connected to a providers on-premise router for SIP trunking and voice functionality.

The specs datasheet from the provider states that for the voice functionality to work over their SIP cloud, our ISR needs to get or learn dinamically the providers DNS server IP address vía PPPoE.

Also, provider doesn´t give any network addressing for our CUBE in order to connect to their equipment onsite, so I suspect our ISR needs to have its WAN interface facing provider´s equipment to automatically retrieve its network addressing and static route to providers network...

I have set up an Gi interface in the voice gw for the connection to providers router, but I don't know how to enable PPPoE and make the router get the DNS server address, IP addressing and static route directly vía providers connection/interface, as Im a voice engineer not familiar at all with similar setups.

I did not find much documentation on this but I wrote a short config snippet based on what I´ve seen on these forums, if anybody could verify it or give a hint on this id appreciate.

 

!
interface GigabitEthernet0/0/1
description SIP ISP
no ip address
no cdp enable
negotiation auto
pppoe enable group global --> this would enable PPPoE on WAN interface
pppoe-client dial-pool-number 1 --> this is for Dialer 1 config if I understood well
!

!
interface Dialer1
ip address negotiated --> this would get an IP from providers DHCP?
ip mtu 1492 --> not sure on the purpose of this line or if it will be necessary
encapsulation ppp 
dialer pool 1
dialer-group 1
ppp ipcp dns request --> this would request provider´s DNS ip address vía Gi0/0/1 ??
ppp ipcp route default --> this would request static route to providers network vía Gi0/0/1 ??
!

 

Thanks in advance!

2 Accepted Solutions

Accepted Solutions

Peter Paluch
Cisco Employee
Cisco Employee

Hello,

You got it almost correct. This is my suggestion:

interface GigabitEthernet0/0/1
 description SIP ISP
 no ip address
 no cdp enable
 negotiation auto
 pppoe-client dial-pool-number 1
 no shutdown
!
interface Dialer1
 encapsulation ppp
 ip address negotiated
 ip mtu 1492
 ip tcp adjust-mss 1452
 dialer pool 1
 ppp ipcp dns request
 ppp ipcp route default
 no shutdown

To comment on individual commands:

  • pppoe-client dial-pool-number 1 enables the PPPoE client functionality on the physical interface and offers it in a pool with ID 1; don't worry too much about the concept of pools, it's a legacy from true dialed interfaces
  • ip address negotiated will indeed ask the other side to assign us with an IPv4 address
  • ip mtu 1492 and ip tcp adjust-mss 1452 are required to tweak the maximum size of IPv4 packets and prevent unnecessary TCP segment fragmentation over PPPoE session since the PPPoE adds 8 bytes of overhead to every packet while the Ethernet frame payload size can't stretch
  • dialer pool 1 tells the Dialer interface the pool to make the actual calls (which, in turn, uses the PPPoE client offering its services in dialer pool 1)
  • ppp ipcp dns request and ppp ipcp route default indeed request the other side to provide us with a DNS server address, and install a default route

You may need additional configuration - for example, for PAP or CHAP authentication (depending on what the provider is using), for NAT, but this configuration here is a good start, I'd say.

Please feel welcome to ask further!

Best regards,
Peter

 

View solution in original post

Hello,

For troubleshooting the PPPoE session, the suggested commands are awesome. I'd complete the set with:

debug ppp negotiation
debug pppoe packets
show ppp all
show pppoe session
show pppoe session all
show interface dialer1
show ip name-servers
show ip route

Should there be any issue with setting this up and getting this running, please feel free to tag me in the new thread if you open it. I'd love to have a look - PPP et al. are close to my heart (I guess that's because we share the initials ; ) ).

Best regards,
Peter

View solution in original post

7 Replies 7

Peter Paluch
Cisco Employee
Cisco Employee

Hello,

You got it almost correct. This is my suggestion:

interface GigabitEthernet0/0/1
 description SIP ISP
 no ip address
 no cdp enable
 negotiation auto
 pppoe-client dial-pool-number 1
 no shutdown
!
interface Dialer1
 encapsulation ppp
 ip address negotiated
 ip mtu 1492
 ip tcp adjust-mss 1452
 dialer pool 1
 ppp ipcp dns request
 ppp ipcp route default
 no shutdown

To comment on individual commands:

  • pppoe-client dial-pool-number 1 enables the PPPoE client functionality on the physical interface and offers it in a pool with ID 1; don't worry too much about the concept of pools, it's a legacy from true dialed interfaces
  • ip address negotiated will indeed ask the other side to assign us with an IPv4 address
  • ip mtu 1492 and ip tcp adjust-mss 1452 are required to tweak the maximum size of IPv4 packets and prevent unnecessary TCP segment fragmentation over PPPoE session since the PPPoE adds 8 bytes of overhead to every packet while the Ethernet frame payload size can't stretch
  • dialer pool 1 tells the Dialer interface the pool to make the actual calls (which, in turn, uses the PPPoE client offering its services in dialer pool 1)
  • ppp ipcp dns request and ppp ipcp route default indeed request the other side to provide us with a DNS server address, and install a default route

You may need additional configuration - for example, for PAP or CHAP authentication (depending on what the provider is using), for NAT, but this configuration here is a good start, I'd say.

Please feel welcome to ask further!

Best regards,
Peter

 

WOW Peter thank you very much for your super fast reply. 

Ok - I´ll keep your suggested setup as a template. I hope it would not need much change on the final config as Im not used at all with this technology....

 

so basically ip mtu 1492 and ip tcp adjust-mss 1452 need to be present in any PPPoE setup if I understood correctly?

 

Provider did specify username and password but just for specific SIP trunk authentication and registration towards their domain. They didn´t specify any other credentials like PAP/CHAP or anything PPPoE related, is this mandatory info in this setup or can PPPoE work without authentication needed?

 

thank you !! 

Hello,

 

WOW Peter thank you very much for your super fast reply.

Nah, I just happened to walk by at the right time : )

 

so basically ip mtu 1492 and ip tcp adjust-mss 1452 need to be present in any PPPoE setup if I understood correctly?

Correct. Without them, some large IP packets would need to be fragmented before being forwarded across the PPPoE session. This both decreases the performance, but can also lead to some nasty packet losses with some firewalls that don't like handling packet fragments. Not nice to troubleshoot - so better to avoid right away.

 

can PPPoE work without authentication needed?

Absolutely. The authentication is technically optional. It is up to the provider whether they require it.

Feel welcome to ask further!

Best regards,
Peter

thank you, I guess all makes sense now. 

 

My last question would be what PPPoE related commands should I take into account in case any troubleshooting is needed from my side. 

I noted a couple of them although Im not sure if I will be able to interpret them properly and make a diagnose, however if any additional help is needed I´ll open a new different thread. 

 

debug ppp negotiation
show pppoe session

 

I´ll soon mark this thread as resolved. You help is super appreciated, Peter !!

Hello,

For troubleshooting the PPPoE session, the suggested commands are awesome. I'd complete the set with:

debug ppp negotiation
debug pppoe packets
show ppp all
show pppoe session
show pppoe session all
show interface dialer1
show ip name-servers
show ip route

Should there be any issue with setting this up and getting this running, please feel free to tag me in the new thread if you open it. I'd love to have a look - PPP et al. are close to my heart (I guess that's because we share the initials ; ) ).

Best regards,
Peter

thanks for such valuable info !! Sure, will tag you then if any issue arises when working with the ISP. The installation is planned by next week  

again, many thanks for your help and time.

Hello,

You are very, very welcome. Thank you!

Best regards,
Peter

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card