cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
801
Views
0
Helpful
5
Replies
kirill1980
Beginner

PPPoE Over IEEE 802.1Q VLANs in 12.4T

I am trying to configure PPPoE Over IEEE 802.1Q VLan on a 2811 router with (C2800NM-SPSERVICESK9-M), Version 12.4(24)T8

PPPoE client on FastEthernet0/0 works fine.

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1

But PPPoE session is not established on a subinterface with encapsulation dot1Q. It is not even trying to connect to the PPPoE server.

Cisco Feature Navigator says that this feature was added in 12.4T.

Can anybody confirm that 'PPPoE over IEEE 802.1Q VLANs' feature works fine on this IOS?

Thank you in advance!

5 REPLIES 5
kirill1980
Beginner

Does anyone has 'PPPoE over 802.1Q VLANs' feature configured on 2800 series router?

Hi there,

Have you tried debugging using debug ppp negotiation.

 

This output is too verbose so better dont do it on console and check what do you see in the logs.

 

HTH

Hitesh

Yes. However there is nothing in the debug ppp negotiation output whilst PPPoE is configured on the subinterface Fa0/0.2. As soon as I back to the Fa0/0 debug show me the standard PPP negotiation proccess and then PPPoE becomes active successfully.

Hi there,

What feature are you running on the router? can you confirm?

also are you using vpdn group of bba group?

Thanks

Hitesh

Below works fine.

vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
bba-group pppoe global

 

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1

But the same doesn't work over the subinterface:

interface FastEthernet0/0.2
 encapsulation dot1Q 2
 pppoe enable group global
 pppoe-client dial-pool-number 1