cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1611
Views
10
Helpful
8
Replies

PPPoE server doesn't work

Anybody help me with configuring simple PPPoE server for lab purposes? I configured it on old Cisco 2800 router, important parts of config:

!
username ppp password 0 ppp
archive
 log config
  hidekeys
!
!
bba-group pppoe global
 virtual-template 1
!
!
interface GigabitEthernet0/1
 ip address 10.34.55.239 255.255.255.0
 duplex auto
 speed auto
 pppoe enable group global
!
!
interface Virtual-Template1
 mtu 1492
 ip unnumbered GigabitEthernet0/1
 peer default ip address pool PPPOEpool
 ppp authentication pap chap
!
!
ip local pool PPPOEpool 10.34.55.100 10.34.55.200
ip forward-protocol nd
no ip http server
no ip http secure-server
!

Direct to GA0/1 I have connected PC with WIndows10 and interface configured as pppoe client. I'm starting connection, wireshark shows on port complete PPPOE negotiation, there is PADI, PADO, PADR, PADS but unfortunately there is no IP address assigned, as it should be and connection is not working. After PADS windows shows popup "checking internet connection", which after minute returns "failed" and in wireshark I se PADT, which ends connection. Inside of PADO there is no IP addres, also during this checking I can see this connection on router:

 

Router_Cisco#sho pppoe session
     1 session  in LOCALLY_TERMINATED (PTA) State
     1 session  total

Uniq ID  PPPoE  RemMAC          Port                  Source   VA         State
           SID  LocMAC                                         VA-st
      8      8  d4be.d96e.8aeb  Gi0/1                 Vt1      Vi2.1      PTA 
                0021.a09b.f841                                 UP   

but here also no assigned IP. Why? If I correctly understand configuration, should be assigned IP from PPPOEpool, but it isn't. Why?
PS: had no idea, what tag should I use for this post.

1 Accepted Solution

Accepted Solutions

Hello


@JaroslawPrzybyl10945 wrote:

 looks Virtual-access 2 is up/up (why 2, not 1?)
 but still no possibility to ping or telnet this .239


I think each time you create a virtual-template it may create a virtual-access, and not being able to ping the VT isn't a sign that the ppoe server isnt working.
Also you dont require any loopback creation or to have any virtual-template in a up/up state for a PPOE client to work, As I stated a virtual-template is a template not an interface, it just used as a place holder for the virtual-access interface.


This is all that you require to get the ppoe server to work, if it doesn't after this then I would suggest to check your clients.

username ppp password  ppp
bba-group pppoe global

virtual-template 1

interface gig0/1
pppoe enable group global

ip local pool PPPOEpool 10.34.55.100 10.34.55.200

 

interface Virtual-Template1
ip address 10.34.55.239 255.255.255.0
peer default ip address pool PPPOEpool
ppp authentication pap chap


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

8 Replies 8

Hello
try the following:

interface GigabitEthernet0/1
no ip address

interface Virtual-Template1
ip address 10.34.55.239 255.255.255.0


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello 

Try removing the virtual-template you created manually and reapplying it without any MTU
Bare in mind when you enable ppoe a virtual-template isnt created its a virtual-access that is created this should be up/up 
sh ip interface brief | in V


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I recreated this template but it seems, mtu is default, didn't type such command, but it is, config looks identical as before. 

My virtual interfaces are here:

Router_Cisco#sho ip interface brief | i V
GigabitEthernet0/0         unassigned      YES NVRAM  administratively down down    
Vlan55                     unassigned      YES NVRAM  up                    down    
SSLVPN-VIF0                unassigned      NO  unset  up                    up      
Virtual-Access1            unassigned      YES unset  down                  down    
Virtual-Template1          10.34.55.239    YES manual down                  down    
Virtual-Access2            unassigned      YES unset  up                    up      
Loopback1                  unassigned      YES NVRAM  administratively down down   

It looks Virtual-access 2 is up/up (why 2, not 1?) , but still no possibility to ping or telnet this .239 IP (GA0/1 is connected to the switch, here I have other PC with IP in this subnet). Unfortunately can't check pppoe client now, because I have no remote access to this PC, will check it tomorrow. 

Hello,

 

try and use a loopback interface for the virtual template:

 

username ppp password 0 ppp
archive
log config
hidekeys
!
!
bba-group pppoe global
virtual-template 1
!
!
interface GigabitEthernet0/1
ip address 10.34.55.239 255.255.255.0
duplex auto
speed auto
pppoe enable group global
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
peer default ip address pool PPPOEpool
ppp authentication pap chap
!
ip local pool PPPOEpool 10.34.55.100 10.34.55.200
ip forward-protocol nd
no ip http server
no ip http secure-server

Now it looks promising:

Virtual-Access1            unassigned      YES unset  down                  down    
Virtual-Template1          1.1.1.1         YES TFTP   down                  down    
Virtual-Access2            unassigned      YES unset  up                    up      
Loopback0                  1.1.1.1         YES manual up                    up      

current config:

!
interface Virtual-Template1
 mtu 1492
 ip unnumbered Loopback0
 peer default ip address pool PPPOEpool
 ppp authentication pap chap
end
!
interface GigabitEthernet0/1
 ip address 10.34.55.239 255.255.255.0
 duplex auto
 speed auto
 pppoe enable group global
end
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
end
Tomorrow I'll check pppoe connection and let's see.

Thx!

Hello


@JaroslawPrzybyl10945 wrote:

 looks Virtual-access 2 is up/up (why 2, not 1?)
 but still no possibility to ping or telnet this .239


I think each time you create a virtual-template it may create a virtual-access, and not being able to ping the VT isn't a sign that the ppoe server isnt working.
Also you dont require any loopback creation or to have any virtual-template in a up/up state for a PPOE client to work, As I stated a virtual-template is a template not an interface, it just used as a place holder for the virtual-access interface.


This is all that you require to get the ppoe server to work, if it doesn't after this then I would suggest to check your clients.

username ppp password  ppp
bba-group pppoe global

virtual-template 1

interface gig0/1
pppoe enable group global

ip local pool PPPOEpool 10.34.55.100 10.34.55.200

 

interface Virtual-Template1
ip address 10.34.55.239 255.255.255.0
peer default ip address pool PPPOEpool
ppp authentication pap chap


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello,

 

out of curiosity, how did you finally get this to work ?

It is a mystery for me. Finally it started to work, but it is not 100% clear for me, how.
As I found there were two problems:

First - access to the router. My GA interface was connected to the switch as a normal access port. And only with IP created on this port I've had access to the router. With ip moved into template (and inherited by virtual-access port) or created as loopback - no access. This problem I left unresolved, used a workaround: moved my connection from GA port to one of FA - here I can define switchport mode and use vlan interface (Question: as I see, for GA port there is no switchport, but I can define vlan for this port - how it works here? By command vlan-id dot1q 666 on interface I'm adding this port to vlan as untagged? So, how to make a trunk on such port?). My current working configuration is here:

!
interface FastEthernet1/0
 switchport access vlan 55
end
!
interface Vlan55
 ip address 10.34.55.239 255.255.255.0
 pppoe enable group global
end
!
interface Virtual-Template1
 mtu 1492
 ip unnumbered Vlan55
 peer default ip address pool PPPOE_pool
 ppp authentication pap chap
end

 

Second - my pppoe client. And here is still a mystery. I used just simple dialup connection wizzard on Windows10, left all options default, user, password and go. And as I wrote yesterday, it made a connection, checked internet access and terminated connection due to failed checking. And here was the second problem: there was a session established, IP addres was given, but without gateway, so result was: no internet access:

C:\Users\local_admin>ipconfig
Windows IP Configuration
PPP adapter PPPoE:
   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 10.34.55.101
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0

 

it started to work fine, when I configured ip and gateway on ethernet interface:

PPP adapter PPPoE:
   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 10.34.55.101
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0

Ethernet adapter Ethernet:
   Connection-specific DNS Suffix  . :
   IPv4 Address. . . . . . . . . . . : 10.34.55.11
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.34.55.254

Finally it is working fine, but it is a bit unclear for me, why I have to create additional interface with gateway.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco