cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
472
Views
0
Helpful
2
Replies

Problem: MPLS VPN with RIP, OSPF running at CE ends

Roopak Sethi
Level 1
Level 1

Hi,

I am running MPLS VPN with RIP and OSPF at CE ends.

* OSPF  for R3 - R1(ospf process 3) and R4 - R5 (ospf process 4)

* RIP for R4 - R6

I am using two vrfs CA( for R3-R1 and R4-R5) and CB (for R4-R6).

for R1 at R3

ip vrf CA
rd 1:10
route-target export 1:105
route-target export 1:615 // used for R6 to communicate with R1 and R5 for some reasons
route-target import 1:105
route-target import 1:615  // used for R6 to communicate with R1 and R5 for some reasons

for R5 at R4

ip vrf CA
rd 1:50
route-target export 1:105
route-target export 1:615
route-target import 1:105
route-target import 1:615

for R6 at R4

ip vrf CB
rd 1:60
route-target export 1:600
route-target export 1:615
route-target import 1:600
route-target import 1:615

Now  for Communicating R6 with R1 and R5 ( for some reasons)  i am using RT  1:615 both (other wise not needed as previously i was using RT 1:600  only and there was no vrf CB at R3 so to get CA routes into CB i used  1:615 for R6).

My  Problem is :- I am not able to ping R5's loopback ip from R6 as i am  not getting the route for 5.5.5.5 (R5's loopback). But i am able to ping  the serial link ip address of R5.

from R6 to R1 ping is successful

from R6 to R1 ping is successful

from R1 to R5 ping is successful

from R5 to R1 ping is successful

from R5 to R6 ping is successful

from R6 to R5 ping is unsuccessful ( i am not getting route for R5's loopback). But i am able to ping the serial link ip address of R5.

Kindly help

Topology:-

Configurations:-

R1:-

interface Loopback0
ip address 1.1.1.1 255.0.0.0
ip ospf network point-to-point
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
duplex half
no keepalive
!
interface Serial0/0
ip address 10.1.13.1 255.255.255.0
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable

router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.13.1 0.0.0.0 area 0
network 192.168.1.1 0.0.0.0 area 0

R2:-

mpls label range 200 299
mpls label protocol ldp

interface Loopback0
ip address 2.2.2.2 255.0.0.0
ip ospf network point-to-point
!
interface FastEthernet0/0
no ip address
duplex half
!
interface FastEthernet0/0
ip address 10.1.23.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip address 10.1.24.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.23.2 0.0.0.0 area 0
network 10.1.24.2 0.0.0.0 area 0

mpls ldp router-id Loopback0 force

R3:-

ip vrf CA
rd 1:10
route-target export 1:105
route-target export 1:615
route-target import 1:105
route-target import 1:615
!

!
mpls label range 300 399
mpls label protocol ldp
!

!
interface Loopback0
ip address 3.3.3.3 255.0.0.0
ip ospf network point-to-point

!
interface Serial0/0
ip vrf forwarding CA
ip address 10.1.13.3 255.255.255.0
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
!

interface FastEthernet1/0
ip address 10.1.23.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 3 vrf CA
log-adjacency-changes
redistribute bgp 65001 subnets
network 10.1.13.3 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.23.3 0.0.0.0 area 0
!
router bgp 65001
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 65001
neighbor 4.4.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv4 vrf CA
redistribute ospf 3 vrf CA
no auto-summary
no synchronization
exit-address-family
!
mpls ldp router-id Loopback0

R4:-


ip vrf CA
rd 1:50
route-target export 1:105
route-target export 1:615
route-target import 1:105
route-target import 1:615
!
ip vrf CB
rd 1:60
route-target export 1:600
route-target export 1:615
route-target import 1:600
route-target import 1:615
!

mpls label range 400 499

mpls label protocol ldp

interface Loopback0
ip address 4.4.4.4 255.0.0.0
ip ospf network point-to-point
!
interface Serial2/0
ip vrf forwarding CA
ip address 10.1.45.4 255.255.255.0
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
!

interface FastEthernet0/0
ip address 10.1.24.4 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip vrf forwarding CB
ip address 10.1.46.4 255.0.0.0
duplex auto
speed auto
!
router ospf 4 vrf CA
domain-id 0.0.0.3
log-adjacency-changes
redistribute bgp 65001 subnets
network 10.1.45.4 0.0.0.0 area 0
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.24.4 0.0.0.0 area 0
!
router rip
version 2
!
address-family ipv4 vrf CB
redistribute bgp 65001 metric 5
network 10.0.0.0
no auto-summary
version 2
exit-address-family
!
router bgp 65001
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 65001
neighbor 3.3.3.3 update-source Loopback0
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf CB
redistribute rip
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf CA
redistribute ospf 4 vrf CA
no auto-summary
no synchronization
exit-address-family
!

mpls ldp router-id Loopback0

R5:-

interface Loopback0
ip address 5.5.5.5 255.0.0.0
ip ospf network point-to-point
!
interface FastEthernet1/0
ip address 192.168.5.5 255.255.255.0
duplex half
no keepalive
!
interface Serial0/0
ip address 10.1.45.5 255.255.255.0
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 10.1.45.5 0.0.0.0 area 0
network 192.168.5.5 0.0.0.0 area 0
!

R6:-

interface Loopback0
ip address 6.6.6.6 255.0.0.0
!
interface FastEthernet1/0
ip address 192.168.6.6 255.255.255.0
duplex half
no keepalive
!
interface FastEthernet0/0
ip address 10.1.46.6 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 6.0.0.0
network 10.0.0.0
network 192.168.6.0
no auto-summary

2 Replies 2

Hello Roopak,

Have you tried changing the routers domain ID to the same, I think I read somewhere when mpls is involved with ospf, the process-ID is used with the domain-id, and if the domain-id isn't the same they are consider external to ospf, instead of inter-area type 3.

sh ip bgp vpnv4 vrf CA x.x.x.x | in Domain

res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul,

Yes, I tried.. changing domain id on R4 as 0.0.0.3 but it did not helped. Also domain id only ment to convert OE2 routes to O IA. I don't think it can impact because when ospf router are redistributed in BGP then BGP takes OSPF metric as MED and when BGP is redistributed into RIP the same MED value is copied to RIP.

But in my case i was using redistribution metric as 5 so i was seeing every route with metric of 5 in routing table of R6. But route for 5.5.5.5 was not available...

Then, I rebuild the same topology again ( fresh topology) and with same configuration. Now it is working fine.

I think the issue was with GNS.

Thanks for the support.. Paul..

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card