cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7390
Views
0
Helpful
12
Replies
retosteinemann
Beginner

Problem VDSL PPPoE

hello

i've got a problem with vdsl over pppoe. i've got a cisco 887VA and now want to connect to my ips with the credentials they gave me.

the cd-led (carrier-detect) is constantly flashing, means i've got a connection to the isp. but the ppp doesn't come up, so i've made somewhere a mistake in the configuration. username and password are correct, i've checked that about 100 times

you'll find my current configuration as attachment.unfortunately i can't send debug commands to the router to check what's wrong, because the router is already at the customer..

thanks for your help!

12 REPLIES 12
retosteinemann
Beginner

Has someone an idea? Should I post more informations?

Flash led means no connections. Check "show dsl interface".

Thanks for your answer! Sorry, i meant the LED is burning. I can’t execute the command “show dsl interface” on my router, but I’ve uploaded some other logs which might be useful.

No need to use attachments. Just cut & past relevant output.

Check show controller vdsl.

I just checked my config again and saw, that the „interface Ethernet0“ looks like this:

interface Ethernet0

ip address dhcp

Isn't that wrong? Shouldn't it look like this?:

interface Ethernet0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

pppoe-client dial-pool-number 1

!

interface Dialer0

description $FW_OUTSIDE$

ip address negotiated

ip access-group 100 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname XYXYXYXYXYXYXYXY

ppp chap password 0 XYXYXYXYXYXYXYXY

!

controller VDSL 0

!

Unfortunately the device is already at the customer so I couldn’t send “show controller vdsl 0”.

Would it be possible, that the internet connection would work, if I change the ethernet0 settings?

Thanks for your answer, I really appreciate your help!

The MTU on dialer0 is wrong, however that is unlikely to cause the problem.

I recommend you have this configured by someone with relevant expereince. Trying youself only cause frustration a customer disappointment.

My ISP said that 1492 as MTU or less should work.

Do you think that the connection works if do these changes:


interface Ethernet0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

pppoe-client dial-pool-number 1

With PPPoE, MTU must be 1492, not more not less.

With networking, it's not a matter of "thinking if", but using the right commands for the right job.

Well if I would be an expert I wouldn't ask in this support community.

My ISP said that the configured MTU works. But I'm not sure if I configured the interface Ethernet0 correct:

interface Ethernet0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

pppoe-client dial-pool-number 1

Configuring a smaller MTU than necessary increases fragmentation and reduces performances, so it should not be done.

Another reason why you want an expert to work on cisco, is that  he/she would know that with a PPPoE circuit, unless you configure mss adjust on the LAN itnerface, you're like to enocunter strange problems.

You will know if the configuration once you're on site. It makes no sense interrogating unless you are.

Note: interface ip commands in presence of "no ip address" are unnecessary, and uneffective.

retosteinemann
Beginner

Hello everyone!

I just found the solution to my problem by myself! My Problem was that I used the “interface ATM0.1 point-to-point” instead of the Ethernet0 interface!

The ATM0 interface is only for ADSL, not for VDSL. So i just configured the Ethernet0 interface like this:

interface Ethernet0

no ip address

pppoe-client dial-pool-number 1

And I even didn’t had to change something on the Dialer0, because the Dialer0 remains the same:

interface Dialer0

ip address negotiated

ip access-group 100 in

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname xyusername123@provider.com

ppp chap password 0 pAsSwOrD123

no cdp enable

That was the hole magic. Could someone marke this thread as solved?

Hello.

I've been reading and working on successfully configuring a 887VA router with VDSL for some time.  I took a break for the last serveral months because the ISP I was working with didn't want to allow me to connect my router to their VDSL network (I assume) because they use 802.1x authentication with their own equipment (modems).  Now that I've given this subject some time to perculate I'm making my rounds back to it.  I've seen (and/or read about) some successful configurations but none with this particular ISP.  However it's good to hear that some people have made it work.

And aside from all of the trivial comments in this post (while trying to glean some useful information) it sounds like it works in this case to.... Is that true?

Thanks,