cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1184
Views
0
Helpful
17
Replies

Problem with automatic ISDN BRI U Backup Interface

jmarin
Level 1
Level 1

I have a cisco 1700 router running 12.1(3) that has one Serial interface for a point-to-point T1, and one BRI U interface for a backup ISDN BRI if the serial interface goes down. Here's my running config:

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname sub-aquatics

!

enable secret xxx

enable password ******

!

username irim-max6k-alpha password 0 ******

!

!

!

!

memory-size iomem 25

ip subnet-zero

ip name-server 69.x.64.8

ip name-server 69.x.64.9

!

isdn switch-type basic-ni

!

!

!

interface Serial0

description Jade Inc.

backup delay 30 60

backup interface BRI0

ip address 69.46.x.x.255.255.252

encapsulation ppp

load-interval 30

no fair-queue

service-module t1 timeslots 1-24

!

interface BRI0

description Backup to Jade

ip address 69.x.x.x.255.255.252

encapsulation ppp

dialer idle-timeout 2000000

dialer string 5527100

dialer load-threshold 1 either

dialer-group 1

isdn switch-type basic-ni

isdn spid1 xxxx

isdn spid2 xxxx

isdn send-alerting

isdn sending-complete

no cdp enable

ppp authentication chap pap callin

ppp chap hostname SubAquatics

ppp chap password xxxx

ppp pap sent-username xxx password xxx

ppp multilink

!

interface FastEthernet0

ip address 69.x.x.x.255.255.192

load-interval 30

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 BRI0 200

no ip http server

!

snmp-server engineID local xxxx

snmp-server community public RO

!

line con 0

transport input none

line aux 0

line vty 0 4

password ******

login

!

no scheduler allocate

end

I pulled this config from another 1700 which is performing this fine, but for some reason when I shutdown the serial interface, or unplug the T1 from it to bring it down, the BRI is not Activating and trying to dial. It just sits there. Can anyone tell me if there's something wrong with my config? Am I missing a command to tell the backup interface to start dialing once the serial is down?

Any help will be appreciated!

1 Accepted Solution

Accepted Solutions

Yes when you remove the backup interface BRI 0 from the serial interface then the BRI will come out of backup mode and will be available for testing.

HTH

Rick

HTH

Rick

View solution in original post

17 Replies 17

thomuff
Level 3
Level 3

Did you have the Telco test the line? Is there anyway to swap this 1700 with the 1700 that is working fine for testing of the circuit and router. Is it the same IOS with same config except for unique settings like IP address dialer strings, usernames password etc...?

what do you get if you do a show isdn status?

well since it is in backup mode, I get:

sub-aquatics#sh isdn status

Global ISDN Switchtype = basic-ni

ISDN BRI0 interface

dsl 0, interface ISDN Switchtype = basic-ni

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

TEI Not Assigned, ces = 1, state = 1(terminal down)

spid1 configured, spid1 NOT sent, spid1 NOT valid

TEI Not Assigned, ces = 2, state = 5(init)

spid2 configured, spid2 NOT sent, spid2 NOT valid

Layer 3 Status:

0 Active Layer 3 Call(s)

Activated dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

Which is what you should get when it is in backup and if I deactivate the Serial interface, I don't think it changes. But I know the spids and everything are good and the cable is good, since I tested them in a separate piece of equipment and they worked fine.

I have verified myself that the line works fine by using a Lucent Pipeline external ISDN router to establish a connection. No I can't swap the routers out b/c they are for two different Internet customers. I believe the working 1700 is running 12.2. The config is identical except for the appropriate variables and I realized today that I was missing the "dialer-list 1 protocol ip permit" command. Unfortunately, this equipment is at a customer's location and is in use, so it is not easy for me to test the backup or do any software upgrades.

I am by no means an ISDN expert, but shouldn't you have a MULTIPLE_FRAME_ESTABLISHED for layer 2 when you do a show ISDN status?

The layer 1 status shows deactivated. This means that either there is no layer 1 signal from telco. Check the wiring to the demarc or call the service provider. You need to see layer 1 active before anything.

Maybe I wasn't clear enough in my earlier explanations... Layer 1 is deactivated b/c the BRI Int is in backup mode which essentially means it is shut down. It shouldn't turn on until the Serial Interface goes offline. Hence the Layer 1: Deactivated status. I'm sure that this is normal because the Cisco support rep that helped me with my initial config on the other router explained this to me. As far as testing wiring etc, I know all of that is good since I used the same cable and plugged in a different router and was able to get a solid connection immediately. So I am 100% sure that the problem lies in the Cisco router, either it is a config problem, an IOS problem, or a hardware problem. I'm just asking for help on determining which of those things is the problem.

Thanks

well since the BRI is essentially administratively down, would that show up?

mohamed-khadr
Level 1
Level 1

Try the following;

1) takeout the delay command fronm the serial interface

<< now doing a sh int bri0/0 will sh up/up spoofing

and sh isdn sta will show layer 1 active, layer 2 multiple frame esatblished>>> if u don't see that, then call the telco.

2) change dialer-idle timeout to 10

3) issue an extend ping to bring the bri int to dial

4) try: isdn test call int bri0/0 spid # of remote site

5) try sho isdn act>>> if fail, then run debug ppp auth,

hth

mohAmed khAdr

3)

mohamed-khadr
Level 1
Level 1

Sorry I meant take out backup command from the serial interface. Also config an ACL for the dialer-group 1 to make ip the interesting traffic

Jasmine is correct that with the backup interface configured on the serial pointing to the BRI that the BRI will not either initiate a call nor answer a call.

I would suggest that with the interface in backup state that there is no useful testing that you can do. And with the BRI not working for some reason it is not providing any effective backup. So would it be possible to remove the backup-interface from the serial (at least long enough to do some testing)?

I believe that Jasmine already knows it, but I will make the point that for testing backup-interface it is NOT good enough to shut down the primary interface. They primary interface must have a problem (like being unplugged) before the backup interface will come out of backup status and try to become active.

If you are able to remove the backup-interface command or otherwise get the BRI into a testing state one of the first things we would want to see, as others have noted, is the output of show isdn status. It might also be helpful (if you can get it) to see output of debug isdn q921 and debug isdn q931.

If I were going to guess at the source of the problem my first guess would be some keystroke error in entering the SPIDs.

HTH

Rick

HTH

Rick

tyoung008
Level 1
Level 1

I do not see a dialer-list command in your configuration.

The backup interface command puts the BRI interface into Standby mode. If the command is removed or the Serial interface goes down (not admin down) then the BRI interface comes up. It does not dial, it only comes up.

After the BRI interface comes up, you should see Layer 1 Active and Layer 2 MULTIPLE_FRAME_ESTABLISHED when you run the "show isdn status" command.

You will need a dialer-list and interesting traffic to match the dialer-list to cause the BRI to dial. For example, "dialer-list 1 protocol ip permit" and "ping 69.x.x.x" (remote ISDN interface) will do.

As a side note, a best practice is to use the dialer string with a dialer interface and a dialer map with the BRI interface. Dialer string will workon the BRI, but I have seen some issues with it occasionally.

Thanks,

Tom

Thanks for mentioning the missing dialer-list command. Here's what I added in:

dialer-list 1 protocol ip permit

(that went in on the line above: snmp-server engineID local *****)

This is only my second attempt at using dialer lists in a Cisco ever. Can you give me more details on what you mentioned as the best practice?

In any case, thanks to all of you for your reponses, once I am able to get to the site where this router is, I will try out everything you've mentioned so far.

One more question... In order to take the BRI out of backup mode, the only command I'll need to remove is: "backup interface BRI0" from the Serial interface right?

Yes when you remove the backup interface BRI 0 from the serial interface then the BRI will come out of backup mode and will be available for testing.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card