05-06-2005 06:10 AM - edited 03-03-2019 09:29 AM
I have a cisco 1700 router running 12.1(3) that has one Serial interface for a point-to-point T1, and one BRI U interface for a backup ISDN BRI if the serial interface goes down. Here's my running config:
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sub-aquatics
!
enable secret xxx
enable password ******
!
username irim-max6k-alpha password 0 ******
!
!
!
!
memory-size iomem 25
ip subnet-zero
ip name-server 69.x.64.8
ip name-server 69.x.64.9
!
isdn switch-type basic-ni
!
!
!
interface Serial0
description Jade Inc.
backup delay 30 60
backup interface BRI0
ip address 69.46.x.x.255.255.252
encapsulation ppp
load-interval 30
no fair-queue
service-module t1 timeslots 1-24
!
interface BRI0
description Backup to Jade
ip address 69.x.x.x.255.255.252
encapsulation ppp
dialer idle-timeout 2000000
dialer string 5527100
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 xxxx
isdn spid2 xxxx
isdn send-alerting
isdn sending-complete
no cdp enable
ppp authentication chap pap callin
ppp chap hostname SubAquatics
ppp chap password xxxx
ppp pap sent-username xxx password xxx
ppp multilink
!
interface FastEthernet0
ip address 69.x.x.x.255.255.192
load-interval 30
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
ip route 0.0.0.0 0.0.0.0 BRI0 200
no ip http server
!
snmp-server engineID local xxxx
snmp-server community public RO
!
line con 0
transport input none
line aux 0
line vty 0 4
password ******
login
!
no scheduler allocate
end
I pulled this config from another 1700 which is performing this fine, but for some reason when I shutdown the serial interface, or unplug the T1 from it to bring it down, the BRI is not Activating and trying to dial. It just sits there. Can anyone tell me if there's something wrong with my config? Am I missing a command to tell the backup interface to start dialing once the serial is down?
Any help will be appreciated!
Solved! Go to Solution.
05-11-2005 01:39 PM
Can you give me more details on what you mentioned as the best practice?
Certainly!
For your configuration, I would use this command, "dialer map ip 69.x.x.x name irim-max6k-alpha broadcast 5527100" instead of the dialer string command. It is the traditional way to configure BRI. It creates a static dialer map, where the dialer string is dynamic. I have occasionally seen problems with the dialer string command on the BRI interface. For the command, the IP address would be of the remote router. The "name" keyword is needed because you are using CHAP authentication. The "broadcast" keyword is only needed if you want to send broadcast or multicast traffic over the circuit (e.g., routing protocol).
Thanks,
Tom
05-12-2005 11:15 AM
Whoever told you that the BRI will show as Layer 1 DEACTIVATED when it's in backup mode is wrong. Here is the result of a show isdn status on one of my routers that is configured almost exactly like yours:
ISDN BRI0/0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 122, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
I_Queue_Len 0, UI_Queue_Len 0
TEI = 123, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
I_Queue_Len 0, UI_Queue_Len 0
Spid Status:
TEI 122, ces = 1, state = 5(init)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 70, tid = B
TEI 123, ces = 2, state = 5(init)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 71, tid = B
Layer 3 Status:
0 Active Layer 3 Call(s)
Activated dsl 0 CCBs = 0
Total Allocated ISDN CCBs = 0
As you can see, all looks well. In fact, the BRI interface is actually up/up but the bearer channels are not. This is what you should see.
05-13-2005 02:24 PM
I just wanted to let everyone know that I was able to get this working once I upgraded to 12.2. I had to make some other small config changes, so I'm not sure whether it was those changes or the upgrade that fixed my problem, or even if it was just adding in the dialer-list command, but everything is up and running now. Thanks again
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide