cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
9549
Views
18
Helpful
12
Replies
Arturo Bianchi
Beginner

PuTTY - Strange packet received: type 3

Hi!

I have a strange problem when I use putty 0.60 to connect to the router via ssh: putty occasionally opens a window with error the following message: "Strange Packet Received: type 3" and terminatig comunication with router.

The problem occurs on some recent versions of IOS, in particular the 12.4 (24) and various hardware platforms.

Any idea to solve this annoying problem??

73

Arturo

12 REPLIES 12
Thomas Schmidt
Beginner

Hello Arturo,

unfortunately I have no solution, but at least I can confirm it.

We are also using Putty 0.60 and are facing the problem only with new C29xx routers with IOS 15.0

Any help is higly appreciated as this behaviour is really annoying.

Best Regards

Thomas

Most IOS versions have this problem.

The only workaround is to use telenet instead.

Hi All,

Just a thought if it affects your sessions to some router all of the time.

If your IOS feature set allows it, you could encrypt telnet traffic between your routers and management workstation(s). And then disable SSH untill the problem is fixed.

It's a bit messy and has a high administrative overhead, but it would secure management traffic.

HTH

Kevin

In putty config go in Connection->SSH->Kex

Change

Max minutes before rekey to 0

Max data before rekey to 0

The strange packet type 3 error happen on rekey...

You can set it to 1min to see it happen faster.

It solved the problem for me.

Hi Hugo, hi all,

this was really the hint I was looking for. Great!

With a first quick test the problem wasn't seen anymore.

I'll do a few more tests within the next days and report back.

Best regards

Thomas

Hi all,

I would just like to confirm that the problem wasn't seen after chaning the mentinoend parameters in putty.

As far as I understand this leads to stop of key exchange in each SSH session. I'm not sure how much security would be degraded by this.

I guess for us it is acceptable as we are using this only for our internal enterprise network.

Anyway, on long term we would appreciated to get it fixed permanently by Cisco or putty developers.

Best regards

Thomas

Hi Hugo,

good info... I have turned the information to the mailing list of putty developers where I was reporting a series of log for catch the bug (Simon Tatham had introduced some new flags in the current version to better identify the problem) !!!

Thanks,

good interim workaround .

73

Arturo

Hate to bump an old thread, but this is the top Google search for this error. FWIW we did not start seeing this until we upgraded from c3845-ipbasek9-mz.124-22.T.bin to c3845-entservicesk9-mz.124-24.T3.bin.

Setting the PuTTY rekey interval to 0 (disabling rekey) will help and is still most likely more secure than using telnet..

We have also been seing this problem for a long time with most versions of IOS. Very annoying. Nice to find a work around but it would be even nicer to see this fixed.

Hey Cisco, can you please address this!

Byte Solutions, Managed Computer Services
https://www.bytesolutions.com 561.338.9696

Hi!

In fact I could not say how much of the problem is attributable to IOS, and than it is to Putty; ultimately, when I use ssh on Linux the problem does not occur. There are two things: or openssh already has an automatic workaround or is there something more! At the time, I read the opinion of Simon Tatham: in fact I still lack the position of some Cisco employees on this annoying defect.


Happy holidays

73,

Arturo

I just started having this problem, but only with ASA, and only when doing a ping with no reply. I get this error on the 2nd or 3rd ?. 

Very strange, and setting kex to 0 did not help.

Thanks for the hint. This workaround has helped me out.