cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3288
Views
0
Helpful
4
Replies

QoS for inbound traffic

0rsnaric
Level 1
Level 1

I have a remote office with a 1.54mb circuit connected to our private MPLS network.  Our main office has a 20mb conneciton to said network.  I want to set a QoS policy for traffic from the remote office to our Avaya subnet within the main office.  This policy is to give priority to all traffic to the Avaya G350.

I have set up the outbound traffic policy on our remote office router using a policy map as follows:

access-list 101 permit ip any 192.168.0.0 0.0.255.255 (this represents the Avaya subnet)

class-map match-all voice_outbound

match access-group 101

policy-map voip_outbound

class voice_outbound

   priority percent 50

interface Serial0/3/0

service-policy output voip_outbound

This works fine for outbound traffic.  Now how do I give priority to inbound traffic from the 192.168.0.0 network?  When I try to do similar command it says CBWFQ is only configurable as output, not input.

I'd just limit it at the far end, but that has a 20mb pipe.  All other traffic from our corporate datacenter, as well as internet traffic, flows from the main office to the remote office.  Should I just rate limit everything else destined for the remote office subnet, and if so, what's the best method?

Suggestions?  Best method to ensure the Avaya G350 has priority over all other traffic is the goal.

Thanks!

~r

1 Accepted Solution

Accepted Solutions

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Assuming you're describing a VPN that runs across a MPLS service provider's cloud, they often support QoS.

If not, on the HQ side, you use a hierarchal policy that shape's for the bottleneck and prioritizes as desired.

e.g.

access-list 101 permit ip 192.168.0.0 0.0.255.255 any (this represents the Avaya subnet)

class-map match-all voice_outbound

match access-group 101

access-list 102 permit ip any x.x.x.x y.y.y.y (remote branch IP address block)

class-map match-all branch

match access-group 102

policy-map voip_outbound

class voice_outbound

   priority percent 50

policy-map for_branch

class branch

shape average 1500000

service policy voip_outbound

interface Serialx

service-policy output for_branch

View solution in original post

4 Replies 4

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Assuming you're describing a VPN that runs across a MPLS service provider's cloud, they often support QoS.

If not, on the HQ side, you use a hierarchal policy that shape's for the bottleneck and prioritizes as desired.

e.g.

access-list 101 permit ip 192.168.0.0 0.0.255.255 any (this represents the Avaya subnet)

class-map match-all voice_outbound

match access-group 101

access-list 102 permit ip any x.x.x.x y.y.y.y (remote branch IP address block)

class-map match-all branch

match access-group 102

policy-map voip_outbound

class voice_outbound

   priority percent 50

policy-map for_branch

class branch

shape average 1500000

service policy voip_outbound

interface Serialx

service-policy output for_branch

This is a point to point over an MPLS network.

What I need to know is what is the best way to make sure regular traffic doesn't eat up the entire 1.54mb bandwidth of the serial interface on the remote offices' router.

I assume I want to do this on the HQ router's MPLS network facing interface. 

What are the correct commands to tell the router that traffic from the Avaya subnet has top priority over all other traffic destined for the remote site, given that the HQ circuit is 20mb, and the remote site is 1.54mb (meaning, I can't just say give it 50%, since it will then assume 10mb is okay for all other traffic)

Is traffic shaping it?

What if I do the following -

Set a priority bandwidth of 1.54mb on traffic to the remote office.

Then do a netsted policy with a bandwidth command of 500kb for any traffic from the Avaya subnet?

The priority bandwidth command would limit all traffic to 1.54, right?  And then the nested command would guarantee 500kb of that for Avaya, right?

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

My original posting shows what to do on your HQ device.  I.e. shape for remote branch's 1.5, prioritize traffic as desired.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco