cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
465
Views
5
Helpful
45
Replies
VIP Expert

Re: QoS for traffic

The applied interface policy will pick up the bandwidth percentages from what it believe the interface is running at, or what you've set the interface bandwidth value to.

You should allocate all 100% of the bandwidth and you should defined a bandwidth for class-default.

The way you match an IP, or address block, you write an ACL to do so and in the class map you match against the ACL. (Actually you did that in one or your earlier posts.)
Participant

Re: QoS for traffic

would this work? Then just make an access list for each group/IP I want to set?

 

class-map match-all VoIP

description Voice Traffic

class-map match-all RDS

description RDS Traffic

class-map match-all Corporate

description Corp Office

class-map match-all Class-Default

class-map match-all Priority

!

!

policy-map VoIP

class VoIP

bandwidth percent 1

policy-map RDS

class RDS

bandwidth percent 8

policy-map Corporate

class Corporate

bandwidth percent 10

Policy-map Default

class class-default

bandwidth percent 81
!
!
ip access-list extended VoIP

permit ip host 45.45.45.1

class-map match-all VoIP

policy-map shape

VIP Expert

Re: QoS for traffic

You're on the right track. You need to add a match statement, in the class-map, to match the corresponding ACL. And yes, you do similar for the other classes.

BTW, for class-default, see if bandwidth statement will take remaining percent 100. This way, if you want to adjust the other classes, you don't need to re-adjust class-default.
Participant

Re: QoS for traffic

Thank you for your continued help. 

 

I've built this in packet tracer and can't seem to figure out how to add the IP to the extended ACL

 

Router#show run

Building configuration...

 

Current configuration : 1381 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2911/K9 sn FTX15244G7R

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

class-map match-all VoIP

description Voice Traffic

class-map match-all RDS

description RDS Traffic

class-map match-all Corporate

description Corp Office

class-map match-all Class-Default

description Default

!

policy-map VoIP

class VoIP

bandwidth percent 1

!

policy-map RDS

class RDS

bandwidth percent 8

!

policy-map Corporate

class Corporate

bandwidth percent 10

!

policy-map Class-Default

class class-default

bandwidth remaining percent 100

!

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

!

ip access-list extended VoIP

permit ip host 45.45.45.1 any

ip access-list extended RDS

permit ip host 45.45.45.2 any

ip access-list extended Corporate

permit ip host 45.45.45.3 any

ip access-list extended Default

permit ip any any

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

VIP Expert

Re: QoS for traffic

Packet Tracer often is feature shy compared to real devices. See what class-map match options there are.
Participant

Re: QoS for traffic

I set it up on a 2901 router with IOS 15.4.3 and still no luck. 

 

I'm not sure where I've botched this up. Any ideas on where I could see an example of what I'm trying to do? I've searched on Google but can't seem to find it where it's done by IP and not service type.

 

Thank you

VIP Expert

Re: QoS for traffic

What does your 2901 config look like? What are you class-map match options on it?
Participant

Re: QoS for traffic

It's the same config I put in the packet tracer.

 

Here are my options

 

Router(config)#ip access-list extended VoIP

Router(config-ext-nacl)#?

<1-2147483647> Sequence Number

default Set a command to its defaults

deny Specify packets to reject

exit Exit from access-list configuration mode

no Negate a command or set its defaults

permit Specify packets to forward

remark Access list entry comment

Router(config-ext-nacl)#

VIP Expert

Re: QoS for traffic

Are you having problems defining the ACL or the class-map? (I thought the latter.)
Participant

Re: QoS for traffic

Correct, I am unable to assign the class-map to the ACL.

VIP Expert

Re: QoS for traffic

You assign the ACL to the class-map.

e.g.
ip access-list extend SampleACL
permit . . .

claas-map match-aXX SampleClassMap
match access-group name SampleACL

policy-map SamplePolicyMap
class SampleClassMap
banwidth percent 10
Participant

Re: QoS for traffic

class-map match-all VoIP
description Voice Traffic
match access-group 10
class-map match-all RDS
description RDS Traffic
match access-group 10
class-map match-all Corporate
description Corp Office
match access-group 10
class-map match-all Class-Default
description Default
match access-group 10
!
policy-map VoIP
class VoIP
bandwidth percent 1
!
policy-map RDS
class RDS
bandwidth percent 8
!
policy-map Corporate
class Corporate
bandwidth percent 10
!
policy-map Class-Default
class class-default
bandwidth remaining percent 100
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
ip access-list extended VoIP
permit ip host 45.45.45.1 any
ip access-list extended RDS
permit ip host 45.45.45.2 any
ip access-list extended Corporate
permit ip host 45.45.45.3 any
ip access-list extended Default
permit ip any any

 

Ok, I think we are close. One more issue when I assign the ACL to the class-map match-all it won't let me put in the work "VoIP" at the end of "match access-group" says invalid input dtected at marker.

 

I did a 

Router#show access-lists

Extended IP access list VoIP

10 permit ip host 45.45.45.1 any

Extended IP access list RDS

10 permit ip host 45.45.45.2 any

Extended IP access list Corporate

10 permit ip host 45.45.45.3 any

Extended IP access list Default

10 permit ip any any

 

It allows me to put 10 in at the end, however thye are all 10. Why are they all the same ACL #?

 

Thank you again for all the help on this issue!

Highlighted
VIP Expert

Re: QoS for traffic

You don't have an ACL 10 (at least in what you've posted). You have "named" ACLs, which show the first ACE as statement #10, for ACL editing purposes.

In your class-map match statements, use the "name" option, as I showed in my prior post (assuming packet tracer supports).

Why all the policy-maps? You likely want a single policy-map, with multiple classes.
Participant

Re: QoS for traffic

ok, I see what you mean on the Policy-map. I will combine those into one and add classes under it.

 

Let me get that done then I'll show you my config. I'm still a little puzzled.

 

Thank you

Participant

Re: QoS for traffic

Ok, here is the new config. However I still don't know how to do the ACL's. Also on the ACL do you need any deny statements?

 

lass-map match-all VoIP

description Voice Traffic

match access-group 10

class-map match-all RDS

description RDS Traffic

class-map match-all Corporate

description Corp Office

class-map match-all Class-Default

description Default

!

policy-map Traffic_QoS

class VoIP

bandwidth percent 1

class Corporate

bandwidth percent 10

class RDS

bandwidth percent 10

class class-default

!

!

!

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

shutdown

!

ip classless

!

ip flow-export version 9

!

!

ip access-list extended VoIP

permit ip host 45.45.45.1 any

ip access-list extended RDS

permit ip host 45.45.45.2 any

ip access-list extended Corporate

permit ip host 45.45.45.3 any

ip access-list extended Default

permit ip any any

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards