cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8461
Views
0
Helpful
7
Replies
Highlighted
Beginner

QoS for VoiP best Practice

Hello, guys!

We've got vpn-concentrator and 15 offices with 881w and 1941 isr connected vo it via ipsec. Our Asterisk is placed behind this vpn-concentrator in local network, so all traffice goes throung vpn tunnels.

Is it possible to make QoS rules using just destination IP address of our Asterisk server?

Everyone's tags (3)
7 REPLIES 7
Highlighted
Rising star

Re: QoS for VoiP via Dst IP

Hi
yes u can do this with a acl

Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

Re: QoS for VoiP via Dst IP

thank you for the answer!

what is more preferable to use in police-map for voice traffic: bandwidth or priority?

Highlighted
Rising star

Re: QoS for VoiP via Dst IP

Hi
both options have different function
bandwidth option will have policing while priority will have polcier

Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

Re: QoS for VoiP via Dst IP

Can you suggest any manual with explanation of differences? I read some articles and forums over the internet and sa I undestand, priority match LLQ traffic with high priority wich will pass through router at first without depending on it's load and bandwidth doesn't match traffic with priority but gives stable % or kbps of throughput ?

Highlighted
Beginner

QoS for VoiP best Practice

Is there any best practice for matching and configuring voip traffic for qos?

We have channel bandwidth 20mb\s from ISP

I made this:

class-map match-any VOICE-CONTROL

match ip dscp cs3

match ip dscp af31

match protocol rtcp

match protocol mgcp

class-map match-any voice

match ip dscp ef

match access-group 106

policy-map qos

class voice

  priority percent 20

  set ip dscp ef

class VOICE-CONTROL

  bandwidth percent 2

  set ip dscp cs3

ip access-list extended VoIP-Control

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060

access-list 106 permit ip any asterisk_ip 0.0.0.3

access-list 106 permit ip any another_asterisk_ip 0.0.0.255

interface GigabitEthernet0/0

ip address * 255.255.255.240

ip flow ingress

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

crypto map vpn

service-policy output qos

Is it ok?

Highlighted
Rising star

Re: QoS for VoiP best Practice

Hi,

I would do it like this:

1. Configure Auto-QoS on L2 access switches (as close to the source of voice traffic as possible).

2. Create  class-maps that will match to VoIP traffic and Voice control traffic.

3. Create policy-map that will prioritize these traffic.

1. Marking:

mls qos

int g0/1

auto qos cisco-phone

ip access-list extended VOICE-SIGNAL

remark filter H323 traffic

permit tcp any range 1718 1720 any

permit tcp any any range 1718 1720

remark filter MGCP

permit udp any range 2427 2428 any

permit udp any any range 2427 2428

permit tcp any range 2000 2002 any

ip access-list extended VOICE

permit udp any any range 16384 32776 dscp ef

2. Class maps

class-map voice_traffic

match ip dscp ef

match access-group name VOICE

class-map voice_control

match ip dscp cs3

match access-group name VOICE-SIGNAL

3. Policy-map

policy-map VOIP_QOS

class voip_traffic

   priority percent 20

class voice_control

   priority percent 2

policy-map SHAPE

class class-default

   shape average 20000000

   service-policy VOIP_QOS

http://www.cisco.com/en/US/tech/tk543/tk759/technologies_white_paper09186a00801348bc.shtml#wp39463

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal
Highlighted
Beginner

Re: QoS for VoiP best Practice

Greg -

"Cisco QOS Exam Certification Guide (IP Telephony Self-Study), Second Edition" as a source of a lot of very thorough and detailed information.  It is available on Safari at: http://my.safaribooksonline.com/book/certification/cisco-qos/1587201240