cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
351
Views
0
Helpful
10
Replies
Highlighted
Beginner

QOS is bottle mecking my MPLS

                   We have QOS over our MPLS and my provider says that our QOS policies are working fine, but when I run the

show policy-map interface command it always shows the EF que with 0 packets and using up 25% of our bandwidth.  We are not tagging anything in the EF que we do not run any time sensitive protocols(voip video) over the MPLS.  All I want to do is remove QOS entirely, but my provider is balking at the idea.  Why would I keep this policy that is wasting 25% of my bandwidth???

show policy-map interface
FastEthernet0/3/0

Service-policy output: 25_74

Class-map: ef (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: none
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
Output Queue: Conversation 265
Bandwidth 25 (%)
Bandwidth 25000 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
QoS Set
dscp ef
Packets marked 0

Class-map: af41 (match-any)
47909379 packets, 7006127169 bytes
5 minute offered rate 82000 bps, drop rate 0 bps
Match: access-group name QOS_AF41
47909379 packets, 7006127415 bytes
5 minute rate 82000 bps
Queueing
Output Queue: Conversation 266
Bandwidth 74 (%)
Bandwidth 74000 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 297/30848
(depth/total drops/no-buffer drops) 0/0/0
QoS Set
dscp af41
Packets marked 47909354

Everyone's tags (3)
10 REPLIES 10
Contributor

Re: QOS is bottle mecking my MPLS

Hello Friend,

I hope you are doing good, very difficult question haa.

Friend we need to analyse the issue first, let us do it together.

Q) What if there is a necessity in future?

A) We must be prepared for the future We undertand it and when the time comes we may plan it and make an RFC and implement it. Till then dont waste your bandwidth unnecessarily.

Note: By your post I understood that you are not going to have such a requirement in the near future.

Q) What is the reason behind SP not willing to remove your policies?

A) Ask SP an find it out, if he is making some valid points that needs to be considered then we we must.

I hope you understood.

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

VIP Advisor

Re: QOS is bottle mecking my MPLS

Hello Dan

FYI - you are not wasting any bandwidth- qos will only be applicable if congestion is occurring.

It looks like you have priority queuing set of EF.

Can you post the run config relating to the qos

Res
Paul

Sent from Cisco Technical Support iPad App



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: QOS is bottle mecking my MPLS

class-map match-any af41

match access-group name QOS_AF41

class-map match-any ef

!

!

policy-map 25_74

class ef

  bandwidth percent 25

  set ip dscp ef

class af41

  bandwidth percent 74

  set ip dscp af41

class class-default

  fair-queue

  set ip dscp default

interface FastEthernet0/3/0

ip address 192.10.200.2 255.255.255.0

ip wccp 62 redirect in

duplex auto

speed auto

no cdp enable

max-reserved-bandwidth 100

service-policy output 25_74

ip access-list extended QOS_AF41

permit tcp any eq 3389 any

permit ip host 192.10.100.80 any

permit ip host 192.10.100.70 any

permit ip host 192.10.100.66 any

class-map match-any af41

match access-group name QOS_AF41

class-map match-any ef

VIP Expert

Re: QOS is bottle mecking my MPLS

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Why would I keep this policy that is wasting 25% of my bandwidth???

It's not.  The 25% is that class's share of bandwidth if there's congestion.  If it doesn't use any or all of it, it's available to other classes.

Beginner

Re: QOS is bottle mecking my MPLS

So even if the circuit is full it will still show 0 bits??  I just pushed a huge file to all our remote locations to see if I could get any traffic on that ef que, and it is still showing 0 bits....

KamcoMPLS#show policy-map interface output
FastEthernet0/3/0

  Service-policy output: 25_74

    Class-map: ef (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: none
        0 packets, 0 bytes
        5 minute rate 0 bps
      Queueing
        Output Queue: Conversation 265
        Bandwidth 25 (%)
        Bandwidth 25000 (kbps)Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
      QoS Set
        dscp ef
          Packets marked 0

    Class-map: af41 (match-any)
      55198316 packets, 8141538565 bytes
      5 minute offered rate 69000 bps, drop rate 0 bps
      Match: access-group name QOS_AF41
        55198316 packets, 8141538811 bytes
        5 minute rate 69000 bps
      Queueing
        Output Queue: Conversation 266
        Bandwidth 74 (%)
        Bandwidth 74000 (kbps)Max Threshold 64 (packets)
        (pkts matched/bytes matched) 341/36959
        (depth/total drops/no-buffer drops) 0/0/0
      QoS Set
        dscp af41
          Packets marked 55198291

    Class-map: class-default (match-any)
      216007783 packets, 122336393528 bytes
      5 minute offered rate 8973000 bps, drop rate 0 bps
      Match: any
      Queueing
        Flow Based Fair Queueing
        Maximum Number of Hashed Queues 256
        (total queued/total drops/no-buffer drops) 0/0/0
      QoS Set
        dscp default
          Packets marked 215804777
KamcoMPLS#

Enthusiast

QOS is bottle mecking my MPLS

Your policy says that if any packets marked EF are sent out of the Fa0/3/0 interface then it will by guaranteed 25% of the bandwidth. Only in times of congestion will this come in to effect - it does not set aside 25% of the bandwidth. If no packets marked EF are being transmitted then all other traffic will get to use 100% of the bandwidth.

I am not sure what the test was you carried out but nothing is hitting that policy map which makes me think you are not sending any packets marked with EF. You can see in the class-default class you are sending about 9Mbps. Class-default is the default class for any packets not specifically referenced by other class maps.

Contributor

Re: QOS is bottle mecking my MPLS

Dan,

These are two experts I know from the cisco forums, if you are not wasting any bandwidth that is fantastic, No need to remove policies.

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

VIP Advisor

Re: QOS is bottle mecking my MPLS

Hello Dan

"So even if the circuit is full it will still show 0 bits??  I just  pushed a huge file to all our remote locations to see if I could get any  traffic on that ef que, and it is still showing 0 bits"

you have nothing specified in class-map match-any ef  - So there is no match criteria for packets to be match against.

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Enthusiast

QOS is bottle mecking my MPLS

Dammit - you just beat me to it...

You need something like this if you want to match packets with ef set:

#class-map match-any ef

#match dscp ef

VIP Advisor

QOS is bottle mecking my MPLS

Hello Mfurnival

Apologies for that sometimes it happens to me - anyway at least we agree and Dan is getting the help he is asking for !

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards