cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4431
Views
0
Helpful
3
Replies
Highlighted

QoS - Mark a routers self-generated OSPF traffic

Hello,

Question; I am running OSPF over a 2Mbit leased line that forwards a lot of FTP traffic. During peaks traffic seems to fill up the line so much that the OSPF hello packets do not make their way over the line before the dead timer expires. I've had an idea to apply QoS to permit the self-generated OSPF traffic to fall into a priority queue - always having 10% of the link capacity dedicated to service these flows but I seem to be not successful with the following configuration that I've applied;

Extended IP access list ospf-marking

  10 permit ospf any any

route-map OSPF-Marking permit 10

  match ip address ospf-marking

  set ip precedence network

ip local policy route-map OSPF-Marking

class-map match-all Routing_Policing

  match ip dscp cs7

policy-map Routing_Policing

  class Routing_Policing

     priority percent 10

interface FastEthernet0/1

  description 2Mbit leased line

  ip address x.x.x.x y.y.y.y

  service-policy output Routing_Policing

I've also tried to run NBAR in a class map matching OSPF traffic and setting dscp cs7 with a policy map.

In short;

How do I mark self-generated OSPF traffic to be prioritized over an outgoing 2Mbit Leased Line?

Thanks, Best Regards

Jhonny Eriksson

Everyone's tags (6)
3 REPLIES 3
Advisor

QoS - Mark a routers self-generated OSPF traffic

Hi,

I think the best way to solve your issue would be to police or shape  ftp traffic  to what extent you want:

class-map FTP_CLASS

match protocol ftp

policy-map FTP_POLICY

class FTP-CLASS

police xxxxx         or shape xxxx      where xxxx is in Bps

int f0/1

service-policy out FTP_POLICY

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

QoS - Mark a routers self-generated OSPF traffic

Hi Jhonny,

By default cisco routers mark the routing protocol traffic with precence level 6 , i think its called "internet". You can either do what you were doing but little simple config like,

class-map CMAPOSPF

match ip precedence internet

!

policy-map PMAPOSPF

class CMAOSF

priority XXXX

!

or

As Alain said , you can shape the FTP traffic as it goes out from both ends and it will help.

Thanks,,

Nandan

VIP Expert

QoS - Mark a routers self-generated OSPF traffic

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting

2Mbps with Ethernet handoff?  First you likely should shape for the 2Mbps. As some shapers implicitly use FQ, that alone might be enough.

e.g.

int f0/1

shape average 2000000

You can do similar with a CBWFQ policy, config is a bit more complex and CBWFQ shaper can, I believe, work differently depending whether you're using pre- or post- HQF CBWFQ.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards