cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10559
Views
0
Helpful
12
Replies

Question of limit the inbound and outbound bandwidth - Cisco Router

wcpon_cisco
Level 1
Level 1

Hi guys, I'm planning to limit the inbound and outbound bandwidth from Cisco Router.

Please find my senario below,

Currently the Cisco Router interface is running in 100 Mbps, and connected to ISP.

ISP provide us bandwidth 5 Mbps and burstable to 10 Mbps.

Any burstable bandwidth more than 5 Mbps, there are charges involved.

I want to limit my interface only capped to 5 Mbps without burstable more than 5 Mbps, what should I do?

Is there any way I can capped the bandwidth to 5 Mbps?

Really appreciate if anyone here can assist me.

Thanks,

Woody

1 Accepted Solution

Accepted Solutions

You can police inbound and outbound

Lets say i wanted to limit to 3mb up and down, you can do this, For anything and everything (in this example):

### To match the traffic
ip access-list extended ACL_3Mbps
permit ip any any
!
### Class the traffic
class-map Link_3Mbps
match access-group ACL_3Mbps
!
### Apply policy against the class (type of traffic specified by your class-map)
policy-map Policy_3Mbps
class Link_3Mbps
police 3000000 8000 exceed-action drop (8000 is the burst rate)
!
interface gigabitethernet1/0
### Applies the policies inbound and outbound, both directions
service-policy input Policy_3Mbps
service-policy output Policy_3Mbps

Where the ACL is you can specify source and destination or just source or source and port depending on how you configure your ACL. You can change this to 5mb with no burst rate.

Hope this helps.

Link for your reference:
http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfpoli_ps1835_TSD_Products_Configuration_Guide_Chapter.html#wp1006389

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

12 Replies 12

I found it useful for you. Please read the document, I feel traffic shaping is the best option for you.

http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800a3a25.shtml

Please rate the post if it is informative.

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

The discussion happened below may be useful for you.

https://supportforums.cisco.com/thread/2207014?tstart=0

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."

Hi, for shapping only applicable to outbound, if I want to applicable to inbound and outbound, is it I need to use policy?

Kindly please advice.

You can police inbound and outbound

Lets say i wanted to limit to 3mb up and down, you can do this, For anything and everything (in this example):

### To match the traffic
ip access-list extended ACL_3Mbps
permit ip any any
!
### Class the traffic
class-map Link_3Mbps
match access-group ACL_3Mbps
!
### Apply policy against the class (type of traffic specified by your class-map)
policy-map Policy_3Mbps
class Link_3Mbps
police 3000000 8000 exceed-action drop (8000 is the burst rate)
!
interface gigabitethernet1/0
### Applies the policies inbound and outbound, both directions
service-policy input Policy_3Mbps
service-policy output Policy_3Mbps

Where the ACL is you can specify source and destination or just source or source and port depending on how you configure your ACL. You can change this to 5mb with no burst rate.

Hope this helps.

Link for your reference:
http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfpoli_ps1835_TSD_Products_Configuration_Guide_Chapter.html#wp1006389

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Thanks for your guidance. Appreciate it..

Just to double check with you this command,

police 3000000 8000 exceed-action drop (8000 is the burst rate)

For 3000000 is 3Mbps,

For 8000 is what bandwidth size? 8KB? 8Kb?

For 8000 is burst-normal or burst-max?

You are correct:
For 3000000 is 3Mb
For 8000 is 8Kb

Because we have the 'exceed-action drop' key words, the burst rate specified is the maximum allowed.

Hope this helps

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Hi Bilal,

The burst rate is it mentioning if the bandwidth more than 3Mb, I still allow the bandwidth burst-max to another 8Kb? If more than 8Kb it will drop?

Am I right??

The command states, allow a B/W of 3Mb with a burst rate of 8Kb. Anything in addition to this will be dropped.

So yes you are correct, you will never go above this limit, I hope this helps.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Thanks for your explaination.

I have configured the below onto my router.

"rate-limit input 4000000 65536 65536 conform-action transmit exceed-action drop"

Base on the above mention, what these means are, my Bandwith is 4Mb, with Normal Burst at 0.5 Mb and Max Burst is also 0.5 Mb. In total, the network traffic should not exceed 4.5 Mb? Anything more than the specify criteria will be drop. Please do correct me if my understanding is wrong.

Thank you

This is correct to my understanding, So 4Mb allowed with up to 0.5Mb burst rate, anything above this will drop. You haven't specified an ACL for your command?

Please note that's bits per second for the rate and Bytes for the burst.

You can verify with show interface rate-limit

Out of interest, which router are you using? Seems like you dont have to go through configuring your class-maps and policy-maps. I haven't tried this way before

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Hi, Bilal,

Thanks for your explaination. Appreciate it for your help.

My Cisco router model is Cisco 7204VXR

Yes, I can either configure rate-limit on the interface or using class-maps & policy-maps.

I believe the best practise is to create the class-maps & policy-maps for better maintenance and scalability.

Thanks.

Joseph W. Doherty
Hall of Fame
Hall of Fame

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

As other posts have already discussed, yes you usually cap bandwidth on Cisco routers.  Generally, you would want to shape for egress, and perhaps police on ingress.

However, before getting into the "how to", you really need clarification what exactly your ISP is measuring, both for ingress and egress.

The issue is, if the interface is running at 100 Mbps, all packet transfers happen at 100 Mbps.  Your "caps" are measured consumption over some time.  Correctly setting shaping or policing values requires knowing what your ISP is measuring.  Otherwise, you might not take advantage of all the bandwidth you're already paying for or still incur consumption charges you not expecting.

Once you do understand exactly what your ISP is measuring, you'll then need to decide how you want to conform.  For example, you might want to never exceed your 5 Mbps cap to avoid usage surcharges.

Once we know all that, we can deal with the "how to".  BTW, "how to" might vary based on platform/IOS, so providing that info could be useful.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card