cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
814
Views
5
Helpful
18
Replies
prague
Beginner

Rate limit subscriber ASR9k BNG

Hi everyone ,

 

I use the policy map below to limit the subscriber, but when I try to use the whole package or when the speed test is at full load on router, I see packet losses. Anyone know the reason?

 

policy-map 20M
class class-default
police rate 20 mbps burst 3840000 bytes peak-rate 20 mbps peak-burst 7680000 bytes
conform-action transmit
exceed-action drop
!
!
end-policy-map

loss.PNG

 

 

Thanks

18 REPLIES 18
Georg Pauwen
VIP Expert

Hello,

 

post the output of:

 

show interfaces x

 

where 'x' is the interface where you applied the service policy.

Without policy-map applied on subscriber interface, no packet loss seemed.... but when applied policy and bng configured , problem persists even exceed-action transmit

 

image_2021-09-11_15-19-38.pngimage_2021-09-11_15-19-52.pngimage_2021-09-11_15-20-16.pngimage_2021-09-11_15-20-35.pngimage_2021-09-11_15-20-45.pngimage_2021-09-11_15-20-55.png

Hello,

 

it looks like you are policing the default class, which means all traffic that exceeds the policed rate is being dropped. Which traffic (source/destination/port) do you want to police ?

Hi,

 

Limiting pppoe subscriber package . We want to police per pppoe user any any any

 

 

 

Hello @prague ,

>> We want to police per pppoe user any any any

OK have you applied the QoS policy map using

service-policy out 20M

under the PPP template context ?

 

Hope to help

Giuseppe

 

We already did basic config, problem is more specific. While the subscriber is using the whole package (all 20mbps), sessions are starting to drop and timeout starts

 

pppoe bba-group PPPOE
ac name BIGBNG
service selection disable
sessions vlan limit 65535
sessions inner-vlan limit 65535
sessions outer-vlan limit 65535
pado delay 0

 

interface TenGigE0/0/0/0.100
service-policy type control subscriber PPP
pppoe enable bba-group PPPOE

 

--------------------

 

radius attribute

 

cisco-avpair += ip:sub-qos-policy-out=20M",
cisco-avpair += ip:sub-qos-policy-in=5M"

prague
Beginner

While using all the speed which i specified in police rate , icmp drops starts. Anyone have any other ideas ?

nethousebimltd
Beginner

+1 following

Aleksandar Vidakovic
Cisco Employee

20Mbps on traffic generator my not be exactly 20Mbps on the router because of different encapsulation. You can adjust at using this command:

 

RP/0/RSP0/CPU0:CORE-TOP(config-subif)#service-policy output Parent account user-defined ?
<-63,+63> Overhead accounting value

Have you tried that already?

 

/Aleksandar

Hi,

 

Thanks for your answer. But our problem isn't exactly these overheads,

 

The problem is that the timeout and sessions break when the client router bursts and passes 20 mbps by 1-2 mbps.

Line card: A9K-MOD400-SE

MPA : A9K-MPA-20x10G

Let me make sure that I understand the use case. Are you saying that you see PPPoE session flap when the CPE sends traffic that exceeds the configured ingress policer rate?

 

/Aleksandar

Yes, we were trying as pppoe before, but now we are limiting the ip interface police rate to better understand the problem . Here is our config;

 

interface TenGigE0/0/0/0
service-policy input 20M
service-policy output 20M
vrf INTERNET
ipv4 mtu 1500
ipv4 address XX.XX.XX.XX 255.255.255.252


policy-map 20M
class class-default
police rate 20480000 bps burst 3840000 bytes peak-burst 7680000 bytes
conform-action transmit
exceed-action drop
!
!
end-policy-map

Hello,

 

this thread has become very long, so I am not sure what and what not has already been mentioned, but have you tried to shape instead of policing ? Something like:

 

policy-map 20M
class class-default
shape average 20480000

 

?

 

The thing with policers is that they drop traffic indiscriminately, while shapers are more 'forgiving'...