cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14201
Views
35
Helpful
26
Replies

Redistribute BGP into EIGRP help needed.

the-lebowski
Level 4
Level 4

Having a hell of a time getting BGP into EIGRP on one end of my WAN.  

Its working on one end but not the other.  I want this router to redistribute any BGP learned route into EIGRP and specific EIGRP learned routes into BGP.  

l3-CE#show run .....
router eigrp 3000
redistribute bgp 65000 route-map BGP2EIGRP
network 10.0.0.0
no auto-summary
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
network 10.0.0.0
redistribute connected
redistribute static
redistribute eigrp 3000 route-map EIGRP2BGP
neighbor 100.65.0.5 remote-as 3549
neighbor 100.65.0.5 send-community
neighbor 100.65.0.5 soft-reconfiguration inbound
no auto-summary
!
ip forward-protocol nd
ip route 10.99.0.0 255.255.0.0 10.120.2.1
ip route 10.100.0.0 255.255.0.0 10.120.2.1
!
!
no ip http server
no ip http secure-server
!
access-list 90 permit 10.100.0.0 0.0.255.255
access-list 100 permit ip any any
no cdp log mismatch duplex
!
!
!
route-map BPG2EIGRP permit 10
match ip address 100
set metric 100 1 255 1 1500
set tag 10
!
route-map EIGRP2BGP deny 10
match tag 10
!
route-map EIGRP2BGP permit 20
match ip address 90
!
l3-CE#show ip route eigrp

l3-CE#show ip route bgp
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
B 10.196.2.0/24 [20/0] via 100.65.0.5, 00:09:13
B 10.196.0.0/16 [20/0] via 100.65.0.5, 00:09:13

l3-CE#show ip eigrp neighbors
IP-EIGRP neighbors for process 3000
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.100.2.1 Fa0/0 13 00:09:22 48 288 0 43
0 10.100.2.10 Fa0/0 10 00:09:22 34 204 0 61

Downstream router (no eigrp routes):


6509-ds#show ip eigrp neighbors
IP-EIGRP neighbors for process 3000
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.100.2.5 Vl2 11 00:09:46 41 246 0 24
2 10.100.2.10 Vl2 14 02:27:33 27 200 0 59

6509-ds#show ip route eigrp


1 Accepted Solution

Accepted Solutions

Then it won't advertise them.

What you need to do is add static routes for the two /17s to your BGP router with a next hop IP of whatever the device is that is the EIGRP neighbor.

Then you can use network statements under BGP ie.

router bgp 65999
network 10.96.0.0 mask 255.255.128.0
network 10.96.128.0 mask 255.255.128.0

then you don't need your route map to control what is redistributed.

Jon

View solution in original post

26 Replies 26

julijime
Cisco Employee
Cisco Employee

Hi dpatten78,

When redistributing into EIGRP you need to specify a seed metric unless you're redistributing connected routes or from another EIGRP process. Please try something like the following:

 

router eigrp 3000
redistribute bgp 65000 route-map BGP2EIGRP metric 1000 10 255 1 1500


HTH

Julio

I added that command yet still no EIGRP routes being added to the routing table on 6509-ds from the upstream router.   Something is not right but I can't figure out what. 

router eigrp 3000
redistribute bgp 65000 metric 1000 10 255 1 1500 route-map BGP2EIGRP
network 10.0.0.0
no auto-summary

6509-ds#show ip route eigrp

6509-ds#show ip eigrp neighbors
IP-EIGRP neighbors for process 3000
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
2 10.100.2.10 Vl2 11 00:04:12 60 360 0 25
1 10.100.2.5 Vl2 11 00:04:13 50 300 0 12  <----this is L3-CE router running BGP and EIGRP

Hi,

are there any prefixes really redistributed from BGP to EIGRP on your l3-CE router?

Try sh ip eigrp topo ... command on it.

If the EIGRP topo database is empty, I'd check if 

route-map BPG2EIGRP permit 10
match ip address 100

is not causing a trouble?

Best regards,

Milan

Lol, sometimes its the simplest things.  I simply misspelled the route-map.  

route-map BPG2EIGRP permit 10
match ip address 100
set metric 100 1 255 1 1500
set tag 10
router eigrp 3000
redistribute bgp 65000 metric 1000 10 255 1 1500 route-map BGP2EIGRP

Once I fixed that it redistributed the routes correctly BUT its preferring the backup route via 10.100.255.2 which I don't want.  

6509-ds#show ip eigrp top 10.196.0.0/16
ip eigrp top 10.196.0.0/16
IP-EIGRP (AS 3000): Topology entry for 10.196.0.0/16
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 13150720
Routing Descriptor Blocks:
10.100.255.2 (FastEthernet0/1), from 10.100.255.2, Send flag is 0x0
Composite metric is (13150720/13125120), Route is Internal
Vector metric:
Minimum bandwidth is 8000 Kbit
Total delay is 501200 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1400
Hop count is 3
10.100.2.5 (Vlan2), from 10.100.2.5, Send flag is 0x0
Composite metric is (25602816/25600256), Route is External
Vector metric:
Minimum bandwidth is 100 Kbit
Total delay is 110 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 100.65.0.6
AS number of route is 65000
External protocol is BGP, external metric is 0
Administrator tag is 3549 (0x00000DDD)

P 10.196.0.0/16, 1 successors, FD is 13150720
via 10.100.255.2 (13150720/13125120), FastEthernet0/1
via 10.100.2.5 (2565120/2562560), Vlan2

1 last question, how do I force 6509-ds to prefer the route learned via 10.100.2.5?  That route is being redistributed from BGP to EIGRP from l3-CE.

The  EIGRP route via the backup is internal ie AD 90.

The redistributed route is EIGRP external ie. AD 170.

So modifying the metrics won't do any good here and in addition you cannot modify the AD of only some EIGRP external routes ie. you can only modify the AD of all external routes which I suspect is not something you want to do.

Assuming you don't want to create an EBGP peering between the 6500 and CE device then you have these possible solutions -

1) create a GRE tunnel from the 6500 to the other site and make the routes learnt internal and then you can modify the metrics.

2) make the backup links EIGRP routes external and then modify the metrics.

You can do this by either using another EIGRP process on the backup link or maybe redistributing that route into EIGRP at the remote site.

3) the route is a /16 so you could advertise as is via the backup link but via BGP advertise two /17's ie. 10.96.0.0/17 and 10.96.128.0/17 which would mean the external routes were more specific and so would be chosen.

Of the above the summary solution may be the easiest but it depends on how the addressing works.

Jon

Jon

I tried option 3 but wasn't able to get the /17's to advertise correctly.  The core (and everything along that path) is still only seeing the entire /16.  Any ideas?

Core:


P 10.196.2.0/24, 1 successors, FD is 2562816, tag is 3549
via 10.100.2.5 (2562816/2560256), Vlan2
P 10.196.0.0/24, 1 successors, FD is 2562816, tag is 3549
via 10.100.2.5 (2562816/2560256), Vlan2
P 10.196.0.0/16, 1 successors, FD is 13150720
via 10.100.255.2 (13150720/13125120), FastEthernet0/1
via 10.100.2.5 (2562816/2560256), Vlan2

Remote site:

router eigrp 3000
redistribute bgp 65999 route-map BGP2EIGRP
network 10.0.0.0
distribute-list 99 out Tunnel1
distribute-list 99 out Tunnel2
no auto-summary
eigrp router-id 10.196.2.2

router bgp 65999
no synchronization
bgp log-neighbor-changes
redistribute eigrp 3000 route-map EIGRP2BGP
neighbor 100.65.0.1 remote-as 3549
neighbor 100.65.0.1 weight 4000
no auto-summary
access-list 90 permit 10.196.0.0 0.0.127.255
access-list 90 permit 10.196.128.0 0.0.127.255
!
route-map EIGRP2BGP deny 10
match tag 10
!
route-map EIGRP2BGP permit 20
match ip address 90
!
route-map BGP2EIGRP permit 10
match ip address 100
set metric 100 1 255 1 1400
set tag 10
!

Is the BGP router at the remote site receiving those /17s via EIGRP ?

Jon

No it's not, it is still seeing a /16.    I have a static route on that BGP router pointing the /16 to the next hop and if I remove that it drops the /16 all-together.   So it looks like none of what I am trying to redistribute is working on the remote site end.  


L3-PE#show ip bgp 10.196.0.0/17
% Network not in table
 Network Next Hop Metric LocPrf Weight Path
*> 10.99.0.0/16 100.65.0.6 0 0 65000 ?
*> 10.100.0.0/16 100.65.0.6 30720 0 65000 ?
*> 10.100.2.0/24 100.65.0.6 0 0 65000 ?
*> 10.196.0.0/24 100.65.0.2 0 0 65999?
*> 10.196.0.0/16 100.65.0.2 0 32768 ?
*> 10.196.2.0/24 100.65.0.2 0 0 65999 ?
...

Then it won't advertise them.

What you need to do is add static routes for the two /17s to your BGP router with a next hop IP of whatever the device is that is the EIGRP neighbor.

Then you can use network statements under BGP ie.

router bgp 65999
network 10.96.0.0 mask 255.255.128.0
network 10.96.128.0 mask 255.255.128.0

then you don't need your route map to control what is redistributed.

Jon

Perfect, thanks a lot Jon!  Its now preferring the smaller /17's and the backup path shows the /16.  One last question, can I use a prefix-list to only advertise the /17's to the BGP router and beyond?  I ask because right now its advertising the smaller /24's as well and I prefer a clearer routing table with just the 2 /17s.

Not sure what you are asking.

Did you advertise the /17s to the BGP router with EIGRP or did you use network statements ?

Which device is advertising the /24s ?

Jon

I used the network statements but I forgot to remove 'redistribute eigrp 3000.'  Once I removed that the BGP routing table cleaned itself up.  


Network Next Hop Metric LocPrf Weight Path
..
*> 10.196.0.0/17 100.65.0.2 0 32768 ?
*> 10.196.128.0/17 100.65.0.2 0 32768 ?

Thanks again for your help with all of this.  

Okay, that makes sense :)

Jon

This is just for your info so you don't have to do it but it just occurred to me that your BGP router is getting /24s that are part of those /17 ranges.

If that is the case then an alternative to using network statements is to use the BGP aggregate address command which advertises a summary address.

So instead of using static routes with network statements you can still redistribute EIGRP into BGP and as long as there is a route that is part of each /17 in the BGP table (note BGP not IP routing table) then you can advertise a summary for the /17 and the more specific prefixes will not be advertised.

It is just a different way to achieve the same thing and it really depends on the rest of your internal topology as to which is best.

So using network statements means as long as the next hop IP for those static routes is up those networks will be advertised by BGP whether or not they are reachable which in some topologies means you may not switch to DMVPN.

Whereas because the aggregate address command is reliant on the EIGRP routes being redistributed into BGP if the BGP router stops receiving those routes it stops advertising the summary address.

Like I say it really depends on the internal topology and I am not trying to confuse the issue so please feel free to ignore.

I am logging off now but if you want to discuss further just post back and we can.

Jon

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: