cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5173
Views
10
Helpful
7
Replies

Redistribute BGP into EIGRP

I am working on a network which has two sites (Site A and Site B). Each site has a MPLS router running BGP and OSPF and is patched into 6509 core switches. There are two 6509s per site and both MPLS routers only have one link to one 6509.

Each site also has two Nexus 7706 switches running EIGRP.

 

My goal is to decommission the 6509s. I am currently planning to move the MPLS routers off 6509s to Nexus. The MPLS routers are redistributing BGP into OSPF and I will have to configure these to redistribute BGP into EIGRP. I am unsure about how to do the metrics

 

MPLS Router configuration:

!

router ospf 100

router-id 10.10.10.100

redistribute bgp 15000 metric 100 subnets route-map Set-OSPF-Metric

passive-interface default

no passive-interface GigabitEthernet0/1 //This is the port that is connected to 6509

!

ip bgp-community new-format

ip community-list 1 permit 100:100

ip community-list 2 permit 100:200

ip community-list 31 permit 31:100

ip community-list 34 permit 34:100

ip community-list 53 permit 53:100

!

router bgp 15000

bgp log-neighbor-changes

network 0.0.0.0

neighbor 10.10.60.5 remote-as 64542

neighbor 10.10.100.2 remote-as 12641

neighbor 10.10.100.2 ebgp-multihop 2

neighbor 10.10.100.2 update-source GigabitEthernet0/0.26

neighbor 10.10.100.2 send-community

neighbor 10.10.100.2 route-map community out

!

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 10.1.1.1

!

ip access-list standard catch-any

permit any

ip access-list standard community

permit any

!

ip prefix-list bgp-deny-routes seq 5 permit 0.0.0.0/0

!

route-map Set-Local-Pref permit 10

set local-preference 50

!

route-map Set-Prepend permit 10

match as-path 1

set as-path prepend 15000 15000

!

route-map Set-Community permit 10

set community 100:200

!

route-map Set-OSPF-Metric permit 2

match community 34

set metric 1000

!

route-map Set-OSPF-Metric permit 3

match community 31

set metric 5

!

route-map Set-OSPF-Metric permit 4

match community 53

set metric 5

!

route-map Set-OSPF-Metric deny 5

match ip address prefix-list bgp-deny-routes

!

route-map Set-OSPF-Metric permit 10

match community 1

set metric 100

!

route-map Set-OSPF-Metric permit 20

match community 2

set metric 200

!

route-map Set-OSPF-Metric permit 30

!

route-map community permit 10

match ip address community

set community 254:100

!

route-map community permit 20

match ip address catch-any

!

 

Proposed Config:

!

router EIGRP 100

redistribute bgp 15000 ????????????????????????

passive-interface default

no passive-interface GigabitEthernet0/1

!

route-map Set-EIGRP-Metric permit 2

match community 34

set metric 1000

!

route-map Set-EIGRP-Metric permit 3

match community 31

set metric 5

!

route-map Set-EIGRP-Metric permit 4

match community 53

set metric 5

!

route-map Set-EIGRP-Metric deny 5

match ip address prefix-list bgp-deny-routes

!

route-map Set-EIGRP-Metric permit 10

match community 1

set metric 100

!

route-map Set-EIGRP-Metric permit 20

match community 2

set metric 200

!

 

 

 

Currently on the 6509s, OSPF is redistributed into EIGRP for network on the Nexus 7Ks

          !

router eigrp 100

network 10.0.0.0

redistribute connected

!

route-map OSPF-to-EIGRP permit 10

match source-protocol ospf 1

match route-type external

set metric 50000 100 255 1 1500

!

 

The IP addresses in here are fictitious.

I want to use route-maps to filter routes and EIGRP metrics to prefer one router over the other. There is one router per site and I want to make sure redistributed routes are advertised back into BGP by the partner router and vice versa.

 

I hope this all makes sense. I have attached two jpgs, one of current setup and one of proposed setup.

 

Thanks

Anthony

7 Replies 7

Richard Burts
Hall of Fame
Hall of Fame

Anthony

 

There are things about your environment that I do not understand yet and that impacts my ability to give good and comprehensive advice. But here are a couple of comments to start with.

 

Your drawing of proposed setup shows that the MPLS connection has moved from 6509 to Nexus but the 6509s are still in the picture. Will they continue to be active in the network? What are the routing impacts of this?

 

In your proposed configs you have several entries like this

route-map Set-EIGRP-Metric permit 2

match community 34

set metric 1000

The OSPF protocol metric for redistribution is a single numeric value (such as 1000 and represents the OSPF cost). But the EIGRP metric for redistribution consists of 5 numeric values (they represent bandwidth, delay, reliability, load, mtu). For EIGRP the first two metrics (bandwidth and delay) are the ones used to calculate the metric for the routing table. So if you want to establish preference between the routers specify a lower value of delay for the primary router and specify a higher value of delay for the secondary router.

 

In your proposed config you have this

redistribute bgp 15000 ????????????????????????

In addition to specifying the source protocol (bgp 15000) you would need to specify a route map to control redistribution and to set the various metrics for redistribution.

 

In your post you show a partial config from the 6509

router eigrp 100

network 10.0.0.0

redistribute connected

but curiously you do not include the line where OSPF is redistributed into EIGRP. I am guessing that it does specify the route map and the 5 numeric values which could serve as your model for redistributing into EIGRP on the Nexus.

 

I have not checked the individual route map instances and have not evaluated whether the suggested EIGRP instances correctly map to corresponding OSPF instances.

 

HTH

 

Rick

 

 

HTH

Rick

Hi Rick,

Thanks for your details response.

The aim is to decommissioned the 6509s altogether but I will not be able to complete this as part of this migration. This will be completed in two week after the routers are moved off the 6509s. The 6509s will continue to route traffic until these services are migrated off and then they will be shutdown.

I would like all routing from branch offices(BGP) to route into the Nexus 7706s into EIGRP. If the traffic requires to be routed onto the remaining services on the 6509s, it will routing into OSPF and routing back will take the same route back, I want to eliminate all asymmetrical routing.

 

Regarding this:
 route-map Set-EIGRP-Metric permit 2
 match community 34
 set metric K1 K2 K3 K4 K5

 

This is the configuration on the MPLS routing going into OSPF on the 6509s, I just changed the route-map name.

 

Here is the full configuration taken from 6509A:
!
router eigrp 100
 network 10.0.0.0
 network NEXUSA 0.0.0.3
 network 6509B 0.0.0.3
 redistribute connected
 redistribute ospf 1 route-map OSPF-to-EIGRP
 passive-interface Vlan1
 passive-interface Vlan100
 passive-interface Vlan600
 passive-interface Vlan660
!
route-map OSPF-to-EIGRP permit 10
 match source-protocol ospf 1
 match route-type external
 set metric 50000 100 255 1 1500
!

Looking at this metric above "set metric 50000 100 255 1 1500", what netric would be the best to use so that the BGP traffic will route accordingly and will not upset the router from OSPF to EIGRP and vice-versa?

 

Hope this makes sense.

 

Thanks
Anthony
 

Anthony

 

Parts of your question are relatively easy to answer and other parts are not. So lets start with easy. As you have in your post the metric specified for EIGRP has 5 parameters, K1, K2, K3, K4, K5. So your suggestion of using 50000 100 255 1 1500 is an excellent place to start. As I tried to explain in my previous response of the 5 parameters only 2 are actually used in calculating the metric (why that is the case is outside the scope of this response - unless you specifically ask about it) K1 and K2. In establishing a primary and backup relationship it is generally better practice to manipulate K2 rather than K1 (again why this is true is beyond scope - unless you specifically ask). So redistributing on one Nexus using 100 and redistributing on the other Nexus with 200 should establish a primary/backup relationship.

 

The easy part was redistributing BGP to create a primary/backup relationship. The not easy part is the relationship of EIGRP and OSPF in your network during the period when 6500 are still active in your network. And we do not have enough understanding of your network to be able to give good answers about that. It appears that part of your network is using OSPF routes while other parts of your network are using EIGRP routes. But we do not know which part is which.

 

It is clear that you have been redistributing BGP into OSPF. I am assuming that you have been redistributing those routes from OSPF into EIGRP somewhere - but perhaps the EIGRP parts of the network have just used default routing to get their data from EIGRP to OSPF to use the BGP routes? Without knowing the relationship of those parts of your network we can not give good advice. There is another unknown factor, which is probably related to what I have just said. The OSPF part of the network has known the BGP routes. As you transition and the BGP routes are redistributed into EIGRP do you need a mechanism to get those routes into OSPF?

 

Another aspect (or perhaps more of the same) is your mention of branch offices. I am assuming that the branch offices have been learning routes from OSPF. What do you plan to change so that they learn routes from EIGRP rather than from OSPF?

 

HTH

 

Rick

 

 

HTH

Rick

Hi Rick,

 

Once again, thanks for your detailed response.

 

Regarding the preference of one link over the other, I am manipulating the K2 metric of one link to be higher than the other. By doing this Site A will route over the local MPLS router rather than traversing the network to go out to MPLS. The same goes for Site B.

 

I am now going to migrate all remaining VLANs on the 6509s to Nexus, once these VLANs will be on Nexus, there will be on EIGRP. Therefore there will be no need for OSPF and the VLANs will be trunked across the links between Nexus and 6509s. In Nexus and 6509s only EIGRP is required and this will lead to a much simpler configuration.

 

Now, only BGP will be redistributed into EIGRP and OSPF configuration will also be removed from the MPLS routers.

The branch offices (they are only small branches with less than 20 users and all services are centralised and are in Site A and B) learn their routes via BGP.

 

What can I do to make sure there will be no asymmetrical routing introduced into the network?

 

Thanks
Anthony.

Anthony

 

To establish a primary/backup relationship between EIGRP routers it is better to manipulate the K2 metric than the K1 metric. So you are on the right path in setting up your redistribution from BGP into EIGRP. Having said that I am a bit puzzled by your comment that you want site A to route out its local connection and site B to route out its local connection. That sounds sort of like the opposite of primary/backup. Perhaps I need a better understanding of how you want your network to work.

 

As I started this response, and thinking in the context of primary/backup I was going to suggest that in the BGP configuration you might set the weight parameter on the incoming BGP advertisement. This would establish a primary/backup relationship for BGP similar to what you are doing for EIGRP. That would help reduce any potential asymmetry in routing. But if you want each site to route out its local interface then you do not want to use weight in BGP.

 

I do not know enough about how your branches are set up to have any opinion or offer any advice about how to do their routing.

 

HTH

 

Rick

HTH

Rick

Hello,

 

in addition to Richard's remarks, a 'basic' default value would be:

 

redistribute bgp 15000 metric 100000 500 255 1 1500

Another option overall, for the redistributing of BGP into EIGRP, I would just do the best to match the interface(s) it will transverse, so delay of 500 would surprise me if that is the case.  

 

Second, IMO, I would keep the metric the same on each router, than create a iBGP between the two BGP routers and let them do the manipulating of traffic instead of messing with EIGRP metrics.  Typically LAN connections are never a problem on bandwidth, it is the circuits that are usually the problem.  I would also create dual EIGRP neighbors on each router, connect one to each Nexus.

 

Thirdly, I would assign a route-map to the redistribution command on EIGRP and configure the metrics there.  you will have better future flexibility this way.

 

!

router eigrp 10

redistribute BGP XXX route-map REDIST

!

route-map REDIST permit 100

match ip address prefix-list REDIST_PRE

set metric 50000 10 255 1 1500

!

ip prefix-list REDIST_PRE permit 0.0.0.0/0 le 32

!

TIPS:

1. you should never use the interface metric commands to manipulate routes as this will affect other processes, like QOS.  

2. if you can't do iBGP between the two MPLS routers, if the cores are neighbors over the fiber they should auto calculate (DUAL) and route out locally typically.  Unless there are some hidden challenges i am not aware of.

 

 

Just another overall option for you, cheers - Tony

 

Review Cisco Networking products for a $25 gift card