cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
619
Views
5
Helpful
1
Replies
Highlighted
Beginner

Redistributing BGP route into OSPF from Azure ExpressRoute

BGP/OSPF novice here.  ICND 1 and 2 only went over the basics.  

 

I'm using Microsoft's Azure ExpressRoute with private peering on an ASR1001X with XE 3.16.02.S

 

show bgp does show my remote routes in Azure.  How do I publish these into my internal OSPF routes so that everyone else knows how to get into the azure private space?  

 

I'm able to see all the other OSPF routes in my network on this ASR so I know I'm a member of OSPF, I just can't figure out how to advertise my azure routes to the rest of my network.

 

10.0.0.16/32 is the primary network

10.0.0.20/32 is the secondary

 

172.30.0.0/16 is the remote azure ip space

10.40.0.11 is the ASR

 

EQX-DA2-ASR#show ip route

Gateway of last resort is 10.40.0.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 10.40.0.1
10.0.0.0/8 is variably subnetted, 29 subnets, 6 masks
O 10.0.0.0/30 [110/3] via 10.40.0.1, 01:48:33, GigabitEthernet0/0/1
.
.
.
C 10.0.0.16/30 is directly connected, GigabitEthernet0/0/3.1
L 10.0.0.17/32 is directly connected, GigabitEthernet0/0/3.1
C 10.0.0.20/30 is directly connected, GigabitEthernet0/0/4.1
L 10.0.0.21/32 is directly connected, GigabitEthernet0/0/4.1
B 172.30.0.0/16 [20/0] via 10.0.0.18, 2d19h


show bgp
BGP table version is 3, local router ID is 10.40.0.11

Network Next Hop Metric LocPrf Weight Path
*> 10.40.0.0/24 0.0.0.0 0 32768 i
* 172.30.0.0 10.0.0.22 0 12076 i
*> 10.0.0.18 0 12076 i

show run
.
.
.

!
interface GigabitEthernet0/0/1
ip address 10.40.0.11 255.255.255.0
ip ospf 1 area 0
negotiation auto
!
interface GigabitEthernet0/0/3
description DA1-CX-PRI-01
no ip address
negotiation auto
!
interface GigabitEthernet0/0/3.1
description ExpressRoute Primary
encapsulation dot1Q 1000
ip address 10.0.0.17 255.255.255.252
!
interface GigabitEthernet0/0/4
description DA1-CX-SEC-01
no ip address
negotiation auto
!
interface GigabitEthernet0/0/4.1
description ExpressRoute Secondary
encapsulation dot1Q 1001
ip address 10.0.0.21 255.255.255.252
!
router ospf 1
router-id 10.40.0.11
network 172.30.0.0 0.0.255.255 area 0
!
router bgp 64512
bgp log-neighbor-changes
neighbor 10.0.0.18 remote-as 12076
neighbor 10.0.0.22 remote-as 12076
!
address-family ipv4
network 10.0.0.30 mask 255.255.255.255
network 10.40.0.0 mask 255.255.255.0
neighbor 10.0.0.18 activate
neighbor 10.0.0.22 activate
exit-address-family
!

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: Redistributing BGP route into OSPF from Azure ExpressRoute

Hi,

 

This is what you need to redistribute bgp prefixes into ospf:

 

router ospf 1

redistribute bgp 64512 subnets 

!

hope this helps.

View solution in original post

1 REPLY 1
Highlighted
Contributor

Re: Redistributing BGP route into OSPF from Azure ExpressRoute

Hi,

 

This is what you need to redistribute bgp prefixes into ospf:

 

router ospf 1

redistribute bgp 64512 subnets 

!

hope this helps.

View solution in original post