cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Redistribution b/w OSPF and RIP Issue

libra_ali786
Beginner
Beginner

I have a one lab environment. I trying to redistribute rip and ospf. Rip network inject from 2 sides routers 3 and 4 , I applying the Route-map to TAG the injected routes from both.But I figure out some OSPF Routes (10.10.10.0 and 192.168.25.0) networks also injected back in to OSPF network by RIP. You can on see my router 3 and 4 also getting the same routes from the Rip. See attached pictures (highlighted networks getting from Rip)  and my configurations.

Please answer the followings:

1. What are the reason?

2. How to handle it.

 

hostname R1
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex half
!

router rip
version 2
offset-list 0 out 5
network 1.0.0.0
network 192.168.12.0
no auto-summary
!








hostname R2

!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 192.168.23.2 255.255.255.0
duplex full
speed auto
!
interface FastEthernet2/0
ip address 192.168.24.2 255.255.255.0
duplex full
speed auto
!
router rip
version 2
network 192.168.12.0
network 192.168.23.0
network 192.168.24.0
no auto-summary
!








hostname R3

!
interface Loopback1
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.1 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 192.168.23.1 255.255.255.0
duplex full
speed auto


!
router ospf 1
router-id 3.3.3.3
redistribute rip subnets route-map TAGGING
network 10.10.10.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 1 route-map TAGGING
network 192.168.23.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
route-map TAGGING deny 10
match tag 1234
!
route-map TAGGING permit 20
set tag 1234
!











hostname R4




!
interface Loopback1
ip address 192.168.25.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 192.168.24.1 255.255.255.0
duplex full
speed auto
!


!
router ospf 1
router-id 4.4.4.4
redistribute rip subnets route-map TAGGING
network 192.168.25.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 0
!
router rip
version 2
redistribute ospf 1 metric 1 route-map TAGGING
network 192.168.24.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
route-map TAGGING deny 10
match tag 1234
!
route-map TAGGING permit 20
set tag 1234
!
1 ACCEPTED SOLUTION

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @libra_ali786 ,

 

You redistribution filtering configuration is fine. The behavior you are seeing with 192.168.25.0 and 10.10.10.0 is due to ospf advertising these prefixes as /32, which is the default when advertising the loopback interface ip address, regardless of the subnet mask configured on the loopback interface. You can change the default behavior by configuring "ip ospf network point-to-point" under the loopback interface. This should fix the issue.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

2 REPLIES 2

Harold Ritter
Cisco Employee
Cisco Employee

Hi @libra_ali786 ,

 

You redistribution filtering configuration is fine. The behavior you are seeing with 192.168.25.0 and 10.10.10.0 is due to ospf advertising these prefixes as /32, which is the default when advertising the loopback interface ip address, regardless of the subnet mask configured on the loopback interface. You can change the default behavior by configuring "ip ospf network point-to-point" under the loopback interface. This should fix the issue.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thank you very Much Sir.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: