cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3592
Views
0
Helpful
9
Replies
Highlighted
Beginner

Reserve outbound bandwidth for VoIP

Greetings,

I have a Cisco 877 on an ADSL connection.  QoS isn't doing the trick -- I need to reserve 200 meg or so of my outbound (upstream) bandwidth for VoIP to end complaints about voice quality.

Can anyone point me to an example of how to classify SIP, RTP, IAX, and Skype traffic and put a rate limit on anything that doesn't fall into that category?  The VoIP phones also are in their own IP range on the LAN side if that would make things easier...or I could even connect them into a specific port on the internal switch in the router.

Advice appreciated!

Thanks,
Eric

Everyone's tags (5)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Advocate

Re: Reserve outbound bandwidth for VoIP

Firstly - I do not mark and prioritise in the same place/policy.

I would mark the VoIP traffic on INGRESS from the LAN

class-map match-any VoIP

match  dscp ef

match protocol sip

match protocol skype

match protocol custom-01

match protocol rtp audio

match protocol rtp video

!

policy-map Mark_VoIP_LAN

class VoIP

set dscp ef

Int x/x Directly connected LAN interface to VoIP Devices

service-policy input Mark_VoIP_LAN

Then change

policy-map SDM-QoS-Policy-3

class VoIP

  set dscp ef (remove this - already done) on LAN policy above)

  priority xxx (actual number in Kbps you want) not the percentage of the interface.

class class-default

  fair-queue
  random-detect dscp-based *** WRED***

HTH>

View solution in original post

Highlighted
Advocate

Re: Reserve outbound bandwidth for VoIP

Missing:-

interface Dialer0

service-policy output SDM-QoS-Policy-3

Other than that - looks OK.

View solution in original post

9 REPLIES 9
Highlighted
Advocate

Re: Reserve outbound bandwidth for VoIP

Eric,

200Mbs? are you seirous? I have a central site location with 300+ people using VoIP phones running on a 10mbs line?

QoS probably is not working for you - as you may not have deployed it correctly.  Remember - Classify & Mark = congestion avoidance.

HTH>

Highlighted
Beginner

Re: Reserve outbound bandwidth for VoIP

Any thoughts on what I did wrong here?

I'm new to QoS and used SDM to create this.  The major problem I'm having is with SIP/RTP.

!

class-map match-any VoIP

match  dscp ef

match protocol sip

match protocol skype

match protocol custom-01

match protocol rtp audio

match protocol rtp video

class-map match-any SDM-Transactional-1

match protocol citrix

match protocol finger

match protocol notes

match protocol novadigm

match protocol pcanywhere

match protocol secure-telnet

match protocol sqlnet

match protocol sqlserver

match protocol ssh

match protocol telnet

match protocol xwindows

class-map match-any SDM-Signaling-1

match protocol h323

match protocol rtcp

match protocol sip

class-map match-any SDM-Routing-1

match protocol bgp

match protocol eigrp

match protocol ospf

match protocol rip

match protocol rsvp

class-map match-any SDM-Voice-1

match protocol rtp audio

match protocol custom-01

match protocol skype

class-map match-any SDM-Management-1

match protocol dhcp

match protocol dns

match protocol imap

match protocol kerberos

match protocol ldap

match protocol secure-imap

match protocol secure-ldap

match protocol snmp

match protocol socks

match protocol syslog

class-map match-any Inbound-VoIP

match  dscp ef

match protocol custom-01

match protocol rtp video

match protocol rtp audio

match protocol skype

match protocol sip

!

!

policy-map SDM-QoS-Policy-2

class Inbound-VoIP

  set dscp ef

class class-default

   police cir 4500000

     conform-action transmit

     exceed-action drop

     violate-action drop

policy-map SDM-QoS-Policy-3

class VoIP

  set dscp ef

  priority percent 20

class class-default

  fair-queue

policy-map SDM-QoS-Policy-1

class SDM-Voice-1

  set dscp ef

  priority percent 75

class SDM-Signaling-1

  set dscp cs3

class SDM-Routing-1

  set dscp cs6

class SDM-Management-1

  set dscp cs2

class SDM-Transactional-1

  set dscp af21

class class-default

   police cir 375000

     violate-action drop

  bandwidth remaining percent 20

!

!

....

!

interface Dialer0

ip address negotiated

ip access-group 103 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nbar protocol-discovery

ip flow ingress

ip flow egress

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username xxxxxxxxxxxxx xxxxxxxxxxxxx xxxxxxxxxxxxxxxxx

service-policy input SDM-QoS-Policy-2

service-policy output SDM-QoS-Policy-3

!

Highlighted
Advocate

Re: Reserve outbound bandwidth for VoIP

Firstly - I do not mark and prioritise in the same place/policy.

I would mark the VoIP traffic on INGRESS from the LAN

class-map match-any VoIP

match  dscp ef

match protocol sip

match protocol skype

match protocol custom-01

match protocol rtp audio

match protocol rtp video

!

policy-map Mark_VoIP_LAN

class VoIP

set dscp ef

Int x/x Directly connected LAN interface to VoIP Devices

service-policy input Mark_VoIP_LAN

Then change

policy-map SDM-QoS-Policy-3

class VoIP

  set dscp ef (remove this - already done) on LAN policy above)

  priority xxx (actual number in Kbps you want) not the percentage of the interface.

class class-default

  fair-queue
  random-detect dscp-based *** WRED***

HTH>

View solution in original post

Highlighted
Beginner

Re: Reserve outbound bandwidth for VoIP

Thanks.

Would that mark all inbound traffic on the LAN interface as ef, or only if it also met the class-map ?

Highlighted
Advocate

Re: Reserve outbound bandwidth for VoIP

Only for traffic that meets the criteria stated in the class map, any other traffic would not be marked.

Highlighted
Beginner

Re: Reserve outbound bandwidth for VoIP

Thank you very much!  Does this look right?  Anything I should remove?

!

class-map match-any VoIP

match  dscp ef

match protocol sip

match protocol skype

match protocol custom-01

match protocol rtp audio

match protocol rtp video

class-map match-any SDM-Transactional-1

match protocol citrix

match protocol finger

match protocol notes

match protocol novadigm

match protocol pcanywhere

match protocol secure-telnet

match protocol sqlnet

match protocol sqlserver

match protocol ssh

match protocol telnet

match protocol xwindows

class-map match-any SDM-Signaling-1

match protocol h323

match protocol rtcp

match protocol sip

class-map match-any SDM-Routing-1

match protocol bgp

match protocol eigrp

match protocol ospf

match protocol rip

match protocol rsvp

class-map match-any SDM-Voice-1

match protocol rtp audio

match protocol custom-01

match protocol skype

class-map match-any SDM-Management-1

match protocol dhcp

match protocol dns

match protocol imap

match protocol kerberos

match protocol ldap

match protocol secure-imap

match protocol secure-ldap

match protocol snmp

match protocol socks

match protocol syslog

class-map match-any Inbound-VoIP

match  dscp ef

match protocol custom-01

match protocol rtp video

match protocol rtp audio

match protocol skype

match protocol sip

!

!

policy-map SDM-QoS-Policy-2

class Inbound-VoIP

  set dscp ef

class class-default

   police cir 4500000

     conform-action transmit

     exceed-action drop

     violate-action drop

policy-map SDM-QoS-Policy-3

class VoIP

  priority 200

class class-default

  fair-queue

  random-detect dscp-based

policy-map SDM-QoS-Policy-1

class SDM-Voice-1

  set dscp ef

  priority percent 75

class SDM-Signaling-1

  set dscp cs3

class SDM-Routing-1

  set dscp cs6

class SDM-Management-1

  set dscp cs2

class SDM-Transactional-1

  set dscp af21

class class-default

   police cir 375000

     violate-action drop

  bandwidth remaining percent 20

policy-map Mark_VoIP_LAN

class VoIP

  set dscp ef

!

!

!

!

interface Null0

no ip unreachables

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.2 point-to-point

no ip redirects

no ip unreachables

no ip proxy-arp

pvc 0/35

  oam-pvc manage

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 10.0.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip inspect sdm_ins_in_100 in

ip route-cache flow

ip tcp adjust-mss 1412

service-policy input Mark_VoIP_LAN

!

interface Dialer0

ip address negotiated

ip access-group 103 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nbar protocol-discovery

ip flow ingress

ip flow egress

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp pap sent-username xxxxxxxxxxxxxxxxxxxxxxxxx

service-policy input SDM-QoS-Policy-2

!

Highlighted
Advocate

Re: Reserve outbound bandwidth for VoIP

Missing:-

interface Dialer0

service-policy output SDM-QoS-Policy-3

Other than that - looks OK.

View solution in original post

Highlighted
Beginner

Re: Reserve outbound bandwidth for VoIP

Thank you very much Andrew!

For anyone else who finds this thread in the future, I also just learned that despite the integrated DSL interface, it appears that the Cisco 877 doesn't "know" how fast the DSL link is. It appears to you need to manually tell it:

interface Dialer0

bandwidth 768
bandwidth receive 5000

I expect I'll undoubtedly have to tweak these downward until I achieve VoIP nirvana.

Thanks again!

Highlighted
Beginner

Re: Reserve outbound bandwidth for VoIP

Mistyped...should have read "200kbps"