cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
475
Views
5
Helpful
8
Replies

rip does not work

I have ISR2821  (c2800nm-adventerprisek9_ivs-mz.150-1.M).

I configured rip but it does not work.

I  am sure that all is right.

I run "debug ip rip"  and  see clean screen.

In my network  rip works on other router and all devices received packets.

 

8 REPLIES 8
shh5455
Participant

Can you post your config?

it is loaded.

 

Current configuration : 10822 bytes
!
! Last configuration change at 00:36:27 Moscow Fri Jan 23 2015 by admin
! NVRAM config last updated at 18:58:44 Moscow Thu Jan 15 2015 by admin
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISR2821
!
boot-start-marker
boot-end-marker
!
logging buffered 52000
enable secret 5 $1$Mxcvbxcvbxcv
enable password vcvbcvb
!
no aaa new-model
!
!
!
clock timezone Moscow 3
clock summer-time Moscow date Mar 30 2003 2:00 Oct 26 2003 3:00
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip name-server 192.168.0.7
ip name-server 192.168.0.15
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
parameter-map type regex sdm-regex-nonascii
 pattern [^\x00-\x80]

parameter-map type protocol-info msn-servers
 server name messenger.hotmail.com
 server name gateway.messenger.hotmail.com
 server name webmessenger.msn.com

parameter-map type protocol-info aol-servers
 server name login.oscar.aol.com
 server name toc.oscar.aol.com
 server name oam-d09a.blue.aol.com

parameter-map type protocol-info yahoo-servers
 server name scs.msg.yahoo.com
 server name scsa.msg.yahoo.com
 server name scsb.msg.yahoo.com
 server name scsc.msg.yahoo.com
 server name scsd.msg.yahoo.com
 server name cs16.msg.dcn.yahoo.com
 server name cs19.msg.dcn.yahoo.com
 server name cs42.msg.dcn.yahoo.com
 server name cs53.msg.dcn.yahoo.com
 server name cs54.msg.dcn.yahoo.com
 server name ads1.vip.scd.yahoo.com
 server name radio1.launch.vip.dal.yahoo.com
 server name in1.msg.vip.re2.yahoo.com
 server name data1.my.vip.sc5.yahoo.com
 server name address1.pim.vip.mud.yahoo.com
 server name edit.messenger.yahoo.com
 server name messenger.yahoo.com
 server name http.pager.yahoo.com
 server name privacy.yahoo.com
 server name csa.yahoo.com
 server name csb.yahoo.com
 server name csc.yahoo.com

!
!
!
!
!
!
voice-card 0
!
!
crypto pki trustpoint TP-self-signed-193052331
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-193052331
 revocation-check none
 rsakeypair TP-self-signed-193052331
!
!
!
license udi pid CISCO2821 sn FHK0914F2FL
username admin privilege 15 secret 5 $1$
!
redundancy
!
!
!
class-map type inspect match-any SDM_AH
 match access-group name SDM_AH
class-map type inspect match-any SDM_ESP
 match access-group name SDM_ESP
!
pseudowire-class l2tp1
 encapsulation l2tpv3
 ip local interface Tunnel1
!
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp policy 2
 encr aes 256
 authentication pre-share
 group 5
crypto isakmp key sdfsdf address 1.1.1.1
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
crypto isakmp key sdfsdf address 1.1.1.1 no-xauth
!
!
crypto ipsec transform-set aes256sh esp-aes 256 esp-sha-hmac
!
crypto map spb 1 ipsec-isakmp
 set peer 1.1.1.1
 set peer 1.1.1.1
 set security-association lifetime seconds 28800
 set transform-set aes256sh
 set pfs group2
 match address 103
crypto map spb 2 ipsec-isakmp
 description Tunnel to dme
 set peer 1.1.1.1
 set peer 1.1.1.1
 set security-association lifetime seconds 28800
 set transform-set aes256sh
 set pfs group2
 match address 104
crypto map spb 3 ipsec-isakmp
 description KRZN
 set peer 1.1.1.1
 set peer 1.1.1.1
 set peer 1.1.1.1
 set transform-set aes256sh
 set pfs group2
 match address 105
crypto map spb 4 ipsec-isakmp
 description gema
 set peer 1.1.1.1
 set peer 1.1.1.1
 set peer 1.1.1.1
 set peer 1.1.1.1
 set transform-set aes256sh
 set pfs group2
 match address 106
crypto map spb 5 ipsec-isakmp
 description samara
 set peer 1.1.1.1
 set transform-set aes256sh
 set pfs group2
 match address 107
crypto map spb 6 ipsec-isakmp
 description leninsk
 set peer 11.1.1.1
 set transform-set aes256sh
 set pfs group2
 match address 108
!
!
!
!
!
!
interface Loopback1
 ip address 172.25.0.253 255.255.255.255
 !
!
interface Tunnel1
 ip address 172.16.54.2 255.255.255.0
 tunnel source 192.168.3.253
 tunnel destination 192.168.100.9
 !
!
interface GigabitEthernet0/0
 ip address 192.168.3.253 255.255.252.0
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
 no mop enabled
 !
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 no keepalive
 xconnect 172.16.54.1 10 encapsulation l2tpv3 pw-class l2tp1
 !
!
interface FastEthernet0/3/0
 !
!
interface FastEthernet0/3/1
 switchport access vlan 99
 !
!
interface FastEthernet0/3/2
 !
!
interface FastEthernet0/3/3
 switchport access vlan 10
 !
!
interface Serial0/0/0
 no ip address
 shutdown
 clock rate 2000000
 !
!
interface Serial0/2/0
 no ip address
 shutdown
 clock rate 2000000
 !
!
interface Serial0/2/1
 no ip address
 shutdown
 clock rate 2000000
 !
!
interface Vlan1
 no ip address
 shutdown
 !
!
interface Vlan10
 ip address 1.1.1.1 255.255.255.224
 ip access-group 161 in
 ip flow ingress
 ip flow egress
 ip policy route-map sklad
 crypto map spb
 !
!
interface Vlan99
 ip address 1.1.1.1 255.255.255.192
 ip access-group 161 in
 ip flow ingress
 ip flow egress
 ip nat outside
 ip virtual-reassembly
 ip policy route-map sklad
 crypto map spb
 !
!
router ospf 1
 router-id 172.25.0.253
 log-adjacency-changes
 redistribute static subnets
 network 192.168.0.0 0.0.3.255 area 0
!
router rip
 version 2
 network 192.168.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip flow-cache timeout active 1
ip flow-export version 5
ip flow-export destination 192.168.0.73 9996
ip flow-top-talkers
 top 10
 sort-by bytes
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1 120
ip route 0.0.0.0 0.0.0.0 1.1.1.1 180
ip route 10.10.100.0 255.255.255.0 1.1.1.1
ip route 10.20.10.0 255.255.255.0 1.1.1.1
ip route 10.20.20.0 255.255.255.0 1.1.1.1
ip route 10.20.30.0 255.255.255.0 1.1.1.1
ip route 192.168.11.0 255.255.255.0 1.1.1.1
ip route 192.168.15.0 255.255.255.0 1.1.1.1
ip route 192.168.100.0 255.255.255.0 1.1.1.1
!
ip access-list extended PBR_SKLAD
 deny   ip 10.0.0.0 0.255.255.255 192.168.0.0 0.0.255.255
 deny   ip 10.0.0.0 0.255.255.255 10.0.0.0 0.255.255.255
 permit ip 10.0.0.0 0.255.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 10.0.0.0 0.255.255.255
 deny   ip 192.168.0.0 0.0.255.255 192.168.0.0 0.0.255.255
 permit ip 192.168.0.0 0.0.255.255 any
!
access-list 22 permit 1.1.1.1
access-list 103 permit ip any 10.20.30.0 0.0.0.255
access-list 104 remark SDM_ACL Category=4
access-list 104 permit ip any 10.20.20.0 0.0.0.255
access-list 105 remark CCP_ACL Category=4
access-list 105 permit ip any 192.168.100.0 0.0.0.255
access-list 106 permit ip any 10.20.10.0 0.0.0.255
access-list 107 permit ip any 10.10.100.0 0.0.0.255
access-list 108 permit ip any 192.168.11.0 0.0.0.255
access-list 110 deny   tcp any host 192.168.100.3 eq 8014
access-list 110 permit ip any any
access-list 110 deny   ip host 192.168.0.110 host 192.168.100.3
access-list 160 permit ip any host 1.1.1.1
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit tcp any eq smtp host 1.1.1.1
access-list 161 permit tcp any eq 443 host 1.1.1.1
access-list 161 permit ip host 1.1.1.1 any
access-list 161 permit udp any eq domain host 1.1.1.1
access-list 161 permit tcp any eq domain host 1.1.1.1
access-list 161 permit udp any eq ntp host 1.1.1.1
access-list 161 permit tcp any host 1.1.1.1 eq smtp
access-list 161 permit icmp any any
access-list 180 permit ip any host 1.1.1.1
access-list 190 permit ip any any
!
!
!
!
route-map sklad permit 10
 match ip address PBR_SKLAD
 set ip next-hop 192.168.0.1
!
snmp-server community public RO
!
!
control-plane
 !
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0 4
 exec-timeout 60 0
 privilege level 15
 password  nbmnm,jhkhjk
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server 192.168.0.7 source GigabitEthernet0/0
end

 

I am still not clear with the problem that you are facing. 

router rip
 version 2
 network 192.168.0.0

 

This is your RIP config. GigabitEthernet0/0 is the interface configured in this network range. So it will try to discover RIP neighbors through that interface. Can you please confirm if the other end of Gi0/0 is configured with the IP add 182.168.3.254. Also, the other end needs to configured with RIP.

 

CF

Router isr2821 is not send rip packets.  I see wareshark and i see rip packet on other router. 

RIP assumes a classful mask when you enter a network in the RIP configuration and 192.168.x.0 networks use a 255.255.255.0 mask.

You have told RIP to run on any interface with an IP in the 192.168.0.1 - 254 range.

But your interface IP is 192.168.3.254 so it won't run on that.

You need to change your RIP configuration ie.

remove 192.168.0.0

and add -

192.168.3.0

you should also check the other router as well.

Jon

Good catch Jon..Missed that..Bad eyes.. :(

CF

Cool! Thank you.